diff mbox series

Added support for package flatbuffers.

Message ID HE1PR0402MB362873CDF66343E07F2D6FB6F96E0@HE1PR0402MB3628.eurprd04.prod.outlook.com
State Superseded
Headers show
Series Added support for package flatbuffers. | expand

Commit Message

Erik Tideman Sept. 13, 2017, 8:08 a.m. UTC

Comments

Arnout Vandecappelle Sept. 13, 2017, 9:35 p.m. UTC | #1
Hi Erik,

 Thanks a lot for your contribution! It's great to see new people using
Buildroot and contributing to it.

 However, in order to ease the review process, we like to receive patches inline
and not as attachments. Indeed, this allows us to simply hit "reply" and comment
on each part of the patch. This is a very typical review process used in the
open-source community. In order to send patches inline, we recommend you to use
"git send-email" as e-mail clients very often rewrap text and therefore make
patches unusable.

 From a quick look to your patch, here are a few comments:

- The patch title should be "flatbuffers: new package".

- Please add yourself to the DEVELOPERS file for this package, to indicate that
you're willing to fix things when they break.

- Please use utils/check-package to check the coding style. Indentation in
Config.in is not OK.

- Wrap FLATBUFFERS_CONF_OPTS, like:

FLATBUFFERS_CONF_OPTS += \
	-DCMAKE_CXX_FLAGS="-std=c++11" \
	-DFLATBUFFERS_BUILD_SHAREDLIB=TRUE \
	-DFLATBUFFERS_BUILD_TESTS=FALSE

(indent with 1 tab).

- You pass -DFLATBUFFERS_BUILD_SHAREDLIB=TRUE, so either it doesn't support
BR2_STATIC_LIBS, or you should supply the proper option based on
BR2_STATIC_LIBS. See e.g. rabbitmq-c.


 Could you look into those comments, and send an updated version of your
contribution, using git send-email ?

 Thanks!
 Regards,
 Arnout


[Thomas, thank you for this template text :-) ]
Erik Tideman Sept. 18, 2017, 9:28 a.m. UTC | #2
Hi,


Thanks for the feedback, I will look into it.




Best regards Erik.
diff mbox series

Patch

From ea2a983b3414871402c9f19a814788b74444091e Mon Sep 17 00:00:00 2001
From: Erik Tideman <erik.tideman@faltcom.se>
Date: Tue, 29 Aug 2017 09:46:49 +0200
Subject: [PATCH] Added support for package flatbuffers.

Signed-off-by: Erik Tideman <erik.tideman@faltcom.se>
---
 package/Config.in                    |  1 +
 package/flatbuffers/Config.in        | 12 ++++++++++++
 package/flatbuffers/flatbuffers.hash |  3 +++
 package/flatbuffers/flatbuffers.mk   | 15 +++++++++++++++
 4 files changed, 31 insertions(+)
 create mode 100644 package/flatbuffers/Config.in
 create mode 100644 package/flatbuffers/flatbuffers.hash
 create mode 100644 package/flatbuffers/flatbuffers.mk

diff --git a/package/Config.in b/package/Config.in
index a0868d9..a208e1c 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1402,6 +1402,7 @@  menu "Other"
 	source "package/elfutils/Config.in"
 	source "package/fftw/Config.in"
 	source "package/flann/Config.in"
+	source "package/flatbuffers/Config.in"
 	source "package/gflags/Config.in"
 	source "package/glibmm/Config.in"
 	source "package/glm/Config.in"
diff --git a/package/flatbuffers/Config.in b/package/flatbuffers/Config.in
new file mode 100644
index 0000000..7483ab4
--- /dev/null
+++ b/package/flatbuffers/Config.in
@@ -0,0 +1,12 @@ 
+config BR2_PACKAGE_FLATBUFFERS
+	bool "flatbuffers"
+    depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 # C++11
+	depends on BR2_INSTALL_LIBSTDCPP
+	help
+      FlatBuffers is an efficient cross platform serialization library for C++, C#, C, 
+      Go, Java, JavaScript, PHP, and Python. It was originally created at Google for 
+      game development and other performance-critical applications. It is available as 
+      Open Source on GitHub under the Apache license, v2 (see LICENSE.txt).
+
+      https://google.github.io/flatbuffers/index.html
+
diff --git a/package/flatbuffers/flatbuffers.hash b/package/flatbuffers/flatbuffers.hash
new file mode 100644
index 0000000..102f0a3
--- /dev/null
+++ b/package/flatbuffers/flatbuffers.hash
@@ -0,0 +1,3 @@ 
+# Locally calculated
+sha256 0f8dcdcfbbaba034756f97e4f9946a3784399b578f1b60c8deee3c85fafa3089  flatbuffers-v1.7.1.tar.gz
+
diff --git a/package/flatbuffers/flatbuffers.mk b/package/flatbuffers/flatbuffers.mk
new file mode 100644
index 0000000..f96e51b
--- /dev/null
+++ b/package/flatbuffers/flatbuffers.mk
@@ -0,0 +1,15 @@ 
+################################################################################
+#
+# flatbuffers
+#
+################################################################################
+
+FLATBUFFERS_VERSION = v1.7.1
+FLATBUFFERS_SITE = $(call github,google,flatbuffers,$(FLATBUFFERS_VERSION))
+FLATBUFFERS_LICENSE = Apache-2.0
+FLATBUFFERS_LICENSE_FILES = COPYING
+FLATBUFFERS_INSTALL_STAGING = YES
+
+FLATBUFFERS_CONF_OPTS += -DCMAKE_CXX_FLAGS="-std=c++11" -DFLATBUFFERS_BUILD_SHAREDLIB=TRUE -DFLATBUFFERS_BUILD_TESTS=FALSE
+
+$(eval $(cmake-package))
-- 
2.7.4