diff mbox series

postgresql: add optional dependency on libxml2

Message ID AD312B93A689234094FC24F3B98DBF33437A1740@INNO-EX-2010.innovaphone.sifi
State Accepted
Headers show
Series postgresql: add optional dependency on libxml2 | expand

Commit Message

Thomas Ehrhardt July 27, 2018, 7:41 a.m. UTC
The postgresql package is now built with --with-libxml if BR2_PACKAGE_LIBXML2 is selected to allow the use of XML functions in postgresql.

Signed-off-by: Daniel Deterding <dde@innovaphone.com>
Signed-off-by: Thomas Ehrhardt <tehrhardt@innovaphone.com>
---
 package/postgresql/postgresql.mk | 8 ++++++++
 1 file changed, 8 insertions(+)

--
2.11.0

Comments

Arnout Vandecappelle July 28, 2018, 2:09 p.m. UTC | #1
On 27-07-18 09:41, Thomas Ehrhardt wrote:
> The postgresql package is now built with --with-libxml if BR2_PACKAGE_LIBXML2 is selected to allow the use of XML functions in postgresql.

 Please wrap commit message lines at 72 columns. vim does this by default.

> 
> Signed-off-by: Daniel Deterding <dde@innovaphone.com>
> Signed-off-by: Thomas Ehrhardt <tehrhardt@innovaphone.com>

 Since you haven't changed the author, I guess you are the primary author and
applied the patch to master.

 Regards,
 Arnout

> ---
>  package/postgresql/postgresql.mk | 8 ++++++++
>  1 file changed, 8 insertions(+)
> 
> diff --git a/package/postgresql/postgresql.mk b/package/postgresql/postgresql.mk
> index 94b3e60e59..0940873686 100644
> --- a/package/postgresql/postgresql.mk
> +++ b/package/postgresql/postgresql.mk
> @@ -70,6 +70,14 @@ else
>  POSTGRESQL_CONF_OPTS += --without-ldap
>  endif
> 
> +ifeq ($(BR2_PACKAGE_LIBXML2),y)
> +POSTGRESQL_DEPENDENCIES += libxml2
> +POSTGRESQL_CONF_OPTS += --with-libxml
> +POSTGRESQL_CONF_ENV += XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config
> +else
> +POSTGRESQL_CONF_OPTS += --without-libxml
> +endif
> +
>  define POSTGRESQL_USERS
>         postgres -1 postgres -1 * /var/lib/pgsql /bin/sh - PostgreSQL Server
>  endef
> --
> 2.11.0
> 
> _______________________________________________________________________________
> 
> Thomas Ehrhardt | Development
> _______________________________________________________________________________
> 
> innovaphone AG
> PURE IP COMMUNICATIONS
> 
> B?blinger Stra?e 76 | 71065 Sindelfingen | Germany
> Tel: +49(7031)73009-648 | Fax: +49(7031)73009-9
> E-Mail: tehrhardt@innovaphone.com | http://www.innovaphone.com
> 
> [Sitz der Gesellschaft: Sindelfingen | HRB Nr. 245196 Amtsgericht Stuttgart | Vorstand: Dagmar Geer (Vorsitzende), Carsten Bode, Guntram Diehl, Gerd Hornig | Vorsitzender des Aufsichtsrates: Gebhard Michel]
> 
> 
> Campaign - https://www.youtube.com/user/innovaphoneTV
> [X]
> 
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
diff mbox series

Patch

diff --git a/package/postgresql/postgresql.mk b/package/postgresql/postgresql.mk
index 94b3e60e59..0940873686 100644
--- a/package/postgresql/postgresql.mk
+++ b/package/postgresql/postgresql.mk
@@ -70,6 +70,14 @@  else
 POSTGRESQL_CONF_OPTS += --without-ldap
 endif

+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+POSTGRESQL_DEPENDENCIES += libxml2
+POSTGRESQL_CONF_OPTS += --with-libxml
+POSTGRESQL_CONF_ENV += XML2_CONFIG=$(STAGING_DIR)/usr/bin/xml2-config
+else
+POSTGRESQL_CONF_OPTS += --without-libxml
+endif
+
 define POSTGRESQL_USERS
        postgres -1 postgres -1 * /var/lib/pgsql /bin/sh - PostgreSQL Server
 endef