diff mbox series

opkg-utils binaries did not installed with make install-utils

Message ID A79A145F-0D4E-40BC-9B67-889333FCDCF7@superbox.one
State Changes Requested
Headers show
Series opkg-utils binaries did not installed with make install-utils | expand

Commit Message

Michael Hacker April 19, 2023, 3:22 a.m. UTC
There seems to be something wrong in the opkg-utils.mk. install-utils does not run correctly and some tools are missing, e.g. opkg-utils.

I have a patch for it and after that everything is installed correctly:

+++ b/buildroot/package/opkg-utils/opkg-utils.mk
@@ -16.7 +16.7 @@ HOST_OPKG_UTILS_DEPENDENCIES = \
 host-xz

 # Nothing to build; only scripts to install.
-define OPKG_UTILS_INSTALL_CMDS
+define OPKG_UTILS_INSTALL_TARGET_CMDS
 $(MAKE) -C $(@D) PREFIX=$(TARGET_DIR) install-utils
 endef

Michael Hacker

Comments

Yann E. MORIN April 23, 2023, 1:05 p.m. UTC | #1
Michael, All,

On 2023-04-19 05:22 +0200, Michael Hacker spake thusly:
> There seems to be something wrong in the opkg-utils.mk. install-utils does not run correctly and some tools are missing, e.g. opkg-utils.
> 
> I have a patch for it and after that everything is installed correctly:
> 
> diff --git a/package/opkg-utils/opkg-utils.mk b/package/opkg-utils/opkg-utils.mk
> index ad267c5c94..384a7323ee 100644
> --- a/buildroot/package/opkg-utils/opkg-utils.mk
> +++ b/buildroot/package/opkg-utils/opkg-utils.mk
> @@ -16.7 +16.7 @@ HOST_OPKG_UTILS_DEPENDENCIES = \
>  host-xz
> 
>  # Nothing to build; only scripts to install.
> -define OPKG_UTILS_INSTALL_CMDS
> +define OPKG_UTILS_INSTALL_TARGET_CMDS

Eh, good catch! ;-)

Can you please resend with a proper commit log, and your sign-off:

    package/opkg-utils: actually install to target

    Commit b9bf1c6535cb (package/opkg-utils: add opkg-utils as target
    pkg) mis-spelled the macro to install to target, most probably as a
    bad copy-paste from the host macro.

    Fix that.

    Signed-off-by: You Real Name <your-email>

Note that I could have tweaked the commit log, but I can't add the sob
line for you.

Regards,
Yann E. MORIN.

>  $(MAKE) -C $(@D) PREFIX=$(TARGET_DIR) install-utils
>  endef
> 
> Michael Hacker
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Yann E. MORIN April 23, 2023, 1:07 p.m. UTC | #2
Micheal, All,

On 2023-04-19 05:22 +0200, Michael Hacker spake thusly:
> There seems to be something wrong in the opkg-utils.mk. install-utils does not run correctly and some tools are missing, e.g. opkg-utils.
> 
> I have a patch for it and after that everything is installed correctly:
> 
> diff --git a/package/opkg-utils/opkg-utils.mk b/package/opkg-utils/opkg-utils.mk
> index ad267c5c94..384a7323ee 100644
> --- a/buildroot/package/opkg-utils/opkg-utils.mk
> +++ b/buildroot/package/opkg-utils/opkg-utils.mk
> @@ -16.7 +16.7 @@ HOST_OPKG_UTILS_DEPENDENCIES = \
>  host-xz
> 
>  # Nothing to build; only scripts to install.
> -define OPKG_UTILS_INSTALL_CMDS
> +define OPKG_UTILS_INSTALL_TARGET_CMDS
>  $(MAKE) -C $(@D) PREFIX=$(TARGET_DIR) install-utils
>  endef
> 
> Michael Hacker

Oh, by the way, your patch is badly mangled, see how patchwork caught
it:

https://patchwork.ozlabs.org/project/buildroot/patch/A79A145F-0D4E-40BC-9B67-889333FCDCF7@superbox.one/

Do commit your change in your git tree (possibly on a branch), and then
use git send-email to send the patch.

Regards,
Yann E. MORIN.

> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Sept. 30, 2023, 7:03 p.m. UTC | #3
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > Michael, All,
 > On 2023-04-19 05:22 +0200, Michael Hacker spake thusly:
 >> There seems to be something wrong in the
 >> opkg-utils.mk. install-utils does not run correctly and some tools
 >> are missing, e.g. opkg-utils.
 >> 
 >> I have a patch for it and after that everything is installed correctly:
 >> 
 >> diff --git a/package/opkg-utils/opkg-utils.mk b/package/opkg-utils/opkg-utils.mk
 >> index ad267c5c94..384a7323ee 100644
 >> --- a/buildroot/package/opkg-utils/opkg-utils.mk
 >> +++ b/buildroot/package/opkg-utils/opkg-utils.mk
 >> @@ -16.7 +16.7 @@ HOST_OPKG_UTILS_DEPENDENCIES = \
 >> host-xz
 >> 
 >> # Nothing to build; only scripts to install.
 >> -define OPKG_UTILS_INSTALL_CMDS
 >> +define OPKG_UTILS_INSTALL_TARGET_CMDS

 > Eh, good catch! ;-)

 > Can you please resend with a proper commit log, and your sign-off:

 >     package/opkg-utils: actually install to target

 >     Commit b9bf1c6535cb (package/opkg-utils: add opkg-utils as target
 >     pkg) mis-spelled the macro to install to target, most probably as a
 >     bad copy-paste from the host macro.

 >     Fix that.

 >     Signed-off-by: You Real Name <your-email>

That never happened, so I've pushed a fix myself.
diff mbox series

Patch

diff --git a/package/opkg-utils/opkg-utils.mk b/package/opkg-utils/opkg-utils.mk
index ad267c5c94..384a7323ee 100644
--- a/buildroot/package/opkg-utils/opkg-utils.mk