diff mbox series

[2/2] iproute2: fix configure output file name

Message ID 8ee7fc92d5c3a7a0b04202d7f4c8043cd32e3724.1513547304.git.baruch@tkos.co.il
State Accepted
Headers show
Series [1/2] iproute2: fix build with threads support disabled | expand

Commit Message

Baruch Siach Dec. 17, 2017, 9:48 p.m. UTC
iproute2 renamed the configure script output file to config.mk. Update
the config tweaking code accordingly.

The configure script now detects xtables correctly, drop this part.

Add a comment to explain the TC_CONFIG_XT disable tweak.

Cc: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/iproute2/iproute2.mk | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

Comments

Petr Vorel Dec. 17, 2017, 10 p.m. UTC | #1
> iproute2 renamed the configure script output file to config.mk. Update
> the config tweaking code accordingly.

> The configure script now detects xtables correctly, drop this part.

> Add a comment to explain the TC_CONFIG_XT disable tweak.

> Cc: Petr Vorel <petr.vorel@gmail.com>
> Signed-off-by: Baruch Siach <baruch@tkos.co.il>
> ---
Acked-by: Petr Vorel <petr.vorel@gmail.com>
diff mbox series

Patch

diff --git a/package/iproute2/iproute2.mk b/package/iproute2/iproute2.mk
index c01917dffef0..15bb132c5001 100644
--- a/package/iproute2/iproute2.mk
+++ b/package/iproute2/iproute2.mk
@@ -31,9 +31,8 @@  define IPROUTE2_WITH_IPTABLES
 endef
 else
 define IPROUTE2_WITH_IPTABLES
-	# em_ipset needs xtables, but configure misdetects it
-	echo "TC_CONFIG_IPSET:=n" >>$(@D)/Config
-	echo "TC_CONFIG_XT:=n" >>$(@D)/Config
+	# m_xt.so is built unconditionally
+	echo "TC_CONFIG_XT:=n" >>$(@D)/config.mk
 endef
 endif