diff mbox

[1,of,4] i2c-tools: add license information

Message ID 8d5a6b127c579be29db4.1381226815@argentina
State Superseded
Headers show

Commit Message

Thomas De Schampheleire Oct. 8, 2013, 10:06 a.m. UTC
Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

---
 package/i2c-tools/i2c-tools.mk |  2 ++
 1 files changed, 2 insertions(+), 0 deletions(-)

Comments

Arnout Vandecappelle Oct. 8, 2013, 7:08 p.m. UTC | #1
On 10/08/13 12:06, Thomas De Schampheleire wrote:
> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
>
> ---
>   package/i2c-tools/i2c-tools.mk |  2 ++
>   1 files changed, 2 insertions(+), 0 deletions(-)
>
> diff --git a/package/i2c-tools/i2c-tools.mk b/package/i2c-tools/i2c-tools.mk
> --- a/package/i2c-tools/i2c-tools.mk
> +++ b/package/i2c-tools/i2c-tools.mk
> @@ -7,6 +7,8 @@
>   I2C_TOOLS_VERSION = 3.1.0
>   I2C_TOOLS_SOURCE = i2c-tools-$(I2C_TOOLS_VERSION).tar.bz2
>   I2C_TOOLS_SITE = http://dl.lm-sensors.org/i2c-tools/releases
> +I2C_TOOLS_LICENSE = GPLv2

  All files are GPLv2+ AFAICS. Only py-smbus/setup.py claims that the 
package is GPLv2, but that's just wrong.

  Regards,
  Arnout

> +I2C_TOOLS_LICENSE_FILES = COPYING
>
>   define I2C_TOOLS_BUILD_CMDS
>    $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
>
Thomas De Schampheleire Oct. 8, 2013, 8:22 p.m. UTC | #2
Arnout Vandecappelle <arnout@mind.be> wrote:
>On 10/08/13 12:06, Thomas De Schampheleire wrote:
>> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
>>
>> ---
>>   package/i2c-tools/i2c-tools.mk |  2 ++
>>   1 files changed, 2 insertions(+), 0 deletions(-)
>>
>> diff --git a/package/i2c-tools/i2c-tools.mk b/package/i2c-tools/i2c-tools.mk
>> --- a/package/i2c-tools/i2c-tools.mk
>> +++ b/package/i2c-tools/i2c-tools.mk
>> @@ -7,6 +7,8 @@
>>   I2C_TOOLS_VERSION = 3.1.0
>>   I2C_TOOLS_SOURCE = i2c-tools-$(I2C_TOOLS_VERSION).tar.bz2
>>   I2C_TOOLS_SITE = http://dl.lm-sensors.org/i2c-tools/releases
>> +I2C_TOOLS_LICENSE = GPLv2
>
>  All files are GPLv2+ AFAICS. Only py-smbus/setup.py claims that the 
>package is GPLv2, but that's just wrong.

Why is that wrong?

I reasoned that if one of the components is gplv2, and the rest is gplv2+, then the whole needs to be gplv2.

Best regards,
Thomas
Arnout Vandecappelle Oct. 8, 2013, 8:32 p.m. UTC | #3
On 10/08/13 22:22, Thomas De Schampheleire wrote:
> Arnout Vandecappelle <arnout@mind.be> wrote:
>> On 10/08/13 12:06, Thomas De Schampheleire wrote:
>>> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
>>>
>>> ---
>>>    package/i2c-tools/i2c-tools.mk |  2 ++
>>>    1 files changed, 2 insertions(+), 0 deletions(-)
>>>
>>> diff --git a/package/i2c-tools/i2c-tools.mk b/package/i2c-tools/i2c-tools.mk
>>> --- a/package/i2c-tools/i2c-tools.mk
>>> +++ b/package/i2c-tools/i2c-tools.mk
>>> @@ -7,6 +7,8 @@
>>>    I2C_TOOLS_VERSION = 3.1.0
>>>    I2C_TOOLS_SOURCE = i2c-tools-$(I2C_TOOLS_VERSION).tar.bz2
>>>    I2C_TOOLS_SITE = http://dl.lm-sensors.org/i2c-tools/releases
>>> +I2C_TOOLS_LICENSE = GPLv2
>>
>>   All files are GPLv2+ AFAICS. Only py-smbus/setup.py claims that the
>> package is GPLv2, but that's just wrong.
>
> Why is that wrong?
>
> I reasoned that if one of the components is gplv2, and the rest is gplv2+, then the whole needs to be gplv2.

  setup.py itself isn't GPLv2, it just claims that the package is GPLv2. 
But it isn't, since each file says it GPLv2+.

  Scratch that: the python module is GPLv2 only. But I don't think we 
build the python module anyway. Just to be safe, put:

I2C_TOOLS_LICENSE = GPLv2+, GPLv2 (py-smbus)

  Regards,
  Arnout
diff mbox

Patch

diff --git a/package/i2c-tools/i2c-tools.mk b/package/i2c-tools/i2c-tools.mk
--- a/package/i2c-tools/i2c-tools.mk
+++ b/package/i2c-tools/i2c-tools.mk
@@ -7,6 +7,8 @@ 
 I2C_TOOLS_VERSION = 3.1.0
 I2C_TOOLS_SOURCE = i2c-tools-$(I2C_TOOLS_VERSION).tar.bz2
 I2C_TOOLS_SITE = http://dl.lm-sensors.org/i2c-tools/releases
+I2C_TOOLS_LICENSE = GPLv2
+I2C_TOOLS_LICENSE_FILES = COPYING
 
 define I2C_TOOLS_BUILD_CMDS
  $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)