diff mbox

[7,of,7] mkpasswd: change version from 'undefined' to 'buildroot-$(BR2_VERSION)'

Message ID 752fa92b51b8ef9eeaec.1399822731@argentina
State Superseded
Headers show

Commit Message

Thomas De Schampheleire May 11, 2014, 3:38 p.m. UTC
The sources of the mkpasswd package are shipped with Buildroot, rather than
downloaded from an external location. As a result, no explicit version is
defined, causing build messages and build directory to show 'undefined' as
version.

This patch sets the version for mkpasswd to 'buildroot-$(BR2_VERSION), which
would for example expand to 'buildroot-2014.05'.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

---
 package/mkpasswd/mkpasswd.mk |  2 ++
 1 files changed, 2 insertions(+), 0 deletions(-)

Comments

Yann E. MORIN May 11, 2014, 9:04 p.m. UTC | #1
Thomas, All,

On 2014-05-11 17:38 +0200, Thomas De Schampheleire spake thusly:
> The sources of the mkpasswd package are shipped with Buildroot, rather than
> downloaded from an external location. As a result, no explicit version is
> defined, causing build messages and build directory to show 'undefined' as
> version.
> 
> This patch sets the version for mkpasswd to 'buildroot-$(BR2_VERSION), which
> would for example expand to 'buildroot-2014.05'.
> 
> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>

Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  package/mkpasswd/mkpasswd.mk |  2 ++
>  1 files changed, 2 insertions(+), 0 deletions(-)
> 
> diff --git a/package/mkpasswd/mkpasswd.mk b/package/mkpasswd/mkpasswd.mk
> --- a/package/mkpasswd/mkpasswd.mk
> +++ b/package/mkpasswd/mkpasswd.mk
> @@ -10,6 +10,8 @@
>  HOST_MKPASSWD_SOURCE =
>  HOST_MKPASSWD_LICENSE = GPLv2+
>  
> +HOST_MKPASSWD_VERSION = buildroot-$(BR2_VERSION)
> +
>  define HOST_MKPASSWD_BUILD_CMDS
>  	$(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) \
>  		package/mkpasswd/mkpasswd.c package/mkpasswd/utils.c \
diff mbox

Patch

diff --git a/package/mkpasswd/mkpasswd.mk b/package/mkpasswd/mkpasswd.mk
--- a/package/mkpasswd/mkpasswd.mk
+++ b/package/mkpasswd/mkpasswd.mk
@@ -10,6 +10,8 @@ 
 HOST_MKPASSWD_SOURCE =
 HOST_MKPASSWD_LICENSE = GPLv2+
 
+HOST_MKPASSWD_VERSION = buildroot-$(BR2_VERSION)
+
 define HOST_MKPASSWD_BUILD_CMDS
 	$(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) \
 		package/mkpasswd/mkpasswd.c package/mkpasswd/utils.c \