diff mbox series

uboot-tools: force host CFLAGS

Message ID 6c246971096ed5ace6c35e3102ca0649025c19fa.1533879441.git.baruch@tkos.co.il
State Accepted
Commit 03a808a0999ac031a1e93000d9a3c50ffbcb64a4
Headers show
Series uboot-tools: force host CFLAGS | expand

Commit Message

Baruch Siach Aug. 10, 2018, 5:37 a.m. UTC
U-Boot now adds -std=gnu11 when building its build utilities, like
fixdep. This option is only supported since gcc version 4.7.

  https://gcc.gnu.org/gcc-4.7/changes.html

Force usage of Buildroot HOST_CFLAGS, like we do already for
host-uboot-tools, to avoid the -std=gnu11 option.

Fixes:
http://autobuild.buildroot.net/results/ea0/ea09b614a3c10d494939d9551c0c3bfca4626ece/
http://autobuild.buildroot.net/results/f8e/f8efd9af4d86c51fe4f5afe44db9abf9adc5718f/
http://autobuild.buildroot.net/results/c0a/c0ab35c3cb46f84863fe20c0ee92ecc2379578b6/

Cc: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/uboot-tools/uboot-tools.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Peter Korsgaard Aug. 10, 2018, 8:34 a.m. UTC | #1
>>>>> "Baruch" == Baruch Siach <baruch@tkos.co.il> writes:

 > U-Boot now adds -std=gnu11 when building its build utilities, like
 > fixdep. This option is only supported since gcc version 4.7.

 >   https://gcc.gnu.org/gcc-4.7/changes.html

 > Force usage of Buildroot HOST_CFLAGS, like we do already for
 > host-uboot-tools, to avoid the -std=gnu11 option.

 > Fixes:
 > http://autobuild.buildroot.net/results/ea0/ea09b614a3c10d494939d9551c0c3bfca4626ece/
 > http://autobuild.buildroot.net/results/f8e/f8efd9af4d86c51fe4f5afe44db9abf9adc5718f/
 > http://autobuild.buildroot.net/results/c0a/c0ab35c3cb46f84863fe20c0ee92ecc2379578b6/

 > Cc: Matt Weber <matthew.weber@rockwellcollins.com>
 > Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Ahh, nice - Committed, thanks.
Peter Korsgaard Aug. 24, 2018, 7:38 a.m. UTC | #2
>>>>> "Baruch" == Baruch Siach <baruch@tkos.co.il> writes:

 > U-Boot now adds -std=gnu11 when building its build utilities, like
 > fixdep. This option is only supported since gcc version 4.7.

 >   https://gcc.gnu.org/gcc-4.7/changes.html

 > Force usage of Buildroot HOST_CFLAGS, like we do already for
 > host-uboot-tools, to avoid the -std=gnu11 option.

 > Fixes:
 > http://autobuild.buildroot.net/results/ea0/ea09b614a3c10d494939d9551c0c3bfca4626ece/
 > http://autobuild.buildroot.net/results/f8e/f8efd9af4d86c51fe4f5afe44db9abf9adc5718f/
 > http://autobuild.buildroot.net/results/c0a/c0ab35c3cb46f84863fe20c0ee92ecc2379578b6/

 > Cc: Matt Weber <matthew.weber@rockwellcollins.com>
 > Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Committed to 2018.02.x and 2018.05.x, thanks.
diff mbox series

Patch

diff --git a/package/uboot-tools/uboot-tools.mk b/package/uboot-tools/uboot-tools.mk
index f5027d2da390..5ac7b1c29399 100644
--- a/package/uboot-tools/uboot-tools.mk
+++ b/package/uboot-tools/uboot-tools.mk
@@ -19,6 +19,7 @@  endef
 UBOOT_TOOLS_MAKE_OPTS = CROSS_COMPILE="$(TARGET_CROSS)" \
 	CFLAGS="$(TARGET_CFLAGS)" \
 	LDFLAGS="$(TARGET_LDFLAGS)" \
+	HOSTCFLAGS="$(HOST_CFLAGS)" \
 	STRIP=$(TARGET_STRIP)
 
 ifeq ($(BR2_PACKAGE_UBOOT_TOOLS_FIT_SUPPORT),y)