diff mbox series

[2/9] support/dependencies: make git a mandatory dependency

Message ID 678f73c0753eb09e05301df347c75928b4444f26.1702742998.git.yann.morin.1998@free.fr
State Changes Requested
Headers show
Series support/docker: improve and extend our docker image (branch yem/dockers) | expand

Commit Message

Yann E. MORIN Dec. 16, 2023, 4:09 p.m. UTC
Currently, we only require wget as a download tool. However, git is very
pervasive and used in many of the packages, making it a de facto
requirement.

Act on that situation and promote git from an optional dependency to a
mandatory dependency.

Reported-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
---
 docs/manual/prerequisite.adoc        | 2 +-
 package/pkg-generic.mk               | 8 --------
 support/dependencies/dependencies.sh | 2 +-
 3 files changed, 2 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/docs/manual/prerequisite.adoc b/docs/manual/prerequisite.adoc
index 262a5153f5..6f07cba551 100644
--- a/docs/manual/prerequisite.adoc
+++ b/docs/manual/prerequisite.adoc
@@ -41,6 +41,7 @@  between distributions).
 
 * Source fetching tools:
 ** +wget+
+** +git+
 
 [[requirement-optional]]
 
@@ -76,7 +77,6 @@  corresponding tool on the host system:
 +
 ** +bazaar+
 ** +cvs+
-** +git+
 ** +mercurial+
 ** +scp+
 ** +sftp+
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 577a148c1e..87931f09c1 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -1240,7 +1240,6 @@  endif
 ifeq ($$($(2)_SITE_METHOD),svn)
 DL_TOOLS_DEPENDENCIES += svn
 else ifeq ($$($(2)_SITE_METHOD),git)
-DL_TOOLS_DEPENDENCIES += git
 ifneq ($$($(2)_GIT_LFS),)
 DL_TOOLS_DEPENDENCIES += git-lfs
 endif
@@ -1254,13 +1253,6 @@  else ifeq ($$($(2)_SITE_METHOD),cvs)
 DL_TOOLS_DEPENDENCIES += cvs
 endif # SITE_METHOD
 
-# cargo/go vendoring (may) need git
-ifeq ($$($(2)_DOWNLOAD_POST_PROCESS),cargo)
-DL_TOOLS_DEPENDENCIES += git
-else ifeq ($$($(2)_DOWNLOAD_POST_PROCESS),go)
-DL_TOOLS_DEPENDENCIES += git
-endif
-
 DL_TOOLS_DEPENDENCIES += $$(call extractor-system-dependency,$$($(2)_SOURCE))
 
 # Ensure all virtual targets are PHONY. Listed alphabetically.
diff --git a/support/dependencies/dependencies.sh b/support/dependencies/dependencies.sh
index 6e7d067ccd..e18e799922 100755
--- a/support/dependencies/dependencies.sh
+++ b/support/dependencies/dependencies.sh
@@ -154,7 +154,7 @@  fi
 
 # Check that a few mandatory programs are installed
 missing_progs="no"
-for prog in perl tar wget cpio unzip rsync bc cmp find xargs ${DL_TOOLS} ; do
+for prog in perl tar wget git cpio unzip rsync bc cmp find xargs ${DL_TOOLS} ; do
 	if ! which $prog > /dev/null ; then
 		echo "You must install '$prog' on your build machine";
 		missing_progs="yes"