diff mbox series

[49/50,v2] package/busybox: add dependency on attr

Message ID 5b94111a961b4f18589aa5b5dbc71fc71289e448.1531043163.git.yann.morin.1998@free.fr
State Accepted
Headers show
Series [01/50,v2] package/busybox: update to 1.29.0 | expand

Commit Message

Yann E. MORIN July 8, 2018, 9:46 a.m. UTC
attr and busybox may each install setfattr, so attr must be installed
before busybox.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
 package/busybox/busybox.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Arnout Vandecappelle July 8, 2018, 11:09 a.m. UTC | #1
On 08-07-18 11:46, Yann E. MORIN wrote:
> attr and busybox may each install setfattr, so attr must be installed
> before busybox.

 bzip2 is in a similar situation, and probably more.

 Regards,
 Arnout

> 
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> ---
>  package/busybox/busybox.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
> index 0a9af9f17b..5266f844b6 100644
> --- a/package/busybox/busybox.mk
> +++ b/package/busybox/busybox.mk
> @@ -22,6 +22,7 @@ BUSYBOX_LDFLAGS = \
>  
>  # Packages that provide commands that may also be busybox applets:
>  BUSYBOX_DEPENDENCIES = \
> +	$(if $(BR2_PACKAGE_ATTR),attr) \
>  	$(if $(BR2_PACKAGE_BASH),bash) \
>  	$(if $(BR2_PACKAGE_BC),bc) \
>  	$(if $(BR2_PACKAGE_BINUTILS),binutils) \
>
Yann E. MORIN July 8, 2018, 12:35 p.m. UTC | #2
Arnout, All,

On 2018-07-08 13:09 +0200, Arnout Vandecappelle spake thusly:
> On 08-07-18 11:46, Yann E. MORIN wrote:
> > attr and busybox may each install setfattr, so attr must be installed
> > before busybox.
>  bzip2 is in a similar situation, and probably more.

Sure, but I took care only of attr because we had a bug about it, not
for the others.

Regards,
Yann E. MORIN.
diff mbox series

Patch

diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 0a9af9f17b..5266f844b6 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -22,6 +22,7 @@  BUSYBOX_LDFLAGS = \
 
 # Packages that provide commands that may also be busybox applets:
 BUSYBOX_DEPENDENCIES = \
+	$(if $(BR2_PACKAGE_ATTR),attr) \
 	$(if $(BR2_PACKAGE_BASH),bash) \
 	$(if $(BR2_PACKAGE_BC),bc) \
 	$(if $(BR2_PACKAGE_BINUTILS),binutils) \