diff mbox series

[1/1] package/linux-firmware: fix build failure when no firmware item selected

Message ID 539abc1b8ea48daa694b45242cab63d0@umbiko.net
State Accepted
Headers show
Series [1/1] package/linux-firmware: fix build failure when no firmware item selected | expand

Commit Message

Andreas Ziegler March 9, 2021, 6:25 p.m. UTC
The latest change in Linux firmware handling breaks the build if no 
specific firmware item is selected below BR2_PACKAGE_LINUX_FIRMWARE.

The firmware archive is only created if at least one firmware 
sub-category is selected; the installation step wants to unpack the 
archive unconditionally.

Use the same condition to control install command definition as in the 
build step.

Signed-off-by: Andreas Ziegler <br015@umbiko.net>

         mkdir -p $(1)
         $(TAR) xf $(@D)/br-firmware.tar -C $(1)
@@ -695,5 +696,6 @@ endef
  define LINUX_FIRMWARE_INSTALL_IMAGES_CMDS
         $(call LINUX_FIRMWARE_INSTALL_FW, $(BINARIES_DIR))
  endef
+endif # LINUX_FIRMWARE_FILES || LINUX_FIRMWARE_DIRS

  $(eval $(generic-package))

Comments

Yann E. MORIN March 9, 2021, 8:07 p.m. UTC | #1
Andreas, All,

On 2021-03-09 18:25 +0000, Andreas Ziegler spake thusly:
> The latest change in Linux firmware handling breaks the build if no specific
> firmware item is selected below BR2_PACKAGE_LINUX_FIRMWARE.
> 
> The firmware archive is only created if at least one firmware sub-category
> is selected; the installation step wants to unpack the archive
> unconditionally.
> 
> Use the same condition to control install command definition as in the build
> step.
> 
> Signed-off-by: Andreas Ziegler <br015@umbiko.net>

Not sure why, but your patch ended up completely mangled on Patchwork:
    https://patchwork.ozlabs.org/project/buildroot/patch/539abc1b8ea48daa694b45242cab63d0@umbiko.net/

Anyway, I fixed it, and moved everything inside a single conditional
block, rather than triplicate the same condition in sequence.

Applied to master, thanks.

Regards,
Yann E. MORIN.

> diff --git a/package/linux-firmware/linux-firmware.mk
> b/package/linux-firmware/linux-firmware.mk
> index 5e92b0446e..5dfc4a657d 100644
> --- a/package/linux-firmware/linux-firmware.mk
> +++ b/package/linux-firmware/linux-firmware.mk
> @@ -675,6 +675,7 @@ endif
>  # sure we canonicalize the pointed-to file, to cover the symlinks of the
> form
>  # a/foo -> ../b/foo  where a/ (the directory where to put the symlink) does
>  # not yet exist.
> +ifneq ($(LINUX_FIRMWARE_FILES)$(LINUX_FIRMWARE_DIRS),)
>  define LINUX_FIRMWARE_INSTALL_FW
>         mkdir -p $(1)
>         $(TAR) xf $(@D)/br-firmware.tar -C $(1)
> @@ -695,5 +696,6 @@ endef
>  define LINUX_FIRMWARE_INSTALL_IMAGES_CMDS
>         $(call LINUX_FIRMWARE_INSTALL_FW, $(BINARIES_DIR))
>  endef
> +endif # LINUX_FIRMWARE_FILES || LINUX_FIRMWARE_DIRS
> 
>  $(eval $(generic-package))
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/linux-firmware/linux-firmware.mk 
b/package/linux-firmware/linux-firmware.mk
index 5e92b0446e..5dfc4a657d 100644
--- a/package/linux-firmware/linux-firmware.mk
+++ b/package/linux-firmware/linux-firmware.mk
@@ -675,6 +675,7 @@  endif
  # sure we canonicalize the pointed-to file, to cover the symlinks of 
the form
  # a/foo -> ../b/foo  where a/ (the directory where to put the symlink) 
does
  # not yet exist.
+ifneq ($(LINUX_FIRMWARE_FILES)$(LINUX_FIRMWARE_DIRS),)
  define LINUX_FIRMWARE_INSTALL_FW