diff mbox

kmod: install depmod to output/host/usr/sbin

Message ID 522F604C.1000206@gmail.com
State Superseded
Headers show

Commit Message

Ryan Coe Sept. 10, 2013, 6:09 p.m. UTC
After the move to kmod, building the Linux kernel no longer generates 
the module dependencies.  The Linux build process is looking for depmod 
at $(HOST_DIR)/usr/sbin/depmod.  Host-kmod is installing the symlink for 
depmod at $(HOST_DIR)/sbin/depmod. Attached is a patch to change the 
location of the depmod symlink for host-kmod.

Comments

Peter Korsgaard Sept. 10, 2013, 8:04 p.m. UTC | #1
>>>>> "Ryan" == Ryan Coe <bluemrp9@gmail.com> writes:

 Ryan> After the move to kmod, building the Linux kernel no longer generates
 Ryan> the module dependencies.  The Linux build process is looking for
 Ryan> depmod at $(HOST_DIR)/usr/sbin/depmod.  Host-kmod is installing the
 Ryan> symlink for depmod at $(HOST_DIR)/sbin/depmod. Attached is a patch to
 Ryan> change the location of the depmod symlink for host-kmod.

Thanks. I decided to change the reference in linux.mk instead.

Please consider sending a real git formatted (with Signed-off-by) patch
next time.
diff mbox

Patch

diff --git a/package/kmod/kmod.mk b/package/kmod/kmod.mk
index a1ad7d6..00b73d6 100644
--- a/package/kmod/kmod.mk
+++ b/package/kmod/kmod.mk
@@ -63,8 +63,8 @@  endif
 # We only install depmod, since that's the only tool used for the
 # host.
 define HOST_KMOD_INSTALL_TOOLS
-	mkdir -p $(HOST_DIR)/sbin/
-	ln -sf ../usr/bin/kmod $(HOST_DIR)/sbin/depmod
+	mkdir -p $(HOST_DIR)/usr/sbin/
+	ln -sf ../../usr/bin/kmod $(HOST_DIR)/usr/sbin/depmod
 endef
 
 HOST_KMOD_POST_INSTALL_HOOKS += HOST_KMOD_INSTALL_TOOLS