diff mbox

Fix xenomai build with Linaro toolchain

Message ID 50CA5162.8090304@wanadoo.fr
State Changes Requested
Headers show

Commit Message

Thierry Bultel Dec. 13, 2012, 10:06 p.m. UTC
This fixes the build with toolchains that have -mthumb by default
(Not supported by xenomai yet)


Signed-off-by: thierry.bultel@wanadoo.fr

Comments

Arnout Vandecappelle Dec. 13, 2012, 10:54 p.m. UTC | #1
On 13/12/12 23:06, Thierry Bultel wrote:
> This fixes the build with toolchains that have -mthumb by default
> (Not supported by xenomai yet)
>
>
> Signed-off-by: thierry.bultel@wanadoo.fr
> --- xenomai.mk 2012-12-13 22:48:05.841982812 +0100
> +++ xenomai.mk.orig 2012-12-13 23:01:13.473982051 +0100

  This won't apply with git am. Could you create the patch with
git send-email?

> @@ -24,6 +23,12 @@
>
> XENOMAI_CONF_OPT += --includedir=/usr/include/xenomai/
>
> +XENOMAI_CONF_ENV = \
> + CFLAGS="$(TARGET_CFLAGS) -marm"

  Wouldn't it be a good idea to make this conditional on BR2_arm? :-)

  I would also use XENOMAI_CONF_ENV +=, easier for the future.

> +
> +XENOMAI_MAKE_ENV = \
> + CFLAGS="$(TARGET_CFLAGS) -marm"

  Is this needed? Should be enough to do it in the CONF_ENV because
the CFLAGS are directly replaced in the Makefiles...


  Regards,
  Arnout

> +
> ifeq ($(BR2_HAVE_DEVFILES),)
> define XENOMAI_REMOVE_DEVFILES
> for i in xeno-config xeno-info wrap-link.sh ; do \
diff mbox

Patch

--- xenomai.mk	2012-12-13 22:48:05.841982812 +0100
+++ xenomai.mk.orig	2012-12-13 23:01:13.473982051 +0100
@@ -24,6 +23,12 @@ 

  XENOMAI_CONF_OPT += --includedir=/usr/include/xenomai/

+XENOMAI_CONF_ENV = \
+	CFLAGS="$(TARGET_CFLAGS) -marm"
+	
+XENOMAI_MAKE_ENV = \
+	CFLAGS="$(TARGET_CFLAGS) -marm"
+
  ifeq ($(BR2_HAVE_DEVFILES),)
  define XENOMAI_REMOVE_DEVFILES
  	for i in xeno-config xeno-info wrap-link.sh ; do \