diff mbox series

[2/2] pulseaudio: fix libsamplerate dependency

Message ID 3e746e6aac146ae876e51f832d4979b1de3c6eb0.1513785771.git.baruch@tkos.co.il
State Accepted
Commit 5b85c6a038cc210355d8d5715cdf6fa73d18e8ac
Headers show
Series [1/2] pulseaudio: normalize alsa-lib optional dependency | expand

Commit Message

Baruch Siach Dec. 20, 2017, 4:02 p.m. UTC
The (deprecated) libsamplerate support is not enabled unless
--enable-samplerate is passed to configure. Fix this.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/pulseaudio/pulseaudio.mk | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Dec. 20, 2017, 8:37 p.m. UTC | #1
>>>>> "Baruch" == Baruch Siach <baruch@tkos.co.il> writes:

 > The (deprecated) libsamplerate support is not enabled unless
 > --enable-samplerate is passed to configure. Fix this.

 > Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Committed, thanks.
Peter Korsgaard Dec. 27, 2017, 10:29 p.m. UTC | #2
>>>>> "Baruch" == Baruch Siach <baruch@tkos.co.il> writes:

 > The (deprecated) libsamplerate support is not enabled unless
 > --enable-samplerate is passed to configure. Fix this.

 > Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Committed to 2017.11.x, thanks.
diff mbox series

Patch

diff --git a/package/pulseaudio/pulseaudio.mk b/package/pulseaudio/pulseaudio.mk
index 3863557881e5..13fcec52a3b3 100644
--- a/package/pulseaudio/pulseaudio.mk
+++ b/package/pulseaudio/pulseaudio.mk
@@ -17,7 +17,6 @@  PULSEAUDIO_CONF_OPTS = \
 
 PULSEAUDIO_DEPENDENCIES = \
 	host-pkgconf libtool libsndfile speex host-intltool \
-	$(if $(BR2_PACKAGE_LIBSAMPLERATE),libsamplerate) \
 	$(if $(BR2_PACKAGE_LIBGLIB2),libglib2) \
 	$(if $(BR2_PACKAGE_AVAHI_DAEMON),avahi) \
 	$(if $(BR2_PACKAGE_DBUS),dbus) \
@@ -25,6 +24,13 @@  PULSEAUDIO_DEPENDENCIES = \
 	$(if $(BR2_PACKAGE_FFTW),fftw) \
 	$(if $(BR2_PACKAGE_SYSTEMD),systemd)
 
+ifeq ($(BR2_PACKAGE_LIBSAMPLERATE),y)
+PULSEAUDIO_CONF_OPTS += --enable-samplerate
+PULSEAUDIO_DEPENDENCIES += libsamplerate
+else
+PULSEAUDIO_CONF_OPTS += --disable-samplerate
+endif
+
 ifeq ($(BR2_PACKAGE_GDBM),y)
 PULSEAUDIO_CONF_OPTS += --with-database=gdbm
 PULSEAUDIO_DEPENDENCIES += gdbm