diff mbox series

[1/3] package/dvb-apps: fix build with some perl version

Message ID 3756298044e002e93aa851a58b8337e6f676c91a.1511779719.git.yann.morin.1998@free.fr
State Accepted
Headers show
Series [1/3] package/dvb-apps: fix build with some perl version | expand

Commit Message

Yann E. MORIN Nov. 27, 2017, 10:48 a.m. UTC
perl can't find a module that is located in the current directory,
so help it locate it.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Francois Perrad <francois.perrad@gadz.org>

---
Note: I have no idea why perl on my machine does not find that file,
while it does on all the autobuilders so far... I just assume that this
is a perl version issue, but I may very well be wrong. François ?
---
 package/dvb-apps/dvb-apps.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Baruch Siach Nov. 27, 2017, 11:39 a.m. UTC | #1
Hi Yann,

On Mon, Nov 27, 2017 at 11:48:54AM +0100, Yann E. MORIN wrote:
> perl can't find a module that is located in the current directory,
> so help it locate it.
> 
> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> Cc: Francois Perrad <francois.perrad@gadz.org>
> 
> ---
> Note: I have no idea why perl on my machine does not find that file,
> while it does on all the autobuilders so far... I just assume that this
> is a perl version issue, but I may very well be wrong. François ?

This might have something to do with the removal of current directory from 
@INC in Debian:

  https://lists.debian.org/debian-devel-announce/2016/08/msg00013.html

baruch

> ---
>  package/dvb-apps/dvb-apps.mk | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/package/dvb-apps/dvb-apps.mk b/package/dvb-apps/dvb-apps.mk
> index 8ba1501d5c..8aa4a29307 100644
> --- a/package/dvb-apps/dvb-apps.mk
> +++ b/package/dvb-apps/dvb-apps.mk
> @@ -15,6 +15,8 @@ DVB_APPS_DEPENDENCIES = libiconv
>  DVB_APPS_LDLIBS += -liconv
>  endif
>  
> +DVB_APPS_MAKE_OPTS = PERL5LIB=$(@D)/util/scan
> +
>  ifeq ($(BR2_STATIC_LIBS),y)
>  DVB_APPS_MAKE_OPTS += enable_shared=no
>  else ifeq ($(BR2_SHARED_LIBS),y)
Yann E. MORIN Nov. 27, 2017, 11:51 a.m. UTC | #2
Baruch, All,

On 2017-11-27 13:39 +0200, Baruch Siach spake thusly:
> On Mon, Nov 27, 2017 at 11:48:54AM +0100, Yann E. MORIN wrote:
> > perl can't find a module that is located in the current directory,
> > so help it locate it.
> > 
> > Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
> > Cc: Francois Perrad <francois.perrad@gadz.org>
> > 
> > ---
> > Note: I have no idea why perl on my machine does not find that file,
> > while it does on all the autobuilders so far... I just assume that this
> > is a perl version issue, but I may very well be wrong. François ?
> 
> This might have something to do with the removal of current directory from 
> @INC in Debian:
> 
>   https://lists.debian.org/debian-devel-announce/2016/08/msg00013.html

Wee! So I was not so insane after all! ;-)

Thanks! :-)

Regards,
Yann E. MORIN.

> baruch
> 
> > ---
> >  package/dvb-apps/dvb-apps.mk | 2 ++
> >  1 file changed, 2 insertions(+)
> > 
> > diff --git a/package/dvb-apps/dvb-apps.mk b/package/dvb-apps/dvb-apps.mk
> > index 8ba1501d5c..8aa4a29307 100644
> > --- a/package/dvb-apps/dvb-apps.mk
> > +++ b/package/dvb-apps/dvb-apps.mk
> > @@ -15,6 +15,8 @@ DVB_APPS_DEPENDENCIES = libiconv
> >  DVB_APPS_LDLIBS += -liconv
> >  endif
> >  
> > +DVB_APPS_MAKE_OPTS = PERL5LIB=$(@D)/util/scan
> > +
> >  ifeq ($(BR2_STATIC_LIBS),y)
> >  DVB_APPS_MAKE_OPTS += enable_shared=no
> >  else ifeq ($(BR2_SHARED_LIBS),y)
> 
> -- 
>      http://baruch.siach.name/blog/                  ~. .~   Tk Open Systems
> =}------------------------------------------------ooO--U--Ooo------------{=
>    - baruch@tkos.co.il - tel: +972.2.679.5364, http://www.tkos.co.il -
Peter Korsgaard Nov. 27, 2017, 10:53 p.m. UTC | #3
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > perl can't find a module that is located in the current directory,
 > so help it locate it.

 > Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
 > Cc: Francois Perrad <francois.perrad@gadz.org>

 > ---
 > Note: I have no idea why perl on my machine does not find that file,
 > while it does on all the autobuilders so far... I just assume that this
 > is a perl version issue, but I may very well be wrong. François ?

Committed to 2017.02.x and 2017.08.x, thanks.
diff mbox series

Patch

diff --git a/package/dvb-apps/dvb-apps.mk b/package/dvb-apps/dvb-apps.mk
index 8ba1501d5c..8aa4a29307 100644
--- a/package/dvb-apps/dvb-apps.mk
+++ b/package/dvb-apps/dvb-apps.mk
@@ -15,6 +15,8 @@  DVB_APPS_DEPENDENCIES = libiconv
 DVB_APPS_LDLIBS += -liconv
 endif
 
+DVB_APPS_MAKE_OPTS = PERL5LIB=$(@D)/util/scan
+
 ifeq ($(BR2_STATIC_LIBS),y)
 DVB_APPS_MAKE_OPTS += enable_shared=no
 else ifeq ($(BR2_SHARED_LIBS),y)