diff mbox series

package/busybox: drop empty configure command

Message ID 31287_1548765380_5C5048C4_31287_396_1_f8e0aabc-6c1f-4878-b75e-c8bbc4e1a17e@OPEXCLILM6F.corporate.adroot.infra.ftgroup
State Accepted
Commit 908a8b5a7fb5744c55adbe609dca991709b2181a
Headers show
Series package/busybox: drop empty configure command | expand

Commit Message

Yann E. MORIN Jan. 29, 2019, 12:36 p.m. UTC
Since commit 50dc350c65 (package/busybox: update to 1.29.0), we no
longer define the BUSYBOX_NOCLOBBER_INSTALL macro, so it expands to an
empty string, so we end up with no action in BUSYBOX_CONFIGURE_CMDS.

Drop BUSYBOX_CONFIGURE_CMDS now that it serves no purpose.

Signed-off-by: Yann MORIN <yann.morin@orange.com>
Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Adam Duskett <aduskett@gmail.com>
Cc: Carlos Santos <casantos@datacom.com.br>
---
 package/busybox/busybox.mk | 4 ----
 1 file changed, 4 deletions(-)

Comments

Peter Korsgaard Jan. 29, 2019, 3:33 p.m. UTC | #1
>>>>>   <yann.morin@orange.com> writes:

 > Since commit 50dc350c65 (package/busybox: update to 1.29.0), we no
 > longer define the BUSYBOX_NOCLOBBER_INSTALL macro, so it expands to an
 > empty string, so we end up with no action in BUSYBOX_CONFIGURE_CMDS.

 > Drop BUSYBOX_CONFIGURE_CMDS now that it serves no purpose.

 > Signed-off-by: Yann MORIN <yann.morin@orange.com>
 > Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
 > Cc: Adam Duskett <aduskett@gmail.com>
 > Cc: Carlos Santos <casantos@datacom.com.br>

Committed, thanks.
Peter Korsgaard Jan. 29, 2019, 3:37 p.m. UTC | #2
>>>>>   <yann.morin@orange.com> writes:

 > Since commit 50dc350c65 (package/busybox: update to 1.29.0), we no
 > longer define the BUSYBOX_NOCLOBBER_INSTALL macro, so it expands to an
 > empty string, so we end up with no action in BUSYBOX_CONFIGURE_CMDS.

 > Drop BUSYBOX_CONFIGURE_CMDS now that it serves no purpose.

 > Signed-off-by: Yann MORIN <yann.morin@orange.com>

FYI, your author name was not configured correctly (was your email
address):

remote:
remote: Refusing to update refs/heads/master:
remote:     fc9fd5a8780966970525b4da8313091a0f0bbc80..8cbcb445b951b3b9e19d7cde7253ec6ce61f06f6
remote:
remote: Author name is not set properly (needs to be first and last name, and it is 'yann.morin@orange.com' instead)

I've fixed that and committed, thanks.
Yann E. MORIN Jan. 30, 2019, 6 a.m. UTC | #3
Peter, All,

On 2019-01-29 16:37 +0100, Peter Korsgaard spake thusly:
> >>>>>   <yann.morin@orange.com> writes:
> 
>  > Since commit 50dc350c65 (package/busybox: update to 1.29.0), we no
>  > longer define the BUSYBOX_NOCLOBBER_INSTALL macro, so it expands to an
>  > empty string, so we end up with no action in BUSYBOX_CONFIGURE_CMDS.
> 
>  > Drop BUSYBOX_CONFIGURE_CMDS now that it serves no purpose.
> 
>  > Signed-off-by: Yann MORIN <yann.morin@orange.com>
> 
> FYI, your author name was not configured correctly (was your email
> address):

Yeah, I have no idea why that is, because here, my 'From' was really what
you'd expect:

    From: "Yann E. MORIN" <yann.morin@orange.com>

But it seems my intelligent mail server stripped it out... Let's see how
that one will fare...

> remote:
> remote: Refusing to update refs/heads/master:
> remote:     fc9fd5a8780966970525b4da8313091a0f0bbc80..8cbcb445b951b3b9e19d7cde7253ec6ce61f06f6
> remote:
> remote: Author name is not set properly (needs to be first and last name, and it is 'yann.morin@orange.com' instead)
> 
> I've fixed that and committed, thanks.

Thanks!

Regards,
Yann E. MORIN.
Peter Korsgaard Jan. 30, 2019, 7:39 a.m. UTC | #4
>>>>>   <yann.morin@orange.com> writes:

 > Peter, All,
 > On 2019-01-29 16:37 +0100, Peter Korsgaard spake thusly:
 >> >>>>>   <yann.morin@orange.com> writes:
 >> 
 >> > Since commit 50dc350c65 (package/busybox: update to 1.29.0), we no
 >> > longer define the BUSYBOX_NOCLOBBER_INSTALL macro, so it expands to an
 >> > empty string, so we end up with no action in BUSYBOX_CONFIGURE_CMDS.
 >> 
 >> > Drop BUSYBOX_CONFIGURE_CMDS now that it serves no purpose.
 >> 
 >> > Signed-off-by: Yann MORIN <yann.morin@orange.com>
 >> 
 >> FYI, your author name was not configured correctly (was your email
 >> address):

 > Yeah, I have no idea why that is, because here, my 'From' was really what
 > you'd expect:

 >     From: "Yann E. MORIN" <yann.morin@orange.com>

 > But it seems my intelligent mail server stripped it out... Let's see how
 > that one will fare...

Still the same ;)
diff mbox series

Patch

diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index bfcca6ed3e..5c5a8ea839 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -323,10 +323,6 @@  define BUSYBOX_KCONFIG_FIXUP_CMDS
 	$(BUSYBOX_SET_INDIVIDUAL_BINARIES)
 endef
 
-define BUSYBOX_CONFIGURE_CMDS
-	$(BUSYBOX_NOCLOBBER_INSTALL)
-endef
-
 define BUSYBOX_BUILD_CMDS
 	$(BUSYBOX_MAKE_ENV) $(MAKE) $(BUSYBOX_MAKE_OPTS) -C $(@D)
 endef