diff mbox series

libkrb5: disable rpath

Message ID 2d3716532e37e7fd57c930fcca6e4656ec7fa649.1526236679.git.baruch@tkos.co.il
State Accepted
Headers show
Series libkrb5: disable rpath | expand

Commit Message

Baruch Siach May 13, 2018, 6:37 p.m. UTC
The default rpath value for krb5 is /usr/lib. On some hosts this might
confuse the build time linker as it looks for target libraries in the
host /usr/lib directory.

Should fix:
http://autobuild.buildroot.net/results/6df/6df84ed325ddd92248741d2f4737423b1b999489/
http://autobuild.buildroot.net/results/049/049f5147288b418402b6e5a4181eff4d426c8d7a/
http://autobuild.buildroot.net/results/432/432d5d0295f77cd34b78e70e8b4b7d77ef19ae3c/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
---
 package/libkrb5/libkrb5.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

André Zwing May 13, 2018, 6:59 p.m. UTC | #1
Am 13.05.2018 um 20:37 schrieb Baruch Siach:
> The default rpath value for krb5 is /usr/lib. On some hosts this might
> confuse the build time linker as it looks for target libraries in the
> host /usr/lib directory.
> 
> Should fix:
> http://autobuild.buildroot.net/results/6df/6df84ed325ddd92248741d2f4737423b1b999489/
> http://autobuild.buildroot.net/results/049/049f5147288b418402b6e5a4181eff4d426c8d7a/
> http://autobuild.buildroot.net/results/432/432d5d0295f77cd34b78e70e8b4b7d77ef19ae3c/
> 
> Signed-off-by: Baruch Siach <baruch@tkos.co.il>
> ---
>  package/libkrb5/libkrb5.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/libkrb5/libkrb5.mk b/package/libkrb5/libkrb5.mk
> index c40be632786b..d9d7160ae8d5 100644
> --- a/package/libkrb5/libkrb5.mk
> +++ b/package/libkrb5/libkrb5.mk
> @@ -28,7 +28,8 @@ LIBKRB5_CONF_OPTS = \
>  	--without-system-et \
>  	--without-system-ss \
>  	--without-system-verto \
> -	--without-tcl
> +	--without-tcl \
> +	--disable-rpath
>  
>  ifeq ($(BR2_PACKAGE_OPENLDAP),y)
>  LIBKRB5_CONF_OPTS += --with-ldap
> 

Thank you!
Sorry for not catching those myself, I just had no clue what was going on here and with the other failures.

Signed-off-by: André Hentschel <nerv@dawncrow.de>
Yann E. MORIN May 13, 2018, 7:11 p.m. UTC | #2
Baruch,

Added Matthew in Cc, as the failures only occur on hios autobuilder, as
I could see...

Matthew, not sure you saw my request on IRC: were you able to test the
same fix I shared on IRC?

On 2018-05-13 21:37 +0300, Baruch Siach spake thusly:
> The default rpath value for krb5 is /usr/lib. On some hosts this might
> confuse the build time linker as it looks for target libraries in the
> host /usr/lib directory.
> 
> Should fix:
> http://autobuild.buildroot.net/results/6df/6df84ed325ddd92248741d2f4737423b1b999489/
> http://autobuild.buildroot.net/results/049/049f5147288b418402b6e5a4181eff4d426c8d7a/
> http://autobuild.buildroot.net/results/432/432d5d0295f77cd34b78e70e8b4b7d77ef19ae3c/
> 
> Signed-off-by: Baruch Siach <baruch@tkos.co.il>

Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> ---
>  package/libkrb5/libkrb5.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/libkrb5/libkrb5.mk b/package/libkrb5/libkrb5.mk
> index c40be632786b..d9d7160ae8d5 100644
> --- a/package/libkrb5/libkrb5.mk
> +++ b/package/libkrb5/libkrb5.mk
> @@ -28,7 +28,8 @@ LIBKRB5_CONF_OPTS = \
>  	--without-system-et \
>  	--without-system-ss \
>  	--without-system-verto \
> -	--without-tcl
> +	--without-tcl \
> +	--disable-rpath
>  
>  ifeq ($(BR2_PACKAGE_OPENLDAP),y)
>  LIBKRB5_CONF_OPTS += --with-ldap
> -- 
> 2.17.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Yann E. MORIN May 13, 2018, 7:13 p.m. UTC | #3
André, All,

On 2018-05-13 20:59 +0200, André Hentschel spake thusly:
> Am 13.05.2018 um 20:37 schrieb Baruch Siach:
> > The default rpath value for krb5 is /usr/lib. On some hosts this might
> > confuse the build time linker as it looks for target libraries in the
> > host /usr/lib directory.
> > 
> > Should fix:
> > http://autobuild.buildroot.net/results/6df/6df84ed325ddd92248741d2f4737423b1b999489/
> > http://autobuild.buildroot.net/results/049/049f5147288b418402b6e5a4181eff4d426c8d7a/
> > http://autobuild.buildroot.net/results/432/432d5d0295f77cd34b78e70e8b4b7d77ef19ae3c/
> > 
> > Signed-off-by: Baruch Siach <baruch@tkos.co.il>
> > ---
> >  package/libkrb5/libkrb5.mk | 3 ++-
> >  1 file changed, 2 insertions(+), 1 deletion(-)
> > 
> > diff --git a/package/libkrb5/libkrb5.mk b/package/libkrb5/libkrb5.mk
> > index c40be632786b..d9d7160ae8d5 100644
> > --- a/package/libkrb5/libkrb5.mk
> > +++ b/package/libkrb5/libkrb5.mk
> > @@ -28,7 +28,8 @@ LIBKRB5_CONF_OPTS = \
> >  	--without-system-et \
> >  	--without-system-ss \
> >  	--without-system-verto \
> > -	--without-tcl
> > +	--without-tcl \
> > +	--disable-rpath
> >  
> >  ifeq ($(BR2_PACKAGE_OPENLDAP),y)
> >  LIBKRB5_CONF_OPTS += --with-ldap
> > 
> 
> Thank you!
> Sorry for not catching those myself, I just had no clue what was going on here and with the other failures.
> 
> Signed-off-by: André Hentschel <nerv@dawncrow.de>

"Signed-off-by" is when you are part of the submission chain, i.e. you
participated in the chain that goes from the author down to the one that
sends it on the mailing list.

If you agree with a patch, you can provide:

    Reviewed-by: you looked at the patch, it looks OK for you, but you
                 can't guarantee there so side effect;

    Acked-by: same as Reviewed-by, but you would commit it if you had
              commit rights;

    Tested-by: you actually tested the patch, and it behaves as expected.

Regards,
Yann E. MORIN.

> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni May 13, 2018, 7:39 p.m. UTC | #4
Hello,

On Sun, 13 May 2018 21:37:59 +0300, Baruch Siach wrote:
> The default rpath value for krb5 is /usr/lib. On some hosts this might
> confuse the build time linker as it looks for target libraries in the
> host /usr/lib directory.
> 
> Should fix:
> http://autobuild.buildroot.net/results/6df/6df84ed325ddd92248741d2f4737423b1b999489/
> http://autobuild.buildroot.net/results/049/049f5147288b418402b6e5a4181eff4d426c8d7a/
> http://autobuild.buildroot.net/results/432/432d5d0295f77cd34b78e70e8b4b7d77ef19ae3c/
> 
> Signed-off-by: Baruch Siach <baruch@tkos.co.il>
> ---
>  package/libkrb5/libkrb5.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/libkrb5/libkrb5.mk b/package/libkrb5/libkrb5.mk
index c40be632786b..d9d7160ae8d5 100644
--- a/package/libkrb5/libkrb5.mk
+++ b/package/libkrb5/libkrb5.mk
@@ -28,7 +28,8 @@  LIBKRB5_CONF_OPTS = \
 	--without-system-et \
 	--without-system-ss \
 	--without-system-verto \
-	--without-tcl
+	--without-tcl \
+	--disable-rpath
 
 ifeq ($(BR2_PACKAGE_OPENLDAP),y)
 LIBKRB5_CONF_OPTS += --with-ldap