diff mbox series

[5/5,v2] package/pkg-golang: host-go is also a build dependency

Message ID 25580_1644422947_6203E723_25580_17_1_a1a52ce7fd9920435f8cc9e82513d62f9badd738.1644422916.git.yann.morin@orange.com
State Changes Requested
Headers show
Series [1/5,v2] package/pkg-cargo: allow packages to define download environment | expand

Commit Message

Yann E. MORIN Feb. 9, 2022, 4:08 p.m. UTC
From: "Yann E. MORIN" <yann.morin@orange.com>

Currently, host-go is a download dependency, because we need go for the
vendoring during the downlaod step.

However, when using a package in override-srcdir, there is no download
step, so host-go is not pulled in as a dependency, which will break the
build of a single package from scratch.

We fix that by adding host-go as a standard dependency too.

Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Christian Stewart <christian@paral.in>
Cc: Anisse Astier <anisse@astier.eu>
---
 package/pkg-golang.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Feb. 9, 2022, 8:03 p.m. UTC | #1
On Wed, 9 Feb 2022 17:08:47 +0100
<yann.morin@orange.com> wrote:

> From: "Yann E. MORIN" <yann.morin@orange.com>
> 
> Currently, host-go is a download dependency, because we need go for the
> vendoring during the downlaod step.
> 
> However, when using a package in override-srcdir, there is no download
> step, so host-go is not pulled in as a dependency, which will break the
> build of a single package from scratch.
> 
> We fix that by adding host-go as a standard dependency too.
> 
> Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> Cc: Christian Stewart <christian@paral.in>
> Cc: Anisse Astier <anisse@astier.eu>

Acked-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Christian Stewart Feb. 9, 2022, 8:11 p.m. UTC | #2
On Wed, Feb 9, 2022 at 8:09 AM <yann.morin@orange.com> wrote:
>
> From: "Yann E. MORIN" <yann.morin@orange.com>
>
> Currently, host-go is a download dependency, because we need go for the
> vendoring during the downlaod step.
>
> However, when using a package in override-srcdir, there is no download
> step, so host-go is not pulled in as a dependency, which will break the
> build of a single package from scratch.
>
> We fix that by adding host-go as a standard dependency too.
>
> Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> Cc: Christian Stewart <christian@paral.in>
> Cc: Anisse Astier <anisse@astier.eu>
> ---
>  package/pkg-golang.mk | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/package/pkg-golang.mk b/package/pkg-golang.mk
> index 69eae02830..ddefdf1214 100644

Reviewed-by: Christian Stewart <christian@paral.in>

Best,
Christian
diff mbox series

Patch

diff --git a/package/pkg-golang.mk b/package/pkg-golang.mk
index 69eae02830..ddefdf1214 100644
--- a/package/pkg-golang.mk
+++ b/package/pkg-golang.mk
@@ -47,8 +47,10 @@  $(2)_BUILD_OPTS += \
 	-trimpath \
 	-p $(PARALLEL_JOBS)
 
-# Target packages need the Go compiler on the host.
+# Target packages need the Go compiler on the host at download time (for
+# vendoring), and at build and install time.
 $(2)_DOWNLOAD_DEPENDENCIES += host-go
+$(2)_DEPENDENCIES += host-go
 
 $(2)_BUILD_TARGETS ?= .