diff mbox series

package/pkg-golang: don't export unused BR_GOMOD

Message ID 22645_1646667795_62262813_22645_170_3_aabbdb8dc24868de9188190a6e1e7e1f1b6b12bc.1646667793.git.yann.morin@orange.com
State Accepted
Headers show
Series package/pkg-golang: don't export unused BR_GOMOD | expand

Commit Message

Yann E. MORIN March 7, 2022, 3:43 p.m. UTC
From: "Yann E. MORIN" <yann.morin@orange.com>

BR_GOMOD is a remnant from a previous iteration of the golang download
infrastructure; it is currently used nowhere.

Do not set it.

Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Anisse Astier <anisse@astier.eu>
Cc: Christian Stewart <christian@paral.in>
---
 package/pkg-golang.mk | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Christian Stewart March 7, 2022, 6:41 p.m. UTC | #1
Hi Yann,

On Mon, Mar 7, 2022 at 7:43 AM <yann.morin@orange.com> wrote:
>
> From: "Yann E. MORIN" <yann.morin@orange.com>
>
> BR_GOMOD is a remnant from a previous iteration of the golang download
> infrastructure; it is currently used nowhere.
>
> Do not set it.
>
> Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> Cc: Anisse Astier <anisse@astier.eu>
> Cc: Christian Stewart <christian@paral.in>
> ---
>  package/pkg-golang.mk | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff --git a/package/pkg-golang.mk b/package/pkg-golang.mk
> index f1c5cfd350..0cb2ed73cc 100644
> --- a/package/pkg-golang.mk
> +++ b/package/pkg-golang.mk
> @@ -87,8 +87,7 @@ $(2)_POST_PATCH_HOOKS += $(2)_GEN_GOMOD
>  $(2)_DOWNLOAD_POST_PROCESS = go
>  $(2)_DL_ENV += \
>         $$(HOST_GO_COMMON_ENV) \
> -       GOPROXY=direct \
> -       BR_GOMOD=$$($(2)_GOMOD)
> +       GOPROXY=direct

Reviewed-by: Christian Stewart <christian@paral.in>

Thanks,
Christian
Peter Korsgaard March 7, 2022, 8:39 p.m. UTC | #2
>>>>>   <yann.morin@orange.com> writes:

 > From: "Yann E. MORIN" <yann.morin@orange.com>
 > BR_GOMOD is a remnant from a previous iteration of the golang download
 > infrastructure; it is currently used nowhere.

 > Do not set it.

 > Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
 > Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 > Cc: Anisse Astier <anisse@astier.eu>
 > Cc: Christian Stewart <christian@paral.in>

Committed, thanks.
Peter Korsgaard March 7, 2022, 8:41 p.m. UTC | #3
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

>>>>>   <yann.morin@orange.com> writes:
 >> From: "Yann E. MORIN" <yann.morin@orange.com>
 >> BR_GOMOD is a remnant from a previous iteration of the golang download
 >> infrastructure; it is currently used nowhere.

 >> Do not set it.

 >> Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
 >> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 >> Cc: Anisse Astier <anisse@astier.eu>
 >> Cc: Christian Stewart <christian@paral.in>

 > Committed, thanks.

Ups, hold that - It doesn't apply to master as it is done on top of the
other pending golang fixes.
Peter Korsgaard March 7, 2022, 9:10 p.m. UTC | #4
>>>>>   <yann.morin@orange.com> writes:

 > From: "Yann E. MORIN" <yann.morin@orange.com>
 > BR_GOMOD is a remnant from a previous iteration of the golang download
 > infrastructure; it is currently used nowhere.

 > Do not set it.

 > Signed-off-by: Yann E. MORIN <yann.morin@orange.com>
 > Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 > Cc: Anisse Astier <anisse@astier.eu>
 > Cc: Christian Stewart <christian@paral.in>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/pkg-golang.mk b/package/pkg-golang.mk
index f1c5cfd350..0cb2ed73cc 100644
--- a/package/pkg-golang.mk
+++ b/package/pkg-golang.mk
@@ -87,8 +87,7 @@  $(2)_POST_PATCH_HOOKS += $(2)_GEN_GOMOD
 $(2)_DOWNLOAD_POST_PROCESS = go
 $(2)_DL_ENV += \
 	$$(HOST_GO_COMMON_ENV) \
-	GOPROXY=direct \
-	BR_GOMOD=$$($(2)_GOMOD)
+	GOPROXY=direct
 
 # Due to vendoring, it is pretty likely that not all licenses are
 # listed in <pkg>_LICENSE.