diff mbox series

package/checksec: fix download

Message ID 20241030212700.2517051-1-romain.naour@smile.fr
State Accepted
Headers show
Series package/checksec: fix download | expand

Commit Message

Romain Naour Oct. 30, 2024, 9:27 p.m. UTC
checksec-2.7.1.tar.gz archive was replaced or regenerated by upstream
sometime between the 22 September 2024 [1] and the 29 September 2024
[2].

diffoscope report no changes in extracted files exept a different
top directory name (checksec.sh-2.7.1/checksec-2.7.1):

  --- checksec-2.7.1.tar.gz a0d7a444d4603fb3d62fa25ef678e544ef39fa7b3c9bd5d22f1a8c526152cdde
  +++ checksec-2.7.1.tar.gz eba0616f4033385d6093608a2a2aad3c2debb847d6778c87346f89c80946684f

  Files identical despite different names
  --- checksec-2.7.1/ChangeLog
  +++ checksec.sh-2.7.1/ChangeLog

Use the git hash of the 2.7.1 release to use a different archive name
than the checksec-2.7.1.tar.gz archive previously released.

[1] https://gitlab.com/buildroot.org/buildroot/-/jobs/7888799855
[2] https://gitlab.com/buildroot.org/buildroot/-/jobs/7948006849

Fixes:
https://gitlab.com/buildroot.org/buildroot/-/jobs/7948006849

Signed-off-by: Romain Naour <romain.naour@smile.fr>
---
 package/checksec/checksec.hash | 2 +-
 package/checksec/checksec.mk   | 3 ++-
 2 files changed, 3 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Oct. 31, 2024, 12:51 p.m. UTC | #1
On Wed, 30 Oct 2024 22:27:00 +0100
Romain Naour via buildroot <buildroot@buildroot.org> wrote:

> checksec-2.7.1.tar.gz archive was replaced or regenerated by upstream
> sometime between the 22 September 2024 [1] and the 29 September 2024
> [2].
> 
> diffoscope report no changes in extracted files exept a different
> top directory name (checksec.sh-2.7.1/checksec-2.7.1):
> 
>   --- checksec-2.7.1.tar.gz a0d7a444d4603fb3d62fa25ef678e544ef39fa7b3c9bd5d22f1a8c526152cdde
>   +++ checksec-2.7.1.tar.gz eba0616f4033385d6093608a2a2aad3c2debb847d6778c87346f89c80946684f
> 
>   Files identical despite different names
>   --- checksec-2.7.1/ChangeLog
>   +++ checksec.sh-2.7.1/ChangeLog
> 
> Use the git hash of the 2.7.1 release to use a different archive name
> than the checksec-2.7.1.tar.gz archive previously released.
> 
> [1] https://gitlab.com/buildroot.org/buildroot/-/jobs/7888799855
> [2] https://gitlab.com/buildroot.org/buildroot/-/jobs/7948006849
> 
> Fixes:
> https://gitlab.com/buildroot.org/buildroot/-/jobs/7948006849
> 
> Signed-off-by: Romain Naour <romain.naour@smile.fr>
> ---
>  package/checksec/checksec.hash | 2 +-
>  package/checksec/checksec.mk   | 3 ++-
>  2 files changed, 3 insertions(+), 2 deletions(-)

Applied to master, thanks. However, I think the idea is to move away
from the github macro and use git downloads instead.

Thomas
diff mbox series

Patch

diff --git a/package/checksec/checksec.hash b/package/checksec/checksec.hash
index 856662b193..4ca3867114 100644
--- a/package/checksec/checksec.hash
+++ b/package/checksec/checksec.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  eba0616f4033385d6093608a2a2aad3c2debb847d6778c87346f89c80946684f  checksec-2.7.1.tar.gz
+sha256  59a351ac9b552a817329f2d2c1cd8ee76f6cf2ad8916e8eea56310154c0e31fc  checksec-181cdfa84893a5d72695944efabfa5b56687379c.tar.gz
 sha256  55154b4be6dfcb3ff29d1e3648d0d07b3943a5fcc3af7c2e0e799b074734f722  LICENSE.txt
diff --git a/package/checksec/checksec.mk b/package/checksec/checksec.mk
index c1170e822e..51a05c2a6b 100644
--- a/package/checksec/checksec.mk
+++ b/package/checksec/checksec.mk
@@ -4,7 +4,8 @@ 
 #
 ################################################################################
 
-CHECKSEC_VERSION = 2.7.1
+# git hash of 2.7.1 release.
+CHECKSEC_VERSION = 181cdfa84893a5d72695944efabfa5b56687379c
 CHECKSEC_SITE = $(call github,slimm609,checksec.sh,$(CHECKSEC_VERSION))
 CHECKSEC_LICENSE = BSD-3-Clause
 CHECKSEC_LICENSE_FILES = LICENSE.txt