diff mbox series

[1/1] package/parsec: new package

Message ID 20240721183223.2792367-1-kazemi.ms@gmail.com
State Changes Requested
Headers show
Series [1/1] package/parsec: new package | expand

Commit Message

Saeed Kazemi July 21, 2024, 6:32 p.m. UTC
Hardware/platform abstraction service for TPMs, HSMs, and Root of Trust

https://github.com/parallaxsecond/parsec.git

Signed-off-by: Saeed Kazemi <kazemi.ms@gmail.com>
---
 DEVELOPERS                                    |  1 +
 package/Config.in                             |  1 +
 ...pile-errors-with-latest-Rust-version.patch | 40 +++++++++++++++++++
 package/parsec/Config.in                      | 15 +++++++
 package/parsec/parsec.hash                    |  3 ++
 package/parsec/parsec.mk                      | 12 ++++++
 6 files changed, 72 insertions(+)
 create mode 100644 package/parsec/0001-Fix-compile-errors-with-latest-Rust-version.patch
 create mode 100644 package/parsec/Config.in
 create mode 100644 package/parsec/parsec.hash
 create mode 100644 package/parsec/parsec.mk

Comments

Thomas Petazzoni July 22, 2024, 12:13 p.m. UTC | #1
Hello Saaed,

On Sun, 21 Jul 2024 20:32:23 +0200
Saeed Kazemi <kazemi.ms@gmail.com> wrote:

> Hardware/platform abstraction service for TPMs, HSMs, and Root of Trust
> 
> https://github.com/parallaxsecond/parsec.git
> 
> Signed-off-by: Saeed Kazemi <kazemi.ms@gmail.com>

Thanks for this patch. Two questions below.

> +Subject: [PATCH] Fix compile errors with latest Rust version
> +
> +Upstream: N/A not applicable directly but based on:
> +https://github.com/parallaxsecond/parsec/commit/82320d345e08fe6310b684191151c78fc5648693

Why are you saying N/A (not applicable), if in fact your change is a
partial backport of an upstream commit? If it's a partial backport,
just state it so:

Upstream: partial backport
of https://github.com/parallaxsecond/parsec/commit/82320d345e08fe6310b684191151c78fc5648693

> +PARSEC_VERSION = 1.3.0

Why 1.3.0 and not 1.4.0 or 1.4.1 that contain the
82320d345e08fe6310b684191151c78fc5648693 fix already ?

Thanks,

Thomas
Saeed Kazemi July 23, 2024, 7:08 a.m. UTC | #2
Hello Thomas,

Indeed, fixed in a new patch.
In the github page the last release is 1.3.0, and I didn't notice there are
new tags.

Thanks,
Saeed

On Mon, Jul 22, 2024 at 2:13 PM Thomas Petazzoni <
thomas.petazzoni@bootlin.com> wrote:

> Hello Saaed,
>
> On Sun, 21 Jul 2024 20:32:23 +0200
> Saeed Kazemi <kazemi.ms@gmail.com> wrote:
>
> > Hardware/platform abstraction service for TPMs, HSMs, and Root of Trust
> >
> > https://github.com/parallaxsecond/parsec.git
> >
> > Signed-off-by: Saeed Kazemi <kazemi.ms@gmail.com>
>
> Thanks for this patch. Two questions below.
>
> > +Subject: [PATCH] Fix compile errors with latest Rust version
> > +
> > +Upstream: N/A not applicable directly but based on:
> > +
> https://github.com/parallaxsecond/parsec/commit/82320d345e08fe6310b684191151c78fc5648693
>
> Why are you saying N/A (not applicable), if in fact your change is a
> partial backport of an upstream commit? If it's a partial backport,
> just state it so:
>
> Upstream: partial backport
> of
> https://github.com/parallaxsecond/parsec/commit/82320d345e08fe6310b684191151c78fc5648693
>
> > +PARSEC_VERSION = 1.3.0
>
> Why 1.3.0 and not 1.4.0 or 1.4.1 that contain the
> 82320d345e08fe6310b684191151c78fc5648693 fix already ?
>
> Thanks,
>
> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering and training
> https://bootlin.com
>
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 333e26d74e..a072e8cb13 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -2862,6 +2862,7 @@  F:	package/biosdevname/
 
 N:	Saeed Kazemi <kazemi.ms@gmail.com>
 F:	package/eza/
+F:	package/parsec/
 F:	package/parsec-tool/
 F:	package/procs/
 F:	package/mxt-app/
diff --git a/package/Config.in b/package/Config.in
index a0d78518b6..8a7c257c85 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1589,6 +1589,7 @@  menu "Crypto"
 	source "package/mbedtls/Config.in"
 	source "package/nettle/Config.in"
 	source "package/openssl/Config.in"
+	source "package/parsec/Config.in"
 	source "package/parsec-tool/Config.in"
 	source "package/pkcs11-helper/Config.in"
 	source "package/rhash/Config.in"
diff --git a/package/parsec/0001-Fix-compile-errors-with-latest-Rust-version.patch b/package/parsec/0001-Fix-compile-errors-with-latest-Rust-version.patch
new file mode 100644
index 0000000000..9dcfefedae
--- /dev/null
+++ b/package/parsec/0001-Fix-compile-errors-with-latest-Rust-version.patch
@@ -0,0 +1,40 @@ 
+From e2ada92b71d8b70e0e771b469f48cc8a07ef11a5 Mon Sep 17 00:00:00 2001
+From: Saeed Kazemi <kazemi.ms@gmail.com>
+Date: Sun, 21 Jul 2024 18:46:38 +0200
+Subject: [PATCH] Fix compile errors with latest Rust version
+
+Upstream: N/A not applicable directly but based on:
+https://github.com/parallaxsecond/parsec/commit/82320d345e08fe6310b684191151c78fc5648693
+
+Signed-off-by: Saeed Kazemi <kazemi.ms@gmail.com>
+---
+ src/key_info_managers/on_disk_manager/mod.rs | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/key_info_managers/on_disk_manager/mod.rs b/src/key_info_managers/on_disk_manager/mod.rs
+index 717b93d..a4bf935 100644
+--- a/src/key_info_managers/on_disk_manager/mod.rs
++++ b/src/key_info_managers/on_disk_manager/mod.rs
+@@ -79,8 +79,8 @@ impl ApplicationName {
+ }
+ 
+ #[allow(deprecated)]
+-impl std::fmt::Display for ApplicationName {
+-    fn fmt(&self, f: &mut std::fmt::Formatter<'_>) -> std::fmt::Result {
++impl fmt::Display for ApplicationName {
++    fn fmt(&self, f: &mut fmt::Formatter<'_>) -> fmt::Result {
+         write!(f, "{}", self.name)
+     }
+ }
+@@ -489,7 +489,7 @@ impl OnDiskKeyInfoManager {
+             fs::remove_file(&key_name_file_path)?;
+         }
+ 
+-        let mut mapping_file = fs::File::create(&key_name_file_path).map_err(|e| {
++        let mut mapping_file = File::create(&key_name_file_path).map_err(|e| {
+             error!(
+                 "Failed to create Key Info Mapping file at {:?}",
+                 key_name_file_path
+-- 
+2.34.1
+
diff --git a/package/parsec/Config.in b/package/parsec/Config.in
new file mode 100644
index 0000000000..378e8b58b4
--- /dev/null
+++ b/package/parsec/Config.in
@@ -0,0 +1,15 @@ 
+config BR2_PACKAGE_PARSEC
+	bool "parsec"
+	depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS
+	select BR2_PACKAGE_HOST_RUSTC
+	help
+	  Hardware/platform abstraction service for TPMs, HSMs, and
+	  Root of Trust
+	  PARSEC is the Platform AbstRaction for SECurity, an
+	  open-source initiative to provide a common API to hardware
+	  security and cryptographic services in a platform-agnostic
+	  way. This abstraction layer keeps workloads decoupled from
+	  physical platform details, enabling cloud-native delivery
+	  flows within the data center and at the edge.
+
+	  https://github.com/parallaxsecond/parsec.git
diff --git a/package/parsec/parsec.hash b/package/parsec/parsec.hash
new file mode 100644
index 0000000000..f411a1cad5
--- /dev/null
+++ b/package/parsec/parsec.hash
@@ -0,0 +1,3 @@ 
+# Locally computed
+sha256  d9eaf0612bbe61475701ba3ef8ade40dae2da2d45366064748a7a2215aa060d1  parsec-1.3.0-cargo2.tar.gz
+sha256  cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30  LICENSE
diff --git a/package/parsec/parsec.mk b/package/parsec/parsec.mk
new file mode 100644
index 0000000000..fa8bf66172
--- /dev/null
+++ b/package/parsec/parsec.mk
@@ -0,0 +1,12 @@ 
+################################################################################
+#
+# parsec
+#
+################################################################################
+
+PARSEC_VERSION = 1.3.0
+PARSEC_SITE = $(call github,parallaxsecond,parsec,$(PARSEC_VERSION))
+PARSEC_LICENSE = Apache-2.0
+PARSEC_LICENSE_FILES = LICENSE
+
+$(eval $(cargo-package))