diff mbox series

[1/1] package/beecrypt: drop package

Message ID 20240616180742.4000901-1-fontaine.fabrice@gmail.com
State New
Headers show
Series [1/1] package/beecrypt: drop package | expand

Commit Message

Fabrice Fontaine June 16, 2024, 6:07 p.m. UTC
As advocated by Yann E. Morin [1], drop beecrypt as package is not
maintained anymore.

This will also avoid the following build failure with gcc 14:

blockmode.c: In function 'blockEncryptCTR':
blockmode.c:162:42: error: implicit declaration of function 'swapu32' [-Wimplicit-function-declaration]
  162 |                                 buf[i] = swapu32(fdback[j]);
      |                                          ^~~~~~~

[1] https://patchwork.ozlabs.org/project/buildroot/patch/20240615204233.3339310-1-fontaine.fabrice@gmail.com

Fixes:
 - http://autobuild.buildroot.org/results/651e0e31305b1f211071d94ea74f7b7a5793b03e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 .checkpackageignore                           |   3 -
 Config.in.legacy                              |   7 +
 package/Config.in                             |   1 -
 .../0001-cppglue.cxx-cplusplus-only.patch     |  28 ---
 package/beecrypt/0002-build-system.patch      | 173 ------------------
 ...3-don-t-check-for-cplusplus-compiler.patch |  27 ---
 package/beecrypt/Config.in                    |  10 -
 package/beecrypt/beecrypt.hash                |   3 -
 package/beecrypt/beecrypt.mk                  |  39 ----
 9 files changed, 7 insertions(+), 284 deletions(-)
 delete mode 100644 package/beecrypt/0001-cppglue.cxx-cplusplus-only.patch
 delete mode 100644 package/beecrypt/0002-build-system.patch
 delete mode 100644 package/beecrypt/0003-don-t-check-for-cplusplus-compiler.patch
 delete mode 100644 package/beecrypt/Config.in
 delete mode 100644 package/beecrypt/beecrypt.hash
 delete mode 100644 package/beecrypt/beecrypt.mk
diff mbox series

Patch

diff --git a/.checkpackageignore b/.checkpackageignore
index 7ff88cb837..441e0926bc 100644
--- a/.checkpackageignore
+++ b/.checkpackageignore
@@ -413,9 +413,6 @@  package/bctoolbox/0001-Fix-Libs.private-flags-for-mbedtls.patch lib_patch.Upstre
 package/bcusdk/0001-fd_set-requires-inclusion-of-sys-select.h.patch lib_patch.Upstream
 package/bcusdk/0002-eibd-fix-endless-recursion-when-using-USB-backends.patch lib_patch.Upstream
 package/bearssl/0001-Fix-missing-objdir-dependency.patch lib_patch.Upstream
-package/beecrypt/0001-cppglue.cxx-cplusplus-only.patch lib_patch.Upstream
-package/beecrypt/0002-build-system.patch lib_patch.Upstream
-package/beecrypt/0003-don-t-check-for-cplusplus-compiler.patch lib_patch.Upstream
 package/benejson/0001-c-std.patch lib_patch.Upstream
 package/benejson/0002-Use-print-as-a-function-for-Py3-compatibility.patch lib_patch.Upstream
 package/berkeleydb/0001-cwd-db_config.patch lib_patch.Upstream
diff --git a/Config.in.legacy b/Config.in.legacy
index 29c386bec4..697937fe47 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -146,6 +146,13 @@  endif
 
 comment "Legacy options removed in 2024.08"
 
+config BR2_PACKAGE_BEECRYPT
+	bool "beecrypt package removed"
+	select BR2_LEGACY
+	help
+	  The beecrypt package was removed as it is not maintained
+	  anymore (no release since 2015).
+
 config BR2_PACKAGE_VERSAL_FIRMWARE
 	bool "versal-firmware has been replaced by xilinx-prebuilt"
 	select BR2_TARGET_XILINX_PREBUILT
diff --git a/package/Config.in b/package/Config.in
index 2f332e96d5..d197320eed 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1538,7 +1538,6 @@  endmenu
 
 menu "Crypto"
 	source "package/bearssl/Config.in"
-	source "package/beecrypt/Config.in"
 	source "package/botan/Config.in"
 	source "package/ca-certificates/Config.in"
 	source "package/cryptodev-linux/Config.in"
diff --git a/package/beecrypt/0001-cppglue.cxx-cplusplus-only.patch b/package/beecrypt/0001-cppglue.cxx-cplusplus-only.patch
deleted file mode 100644
index 298e3eba93..0000000000
--- a/package/beecrypt/0001-cppglue.cxx-cplusplus-only.patch
+++ /dev/null
@@ -1,28 +0,0 @@ 
-Makefile.am: Only compile/link cppglue.cxx if --with-cplusplus is used
-
-Bloats libbeecrypt for no use and breaks build on systems without a C++
-compiler.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- Makefile.am |    7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-Index: beecrypt-4.2.1/Makefile.am
-===================================================================
---- beecrypt-4.2.1.orig/Makefile.am
-+++ beecrypt-4.2.1/Makefile.am
-@@ -62,7 +62,12 @@
- 
- lib_LTLIBRARIES = libbeecrypt.la
- 
--libbeecrypt_la_SOURCES = aes.c base64.c beecrypt.c blockmode.c blockpad.c blowfish.c dhies.c dldp.c dlkp.c dlpk.c dlsvdp-dh.c dsa.c elgamal.c endianness.c entropy.c fips186.c hmac.c hmacmd5.c hmacsha1.c hmacsha224.c hmacsha256.c md4.c md5.c hmacsha384.c hmacsha512.c memchunk.c mp.c mpbarrett.c mpnumber.c mpprime.c mtprng.c pkcs1.c pkcs12.c ripemd128.c ripemd160.c ripemd256.c ripemd320.c rsa.c rsakp.c rsapk.c sha1.c sha224.c sha256.c sha384.c sha512.c sha2k32.c sha2k64.c timestamp.c cppglue.cxx
-+libbeecrypt_la_SOURCES = aes.c base64.c beecrypt.c blockmode.c blockpad.c blowfish.c dhies.c dldp.c dlkp.c dlpk.c dlsvdp-dh.c dsa.c elgamal.c endianness.c entropy.c fips186.c hmac.c hmacmd5.c hmacsha1.c hmacsha224.c hmacsha256.c md4.c md5.c hmacsha384.c hmacsha512.c memchunk.c mp.c mpbarrett.c mpnumber.c mpprime.c mtprng.c pkcs1.c pkcs12.c ripemd128.c ripemd160.c ripemd256.c ripemd320.c rsa.c rsakp.c rsapk.c sha1.c sha224.c sha256.c sha384.c sha512.c sha2k32.c sha2k64.c timestamp.c
-+
-+if WITH_CPLUSPLUS
-+libbeecrypt_la_SOURCES += cppglue.cxx
-+endif
-+
- libbeecrypt_la_DEPENDENCIES = $(BEECRYPT_OBJECTS)
- libbeecrypt_la_LIBADD = blowfishopt.lo mpopt.lo sha1opt.lo $(OPENMP_LIBS)
- libbeecrypt_la_LDFLAGS = -no-undefined -version-info $(LIBBEECRYPT_LT_CURRENT):$(LIBBEECRYPT_LT_REVISION):$(LIBBEECRYPT_LT_AGE)
diff --git a/package/beecrypt/0002-build-system.patch b/package/beecrypt/0002-build-system.patch
deleted file mode 100644
index 05746899ef..0000000000
--- a/package/beecrypt/0002-build-system.patch
+++ /dev/null
@@ -1,173 +0,0 @@ 
-Fix build with BR2_ENABLE_DEBUG=yes, no need for expert mode anymore
-
-Otherwise configure issues this error message:
-configure: error: --enable-debug cannot be used in conjunction with --enable-expert-mode
-
-Downloaded from Gentoo:
-http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-libs/beecrypt/files/beecrypt-4.2.1-build-system.patch?revision=1.2&view=markup
-
-This patch also removes the hard-coded CFLAGS provided by beecrypt in favour
-of the CFLAGS provided by buildroot.
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
-
---- beecrypt-4.2.1/configure.ac
-+++ beecrypt-4.2.1/configure.ac
-@@ -11,7 +11,7 @@
- 
- # Checks for package options
- AC_ARG_ENABLE(expert-mode, [  --enable-expert-mode      follow user-defined CFLAGS settings [[default=no]]],[
--  ac_enable_expert_mode=yes
-+  ac_enable_expert_mode=$enableval
-   ],[
-   if test "X$CFLAGS" != "X"; then
-     echo "enabling expert mode"
-@@ -25,7 +25,7 @@
-   if test "$ac_enable_expert_mode" = yes; then
-     AC_MSG_ERROR([--enable-debug cannot be used in conjunction with --enable-expert-mode])
-   fi
--  ac_enable_debug=yes
-+  ac_enable_debug=$enableval
-   ],[
-   ac_enable_debug=no
-   ])
-@@ -456,7 +456,7 @@
-       ac_cv_python_include="-I`$PYTHON -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_inc()'`"
-     ])
-     AC_CACHE_CHECK([where to install python libraries], ac_cv_python_libdir, [
--      ac_cv_python_libdir=`$PYTHON -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib()'`
-+      ac_cv_python_libdir=`$PYTHON -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib(1, 0)'`
-     ])
-   fi
- fi
---- beecrypt-4.2.1/acinclude.m4
-+++ beecrypt-4.2.1/acinclude.m4
-@@ -498,15 +498,6 @@ AC_DEFUN([BEE_GNU_CC],[
-     AC_SUBST(OPENMP_LIBS,"-lgomp")
-   fi
-   case $bc_target_arch in
--  x86_64 | athlon64 | athlon-fx | k8 | opteron | em64t | nocona)
--    CC="$CC -m64"
--    ;;
--  i[[3456]]86 | \
--  pentium* | \
--  athlon*)
--    CC="$CC -m32"
--    CCAS="$CCAS -m32"
--    ;;
-   ia64)
-     case $target_os in
-     # HP/UX on Itanium needs to be told that a long is 64-bit!
-@@ -525,17 +516,8 @@ AC_DEFUN([BEE_GNU_CC],[
-     aix*)
-       CC="$CC -maix64"
-       ;;
--    linux*)
--      CC="$CC -m64"
--      ;;
-     esac
-     ;;
--  sparc | sparcv8*)
--    CC="$CC -m32"
--    ;;
--  sparc64 | sparcv9*)
--    CC="$CC -m64"
--    ;;
-   esac
-   # Certain platforms needs special flags for multi-threaded code
-   if test "$ac_enable_threads" = yes; then
-@@ -646,14 +646,6 @@ dnl  BEE_GNU_CXX
- AC_DEFUN([BEE_GNU_CXX],[
-   AC_REQUIRE([AC_PROG_CXX])
-   case $bc_target_arch in
--  x86_64 | athlon64 | athlon-fx | k8 | opteron | em64t | nocona | core2)
--    CXX="$CXX -m64"
--    ;;
--  i[[3456]]86 | \
--  pentium* | \
--  athlon*)
--    CXX="$CXX -m32"
--    ;;
-   ia64)
-     case $target_os in
-     # HP/UX on Itanium needs to be told that a long is 64-bit!
-@@ -672,17 +664,8 @@ AC_DEFUN([BEE_GNU_CXX],[
-     aix*)
-       CXX="$CXX -maix64"
-       ;;
--    linux*)
--      CXX="$CXX -m64"
--      ;;
-     esac
-     ;;
--  sparc | sparcv8*)
--    CXX="$CXX -m32"
--    ;;
--  sparc64 | sparcv9*)
--    CXX="$CXX -m64"
--    ;;
-   esac
-   # Certain platforms needs special flags for multi-threaded code
-   if test "$ac_enable_threads" = yes; then
---- beecrypt-4.2.1/java/Makefile.am
-+++ beecrypt-4.2.1/java/Makefile.am
-@@ -26,7 +26,7 @@
- 
- INCLUDES = -I$(top_srcdir)/include
- 
--libaltdir=$(prefix)/lib@LIBALT@
-+libaltdir=$(libdir)
- 
- libalt_LTLIBRARIES = libbeecrypt_java.la
- 
---- beecrypt-4.2.1/acinclude.m4
-+++ beecrypt-4.2.1/acinclude.m4
-@@ -1589,20 +1589,5 @@
-   AC_SUBST(TYPEDEF_BC_THREADID_T,$bc_typedef_bc_threadid_t)
-   ])
--
--AH_BOTTOM([
--#if ENABLE_THREADS
--# ifndef _REENTRANT
--#  define _REENTRANT
--# endif
--# if LINUX
--#  define _LIBC_REENTRANT
--# endif
--#else
--# ifdef _REENTRANT
--#  undef _REENTRANT
--# endif
--#endif
--])
- 
- 
- dnl  BEE_THREAD_LOCAL_STORAGE
-@@ -1623,7 +1609,5 @@
-   ])
- 
- AH_BOTTOM([
--#if !ENABLE_THREAD_LOCAL_STORAGE
--# define __thread
--#endif
-+#include "config.threads.h"
- ])
---- beecrypt-4.2.1/config.threads.h
-+++ beecrypt-4.2.1/config.threads.h
-@@ -0,0 +1,16 @@
-+#if ENABLE_THREADS
-+# ifndef _REENTRANT
-+#  define _REENTRANT
-+# endif
-+# if LINUX
-+#  define _LIBC_REENTRANT
-+# endif
-+#else
-+# ifdef _REENTRANT
-+#  undef _REENTRANT
-+# endif
-+#endif
-+
-+#if !ENABLE_THREAD_LOCAL_STORAGE
-+# define __thread
-+#endif
diff --git a/package/beecrypt/0003-don-t-check-for-cplusplus-compiler.patch b/package/beecrypt/0003-don-t-check-for-cplusplus-compiler.patch
deleted file mode 100644
index 32f167996f..0000000000
--- a/package/beecrypt/0003-don-t-check-for-cplusplus-compiler.patch
+++ /dev/null
@@ -1,27 +0,0 @@ 
-configure.ac: don't check for C++ compiler
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-
-diff -durN beecrypt-4.2.1-orig/configure.ac beecrypt-4.2.1/configure.ac
---- beecrypt-4.2.1-orig/configure.ac	2019-03-01 19:58:16.516117640 +0100
-+++ beecrypt-4.2.1/configure.ac	2019-03-01 21:10:17.707391803 +0100
-@@ -119,9 +119,6 @@
- 
- # Checks for C compiler and preprocessor
- AC_PROG_CC
--AC_PROG_CPP
--AC_PROG_CXX
--AC_PROG_CXXCPP
- AM_PROG_AS
- AC_PROG_LD
- AC_PROG_LN_S
-@@ -133,9 +130,6 @@
- AC_LANG_PUSH(C)
- AC_OPENMP
- AC_LANG_POP(C)
--AC_LANG_PUSH(C++)
--AC_OPENMP
--AC_LANG_POP(C++)
- 
- # Checks for compiler characteristics and flags
- if test "$ac_enable_expert_mode" = no; then
diff --git a/package/beecrypt/Config.in b/package/beecrypt/Config.in
deleted file mode 100644
index 9aec85afdb..0000000000
--- a/package/beecrypt/Config.in
+++ /dev/null
@@ -1,10 +0,0 @@ 
-comment "beecrypt needs a toolchain w/ threads"
-	depends on !BR2_TOOLCHAIN_HAS_THREADS
-
-config BR2_PACKAGE_BEECRYPT
-	bool "beecrypt"
-	depends on BR2_TOOLCHAIN_HAS_THREADS
-	help
-	  Beecrypt is a general-purpose cryptography library.
-
-	  http://beecrypt.sf.net
diff --git a/package/beecrypt/beecrypt.hash b/package/beecrypt/beecrypt.hash
deleted file mode 100644
index 2f84007b45..0000000000
--- a/package/beecrypt/beecrypt.hash
+++ /dev/null
@@ -1,3 +0,0 @@ 
-# Locally computed:
-sha256  286f1f56080d1a6b1d024003a5fa2158f4ff82cae0c6829d3c476a4b5898c55d  beecrypt-4.2.1.tar.gz
-sha256  512d2d21b6b3384ba64781abb0208a1b87740bc31e2df48e2b206ddb7e4d5779  COPYING.LIB
diff --git a/package/beecrypt/beecrypt.mk b/package/beecrypt/beecrypt.mk
deleted file mode 100644
index 20e1a122d0..0000000000
--- a/package/beecrypt/beecrypt.mk
+++ /dev/null
@@ -1,39 +0,0 @@ 
-################################################################################
-#
-# beecrypt
-#
-################################################################################
-
-BEECRYPT_VERSION = 4.2.1
-BEECRYPT_SITE = http://downloads.sourceforge.net/project/beecrypt/beecrypt/$(BEECRYPT_VERSION)
-BEECRYPT_AUTORECONF = YES
-BEECRYPT_INSTALL_STAGING = YES
-BEECRYPT_LICENSE = LGPL-2.1+
-BEECRYPT_LICENSE_FILES = COPYING.LIB
-BEECRYPT_CPE_ID_VALID = YES
-
-BEECRYPT_CONF_OPTS = \
-	--disable-expert-mode \
-	--without-java \
-	--without-python \
-	--disable-openmp \
-	--without-cplusplus
-
-# disable optimized m68k assembly as it doesn't compile for coldfire
-ifeq ($(BR2_m68k_cf),y)
-BEECRYPT_CONF_OPTS += --enable-debug
-endif
-
-# arm asm optimization doesn't work for thumb-only
-ifeq ($(BR2_arm):$(BR2_ARM_CPU_HAS_ARM),y:)
-BEECRYPT_CONF_OPTS += --enable-debug
-endif
-
-# automake/libtool uses the C++ compiler to link libbeecrypt because of
-# (the optional) cppglue.cxx. Force it to use the C compiler instead.
-define BEECRYPT_LINK_WITH_CC
-	$(SED) 's/--tag=CXX/--tag=CC/g' $(@D)/Makefile
-endef
-BEECRYPT_POST_CONFIGURE_HOOKS += BEECRYPT_LINK_WITH_CC
-
-$(eval $(autotools-package))