diff mbox series

package/ncftp: bump to version 3.2.7

Message ID 20240521134159.2268664-1-yegorslists@googlemail.com
State Changes Requested
Headers show
Series package/ncftp: bump to version 3.2.7 | expand

Commit Message

Frager, Neal via buildroot May 21, 2024, 1:41 p.m. UTC
From: Yegor Yefremov <yegorslists@googlemail.com>

Fix download location.

Remove already upstreamed patch.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
---
 package/ncftp/0001-fix-gcc-10.patch | 24 ------------------------
 package/ncftp/ncftp.hash            |  2 +-
 package/ncftp/ncftp.mk              |  4 ++--
 3 files changed, 3 insertions(+), 27 deletions(-)
 delete mode 100644 package/ncftp/0001-fix-gcc-10.patch

Comments

Peter Korsgaard May 31, 2024, 5:38 p.m. UTC | #1
>>>>> "yegorslists---" == yegorslists--- via buildroot <buildroot@buildroot.org> writes:

 > From: Yegor Yefremov <yegorslists@googlemail.com>
 > Fix download location.

Fix as in it wasn't working for 3.2.6 or just that it isn't available
for 3.2.7?

 > Remove already upstreamed patch.

 > Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
 > ---
 >  package/ncftp/0001-fix-gcc-10.patch | 24 ------------------------
 >  package/ncftp/ncftp.hash            |  2 +-
 >  package/ncftp/ncftp.mk              |  4 ++--
 >  3 files changed, 3 insertions(+), 27 deletions(-)
 >  delete mode 100644 package/ncftp/0001-fix-gcc-10.patch

 > diff --git a/package/ncftp/0001-fix-gcc-10.patch b/package/ncftp/0001-fix-gcc-10.patch

You forgot to remove it from .checkpackageignore as pointed out by
utils/check-package:

Applying: package/ncftp: bump to version 3.2.7
.checkpackageignore:1089: ignored file package/ncftp/0001-fix-gcc-10.patch is missing

 >  ################################################################################
 
 > -NCFTP_VERSION = 3.2.6
 > +NCFTP_VERSION = 3.2.7
 >  # use .gz as upstream .xz tarball has changed after the hash was added for
 >  # 2017.02. Can be changed back to .xz when version is bumped
 >  NCFTP_SOURCE = ncftp-$(NCFTP_VERSION)-src.tar.gz

How about that? How about using the .tar.xz?
diff mbox series

Patch

diff --git a/package/ncftp/0001-fix-gcc-10.patch b/package/ncftp/0001-fix-gcc-10.patch
deleted file mode 100644
index 8ff9c44c50..0000000000
--- a/package/ncftp/0001-fix-gcc-10.patch
+++ /dev/null
@@ -1,24 +0,0 @@ 
-Fix build with gcc 10
-
-Add missing extern to gBm to fix the following build failure with
--fno-common which is enabled by default with gcc 10:
-
-/usr/lfs/hdd_v1/rc-buildroot-test/scripts/instance-0/output-1/host/lib/gcc/arm-buildroot-linux-gnueabihf/10.2.0/../../../../arm-buildroot-linux-gnueabihf/bin/ld: bookmark.o:(.bss+0x10): multiple definition of `gBm'; gpshare.o:(.bss+0x24): first defined here
-
-Fixes:
- - http://autobuild.buildroot.org/results/78822bc0e0039e8f8949011a256cac022863276f
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-
-diff -Nura ncftp-3.2.6-orig/sh_util/gpshare.c ncftp-3.2.6/sh_util/gpshare.c
---- ncftp-3.2.6-orig/sh_util/gpshare.c	2020-08-21 10:46:34.173816750 +0200
-+++ ncftp-3.2.6/sh_util/gpshare.c	2020-08-21 10:52:25.407976319 +0200
-@@ -28,7 +28,7 @@
- 
- static int gIsAtty1 = 1, gIsAtty2 = 1;
- extern int gLoadedBm, gBookmarkMatchMode;
--Bookmark gBm;
-+extern Bookmark gBm;
- 
- double
- FileSize(double size, const char **uStr0, double *uMult0)
diff --git a/package/ncftp/ncftp.hash b/package/ncftp/ncftp.hash
index 3ab27df5cc..8766516ef8 100644
--- a/package/ncftp/ncftp.hash
+++ b/package/ncftp/ncftp.hash
@@ -1,3 +1,3 @@ 
 # Locally computed:
-sha256  129e5954850290da98af012559e6743de193de0012e972ff939df9b604f81c23  ncftp-3.2.6-src.tar.gz
+sha256  dbde0d3b4d28ba3a445621e10deaee57a6ba3ced277cc9dbce4052bcddf6cb2a  ncftp-3.2.7-src.tar.gz
 sha256  4fe2f063d25d79c49712a272ebb68e050c703eed9c66c80108427edfe3285580  doc/LICENSE.txt
diff --git a/package/ncftp/ncftp.mk b/package/ncftp/ncftp.mk
index 676a9c5895..37da898d5d 100644
--- a/package/ncftp/ncftp.mk
+++ b/package/ncftp/ncftp.mk
@@ -4,11 +4,11 @@ 
 #
 ################################################################################
 
-NCFTP_VERSION = 3.2.6
+NCFTP_VERSION = 3.2.7
 # use .gz as upstream .xz tarball has changed after the hash was added for
 # 2017.02. Can be changed back to .xz when version is bumped
 NCFTP_SOURCE = ncftp-$(NCFTP_VERSION)-src.tar.gz
-NCFTP_SITE = ftp://ftp.ncftp.com/ncftp
+NCFTP_SITE = https://www.ncftp.com/public_ftp/ncftp
 NCFTP_TARGET_BINS = ncftp
 NCFTP_LICENSE = Clarified Artistic License
 NCFTP_LICENSE_FILES = doc/LICENSE.txt