diff mbox series

package/libvncserver: correct WITH_THREADS=ON/OFF logic

Message ID 20240515145903.363218-1-peter@korsgaard.com
State Accepted
Headers show
Series package/libvncserver: correct WITH_THREADS=ON/OFF logic | expand

Commit Message

Peter Korsgaard May 15, 2024, 2:59 p.m. UTC
Commit ee59023794f5540e5 (package/libvncserver: bump to version 0.9.12)
changes the package from autotools to cmake and accidently inverted the
threads logic.

The reason this was not noticed is that the build system verifies if threads
support works and otherwise disables it even when -DWITH_THREADS=ON is
passed, E.G.  for a nothread configuration:

cmake ... -DWITH_THREADS=ON ...
..
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD - Failed
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - not found

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/libvncserver/libvncserver.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN May 17, 2024, 2:38 p.m. UTC | #1
Peter, All,

On 2024-05-15 16:59 +0200, Peter Korsgaard spake thusly:
> Commit ee59023794f5540e5 (package/libvncserver: bump to version 0.9.12)
> changes the package from autotools to cmake and accidently inverted the
> threads logic.
> 
> The reason this was not noticed is that the build system verifies if threads
> support works and otherwise disables it even when -DWITH_THREADS=ON is
> passed, E.G.  for a nothread configuration:
> 
> cmake ... -DWITH_THREADS=ON ...
> ..
> -- Performing Test CMAKE_HAVE_LIBC_PTHREAD
> -- Performing Test CMAKE_HAVE_LIBC_PTHREAD - Failed
> -- Looking for pthread_create in pthreads
> -- Looking for pthread_create in pthreads - not found
> -- Looking for pthread_create in pthread
> -- Looking for pthread_create in pthread - not found
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/libvncserver/libvncserver.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/libvncserver/libvncserver.mk b/package/libvncserver/libvncserver.mk
> index 3a15a82d08..082f838f12 100644
> --- a/package/libvncserver/libvncserver.mk
> +++ b/package/libvncserver/libvncserver.mk
> @@ -22,7 +22,7 @@ LIBVNCSERVER_CONF_OPTS += \
>  	-DWITH_SDL=OFF \
>  	-DWITH_TESTS=OFF
>  
> -ifneq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
> +ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
>  LIBVNCSERVER_CONF_OPTS += -DWITH_THREADS=ON
>  else
>  LIBVNCSERVER_CONF_OPTS += -DWITH_THREADS=OFF
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/libvncserver/libvncserver.mk b/package/libvncserver/libvncserver.mk
index 3a15a82d08..082f838f12 100644
--- a/package/libvncserver/libvncserver.mk
+++ b/package/libvncserver/libvncserver.mk
@@ -22,7 +22,7 @@  LIBVNCSERVER_CONF_OPTS += \
 	-DWITH_SDL=OFF \
 	-DWITH_TESTS=OFF
 
-ifneq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
 LIBVNCSERVER_CONF_OPTS += -DWITH_THREADS=ON
 else
 LIBVNCSERVER_CONF_OPTS += -DWITH_THREADS=OFF