diff mbox series

[v2,1/4] Config.in: do not expand TOPDIR, BASE_DIR and CONFIG_DIR

Message ID 20240513091950.30116-1-ps.report@gmx.net
State New
Headers show
Series [v2,1/4] Config.in: do not expand TOPDIR, BASE_DIR and CONFIG_DIR | expand

Commit Message

Peter Seiderer May 13, 2024, 9:19 a.m. UTC
- escape TOPDIR, BASE_DIR and CONFIG_DIR usage to force to not exapnd at
  configure time (but at make time), needed for upcoming kconfig update
  (see upstream commit [1])

[1] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=104daea149c45cc84842ce77a9bd6436d19f3dd8

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
Changes v1 -> v2:
  - new patch (moved escape fixes from 'support/kconfig: reference environment
    variables directly (remove 'option env=')' to this extra/preliminary patch)
---
 Config.in | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Peter Seiderer May 13, 2024, 10:11 p.m. UTC | #1
On Mon, 13 May 2024 11:19:45 +0200, Peter Seiderer via buildroot <buildroot@buildroot.org> wrote:

> - escape TOPDIR, BASE_DIR and CONFIG_DIR usage to force to not exapnd at
>   configure time (but at make time), needed for upcoming kconfig update
>   (see upstream commit [1])

Same is needed for 'ARCH' usage in toolchain/toolchain-external/toolchain-external-bootlin/Config.in.options
and toolchain/toolchain-external/toolchain-external-custom/Config.in.options (and
support/scripts/gen-bootlin-toolchains)..., additional patch will follow with
next patch set iteration...

Regards,
Peter


>
> [1] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=104daea149c45cc84842ce77a9bd6436d19f3dd8
>
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>
> ---
> Changes v1 -> v2:
>   - new patch (moved escape fixes from 'support/kconfig: reference environment
>     variables directly (remove 'option env=')' to this extra/preliminary patch)
> ---
>  Config.in | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/Config.in b/Config.in
> index b5a94325c4..035900c971 100644
> --- a/Config.in
> +++ b/Config.in
> @@ -197,7 +197,7 @@ config BR2_DEFCONFIG
>
>  config BR2_DL_DIR
>  	string "Download dir"
> -	default "$(TOPDIR)/dl"
> +	default "\$(TOPDIR)/dl"
>  	help
>  	  Directory to store all the source files that we need to fetch.
>  	  If the Linux shell environment has defined the BR2_DL_DIR
> @@ -211,7 +211,7 @@ config BR2_DL_DIR
>
>  config BR2_HOST_DIR
>  	string "Host dir"
> -	default "$(BASE_DIR)/host"
> +	default "\$(BASE_DIR)/host"
>  	help
>  	  Directory to store all the binary files that are built for the
>  	  host. This includes the cross compilation toolchain when
> @@ -669,7 +669,7 @@ endchoice
>
>  config BR2_PACKAGE_OVERRIDE_FILE
>  	string "location of a package override file"
> -	default "$(CONFIG_DIR)/local.mk"
> +	default "\$(CONFIG_DIR)/local.mk"
>  	help
>  	  A package override file is a short makefile that contains
>  	  variable definitions of the form <pkg>_OVERRIDE_SRCDIR, which
diff mbox series

Patch

diff --git a/Config.in b/Config.in
index b5a94325c4..035900c971 100644
--- a/Config.in
+++ b/Config.in
@@ -197,7 +197,7 @@  config BR2_DEFCONFIG
 
 config BR2_DL_DIR
 	string "Download dir"
-	default "$(TOPDIR)/dl"
+	default "\$(TOPDIR)/dl"
 	help
 	  Directory to store all the source files that we need to fetch.
 	  If the Linux shell environment has defined the BR2_DL_DIR
@@ -211,7 +211,7 @@  config BR2_DL_DIR
 
 config BR2_HOST_DIR
 	string "Host dir"
-	default "$(BASE_DIR)/host"
+	default "\$(BASE_DIR)/host"
 	help
 	  Directory to store all the binary files that are built for the
 	  host. This includes the cross compilation toolchain when
@@ -669,7 +669,7 @@  endchoice
 
 config BR2_PACKAGE_OVERRIDE_FILE
 	string "location of a package override file"
-	default "$(CONFIG_DIR)/local.mk"
+	default "\$(CONFIG_DIR)/local.mk"
 	help
 	  A package override file is a short makefile that contains
 	  variable definitions of the form <pkg>_OVERRIDE_SRCDIR, which