diff mbox series

[1/1] package/kodi: remove libatomic from linker flags

Message ID 20240512163159.999251-1-bernd@kuhls.net
State Accepted
Headers show
Series [1/1] package/kodi: remove libatomic from linker flags | expand

Commit Message

Bernd Kuhls May 12, 2024, 4:31 p.m. UTC
Kodi added detection for atomic/libatomic with commit
https://github.com/xbmc/xbmc/commit/1673f476b802da1da942cef256cae6272fdf9a4b
so we can remove our own code to handle the dependency.

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
 package/kodi/kodi.mk | 5 -----
 1 file changed, 5 deletions(-)

Comments

Yann E. MORIN May 12, 2024, 5:54 p.m. UTC | #1
Bernd, All,

On 2024-05-12 18:31 +0200, Bernd Kuhls spake thusly:
> Kodi added detection for atomic/libatomic with commit
> https://github.com/xbmc/xbmc/commit/1673f476b802da1da942cef256cae6272fdf9a4b
> so we can remove our own code to handle the dependency.
> 
> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>

Applied to master, thanks for the quick fix!

Regards,
Yann E. MORIN.

> ---
>  package/kodi/kodi.mk | 5 -----
>  1 file changed, 5 deletions(-)
> 
> diff --git a/package/kodi/kodi.mk b/package/kodi/kodi.mk
> index 62463b731e..94cab237dc 100644
> --- a/package/kodi/kodi.mk
> +++ b/package/kodi/kodi.mk
> @@ -217,11 +217,6 @@ else
>  KODI_CONF_OPTS += -D_AVX2_OK=OFF -D_AVX2_TRUE=OFF
>  endif
>  
> -# mips: uses __atomic_load_8
> -ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
> -KODI_CONF_OPTS += -DCMAKE_EXE_LINKER_FLAGS=-latomic
> -endif
> -
>  ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_5),)
>  KODI_C_FLAGS += -std=gnu99
>  endif
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/kodi/kodi.mk b/package/kodi/kodi.mk
index 62463b731e..94cab237dc 100644
--- a/package/kodi/kodi.mk
+++ b/package/kodi/kodi.mk
@@ -217,11 +217,6 @@  else
 KODI_CONF_OPTS += -D_AVX2_OK=OFF -D_AVX2_TRUE=OFF
 endif
 
-# mips: uses __atomic_load_8
-ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
-KODI_CONF_OPTS += -DCMAKE_EXE_LINKER_FLAGS=-latomic
-endif
-
 ifeq ($(BR2_TOOLCHAIN_GCC_AT_LEAST_5),)
 KODI_C_FLAGS += -std=gnu99
 endif