diff mbox series

[v3,08/14] package/qt6/qt6declarative: fix build when Qt Network not available

Message ID 20240512114617.2564569-8-roykollensvendsen@gmail.com
State Superseded
Headers show
Series [v3,01/14] package/qt6: bump version to 6.7.0 | expand

Commit Message

Roy Kollen Svendsen May 12, 2024, 11:45 a.m. UTC
From: Roy Kollen Svendsen <roy.kollen.svendsen@akersolutions.com>

Avoid checking for FEATURE_ssl when FEATURE_network is not available.

The failure occurs because FEATURE_ssl is defined by the Qt Network
module. So we check for FEATURE_network before we check for
FEATURE_ssl.

Fixes the following build failure:

CMake Error at qt6base-6.7.0/cmake/QtFeature.cmake:376 (message):
  Attempting to evaluate feature ssl but its definition is missing.  Either
  the feature does not exist or a dependency to the module that defines it is
  missing
Call Stack (most recent call first):
  qt6base-6.7.0/cmake/QtFeature.cmake:141 (qt_evaluate_feature)
  qt6base-6.7.0/cmake/QtFeature.cmake:180 (qt_internal_evaluate_config_expression)
  qt6base-6.7.0/cmake/QtFeature.cmake:396 (qt_evaluate_config_expression)
  qt6base-6.7.0/cmake/QtFeature.cmake:711 (qt_evaluate_feature)
  qt6base-6.7.0/cmake/QtFeature.cmake:680 (qt_feature_module_end)
  src/qml/CMakeLists.txt:13 (qt_feature_evaluate_features)

Signed-off-by: Roy Kollen Svendsen <roykollensvendsen@gmail.com>
---
Changes v2 -> v3:
  - This fix was added in this version of the patch set.

 ...1-Fix-build-with--no-feature-network.patch | 28 +++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 package/qt6/qt6declarative/0001-Fix-build-with--no-feature-network.patch
diff mbox series

Patch

diff --git a/package/qt6/qt6declarative/0001-Fix-build-with--no-feature-network.patch b/package/qt6/qt6declarative/0001-Fix-build-with--no-feature-network.patch
new file mode 100644
index 0000000000..bef5794229
--- /dev/null
+++ b/package/qt6/qt6declarative/0001-Fix-build-with--no-feature-network.patch
@@ -0,0 +1,28 @@ 
+From 8377691a0998fd84e6fc8349a5db450bf2d79164 Mon Sep 17 00:00:00 2001
+From: Tasuku Suzuki <tasuku.suzuki@signal-slot.co.jp>
+Date: Tue, 21 Nov 2023 23:58:43 +0900
+Subject: Fix build with -no-feature-network
+
+Change-Id: Ib21012301da6afb5458f707b39a9a8079d93eb93
+Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
+Upstream: https://code.qt.io/cgit/qt/qtdeclarative.git/commit/?id=8377691a0998fd84e6fc8349a5db450bf2d79164
+Signed-off-by: Roy Kollen Svendsen <roy.kollen.svendsen@akersolutions.com>
+---
+ src/qml/configure.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/qml/configure.cmake b/src/qml/configure.cmake
+index 2d0434643a..d1ff90bd54 100644
+--- a/src/qml/configure.cmake
++++ b/src/qml/configure.cmake
+@@ -82,7 +82,7 @@ qt_feature("qml-ssl" PUBLIC
+     SECTION "QML"
+     LABEL "QML SSL support"
+     PURPOSE "Provides ssl support in QML."
+-    CONDITION QT_FEATURE_ssl
++    CONDITION QT_FEATURE_qml_network AND QT_FEATURE_ssl
+ )
+ 
+ # On arm and arm64 we need a specialization of cacheFlush() for each OS to be
+-- 
+cgit v1.2.3