diff mbox series

[1/2] package/zbar: add the optional imagemagick dependency

Message ID 20240509193737.168634-1-ju.o@free.fr
State Accepted
Headers show
Series [1/2] package/zbar: add the optional imagemagick dependency | expand

Commit Message

Julien Olivain May 9, 2024, 7:37 p.m. UTC
When ImageMagick is selected, the "zbarimg" program is compiled and
installed on target. It allows to decode a QR code from an image file.

Signed-off-by: Julien Olivain <ju.o@free.fr>
---
 package/zbar/zbar.mk | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni May 9, 2024, 8:09 p.m. UTC | #1
On Thu,  9 May 2024 21:37:36 +0200
Julien Olivain <ju.o@free.fr> wrote:

> When ImageMagick is selected, the "zbarimg" program is compiled and
> installed on target. It allows to decode a QR code from an image file.
> 
> Signed-off-by: Julien Olivain <ju.o@free.fr>
> ---
>  package/zbar/zbar.mk | 8 +++++++-
>  1 file changed, 7 insertions(+), 1 deletion(-)

Series applied, thanks!

Thomas
Peter Korsgaard June 3, 2024, 5:31 p.m. UTC | #2
>>>>> "Julien" == Julien Olivain <ju.o@free.fr> writes:

 > When ImageMagick is selected, the "zbarimg" program is compiled and
 > installed on target. It allows to decode a QR code from an image file.

 > Signed-off-by: Julien Olivain <ju.o@free.fr>

Committed to 2024.02.x, thanks.
diff mbox series

Patch

diff --git a/package/zbar/zbar.mk b/package/zbar/zbar.mk
index 0e79004bb30..86f33796a24 100644
--- a/package/zbar/zbar.mk
+++ b/package/zbar/zbar.mk
@@ -18,7 +18,6 @@  ZBAR_CONF_ENV = \
 	LIBS=$(TARGET_NLS_LIBS)
 ZBAR_CONF_OPTS = \
 	--disable-doc \
-	--without-imagemagick \
 	--without-qt \
 	--without-qt5 \
 	--without-gtk \
@@ -32,6 +31,13 @@  else
 ZBAR_CONF_OPTS += --without-dbus
 endif
 
+ifeq ($(BR2_PACKAGE_IMAGEMAGICK),y)
+ZBAR_DEPENDENCIES += imagemagick
+ZBAR_CONF_OPTS += --with-imagemagick
+else
+ZBAR_CONF_OPTS += --without-imagemagick
+endif
+
 ifeq ($(BR2_PACKAGE_PYTHON3),y)
 ZBAR_DEPENDENCIES += host-python3 python3
 ZBAR_CONF_OPTS += --with-python=python3