diff mbox series

[v2] package/agentpp: bump to version 4.6.1

Message ID 20240508065039.6060-1-jesseevg@gmail.com
State Accepted
Headers show
Series [v2] package/agentpp: bump to version 4.6.1 | expand

Commit Message

Jesse Van Gavere May 8, 2024, 6:50 a.m. UTC
Bump to version 4.6.1 and drop the linking without v3 patch as this
version integrates the fix for that

Signed-off-by: Jesse Van Gavere <jesseevg@gmail.com>
---
Changes from v1:
- Drop accidental change in .packageignore, this was for the snmppp
  version bump
- Drop the patch, the failure mode here is not strictly related to the
  use of debugprintf but rather that the buildroot build of snmppp
  does not define __STRICT_ANSI__ but in my application using agentpp
  I use Qt which does define this, this rippled through and causes a
  mismatch between the function definition used in the buildroot build
  and the function my application wants to use and link against

 ...mpx-fix-const-nonconst-type-mismatch.patch | 51 -------------------
 package/agentpp/agentpp.hash                  |  2 +-
 package/agentpp/agentpp.mk                    |  2 +-
 3 files changed, 2 insertions(+), 53 deletions(-)
 delete mode 100644 package/agentpp/0001-Snmpx-fix-const-nonconst-type-mismatch.patch

Comments

Thomas Petazzoni May 8, 2024, 4:31 p.m. UTC | #1
On Wed,  8 May 2024 08:50:39 +0200
Jesse Van Gavere <jesseevg@gmail.com> wrote:

> Bump to version 4.6.1 and drop the linking without v3 patch as this
> version integrates the fix for that
> 
> Signed-off-by: Jesse Van Gavere <jesseevg@gmail.com>
> ---
> Changes from v1:
> - Drop accidental change in .packageignore, this was for the snmppp
>   version bump
> - Drop the patch, the failure mode here is not strictly related to the
>   use of debugprintf but rather that the buildroot build of snmppp
>   does not define __STRICT_ANSI__ but in my application using agentpp
>   I use Qt which does define this, this rippled through and causes a
>   mismatch between the function definition used in the buildroot build
>   and the function my application wants to use and link against

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/agentpp/0001-Snmpx-fix-const-nonconst-type-mismatch.patch b/package/agentpp/0001-Snmpx-fix-const-nonconst-type-mismatch.patch
deleted file mode 100644
index 07981eff3e..0000000000
--- a/package/agentpp/0001-Snmpx-fix-const-nonconst-type-mismatch.patch
+++ /dev/null
@@ -1,51 +0,0 @@ 
-From 7e541e6dba8d4976bbb490838a09b569f38b047d Mon Sep 17 00:00:00 2001
-From: Luca Ceresoli <luca.ceresoli@bootlin.com>
-Date: Mon, 26 Jun 2023 17:45:00 +0200
-Subject: [PATCH] Snmpx: fix const/nonconst type mismatch
-
-Fixes build failure:
-
-  snmp_pp_ext.cpp:1176:28: error: binding reference of type 'Snmp_pp::Pdu&' to 'const Snmp_pp::Pdu' discards qualifiers
-   1176 |     status = snmpmsg.load( pdu, community, version);
-        |                            ^~~
-
-Fixes:
-  http://autobuild.buildroot.net/results/e8abd6bdc62a028955915706b03d72239786c703/
-  http://autobuild.buildroot.net/results/24441fb679fbf5f913c9b6431c98aec596ead587/
-
-Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com>
-Upstream: sent to katz.agentpp.com@magenta.de and support@agentpp.com
----
- include/agent_pp/snmp_pp_ext.h | 2 +-
- src/snmp_pp_ext.cpp            | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/agent_pp/snmp_pp_ext.h b/include/agent_pp/snmp_pp_ext.h
-index 7c5a6783ee70..d8a46060db98 100644
---- a/include/agent_pp/snmp_pp_ext.h
-+++ b/include/agent_pp/snmp_pp_ext.h
-@@ -807,7 +807,7 @@ public:
- 	 *   SNMP_CLASS_SUCCESS on success and SNMP_CLASS_ERROR,
- 	 *   SNMP_CLASS_TL_FAILED on failure.
- 	 */
--        int send (Pdux const &, NS_SNMP UdpAddress const &, NS_SNMP snmp_version, NS_SNMP OctetStr const &);
-+        int send (Pdux &, NS_SNMP UdpAddress const &, NS_SNMP snmp_version, NS_SNMP OctetStr const &);
- #endif
- 
- 	/**
-diff --git a/src/snmp_pp_ext.cpp b/src/snmp_pp_ext.cpp
-index 54a29ec8ea28..b61cbf056246 100644
---- a/src/snmp_pp_ext.cpp
-+++ b/src/snmp_pp_ext.cpp
-@@ -1203,7 +1203,7 @@ int Snmpx::send (Pdux &pdu, SnmpTarget* target)
- 
- #else  // _SNMPv3 is not defined
- 
--int Snmpx::send (Pdux  const &pdu,
-+int Snmpx::send (Pdux  &pdu,
- 		 UdpAddress  const &udp_address,
- 		 snmp_version version,
- 		 OctetStr  const &community)
--- 
-2.34.1
-
diff --git a/package/agentpp/agentpp.hash b/package/agentpp/agentpp.hash
index 527414eed5..7c94f4b1b0 100644
--- a/package/agentpp/agentpp.hash
+++ b/package/agentpp/agentpp.hash
@@ -1,3 +1,3 @@ 
 # Locally computed:
-sha256  e09dc2d40277d468c18f1539ad18f43e0c3a95b10fad8a02184e9ace8bac0d67  agent++-4.6.0.tar.gz
+sha256  3287218cf6eaa3744b3788afd1e7d72e7a9508d45741243178404f6b47edd86f  agent++-4.6.1.tar.gz
 sha256  1eb85fc97224598dad1852b5d6483bbcf0aa8608790dcc657a5a2a761ae9c8c6  LICENSE-2_0.txt
diff --git a/package/agentpp/agentpp.mk b/package/agentpp/agentpp.mk
index 7616d3eb0c..3756d0ca28 100644
--- a/package/agentpp/agentpp.mk
+++ b/package/agentpp/agentpp.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-AGENTPP_VERSION = 4.6.0
+AGENTPP_VERSION = 4.6.1
 AGENTPP_SOURCE = agent++-$(AGENTPP_VERSION).tar.gz
 AGENTPP_SITE = http://www.agentpp.com/download
 AGENTPP_LICENSE = Apache-2.0