diff mbox series

[v2,1/2] configs/sheevaplug_defconfig: bump Linux to fix binutils 2.41 build

Message ID 20240506074013.263439-1-peter@korsgaard.com
State Accepted
Headers show
Series [v2,1/2] configs/sheevaplug_defconfig: bump Linux to fix binutils 2.41 build | expand

Commit Message

Peter Korsgaard May 6, 2024, 7:40 a.m. UTC
Fixes:
https://gitlab.com/buildroot.org/buildroot/-/jobs/6761770801

The Linux kernel fails to build since commit e88225ed882 (package/binutils:
make 2.41 the default version):

arch/arm/mm/proc-feroceon.S: Assembler messages:
arch/arm/mm/proc-feroceon.S:587: Error: junk at end of line, first unrecognized character is `#'
make[3]: *** [scripts/Makefile.build:430: arch/arm/mm/proc-feroceon.o] Error 1
make[3]: *** Waiting for unfinished jobs....

Fix the build by bumping the kernel to 4.14.336, which includes commit
3ab03df64f77 (ARM: 8933/1: replace Sun/Solaris style flag on section
directive):

https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-4.14.y&id=3ab03df64f7754728a2257c47775a70a88428331

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 configs/sheevaplug_defconfig | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni May 6, 2024, 7:31 p.m. UTC | #1
On Mon,  6 May 2024 09:40:11 +0200
Peter Korsgaard <peter@korsgaard.com> wrote:

> Fixes:
> https://gitlab.com/buildroot.org/buildroot/-/jobs/6761770801
> 
> The Linux kernel fails to build since commit e88225ed882 (package/binutils:
> make 2.41 the default version):
> 
> arch/arm/mm/proc-feroceon.S: Assembler messages:
> arch/arm/mm/proc-feroceon.S:587: Error: junk at end of line, first unrecognized character is `#'
> make[3]: *** [scripts/Makefile.build:430: arch/arm/mm/proc-feroceon.o] Error 1
> make[3]: *** Waiting for unfinished jobs....
> 
> Fix the build by bumping the kernel to 4.14.336, which includes commit
> 3ab03df64f77 (ARM: 8933/1: replace Sun/Solaris style flag on section
> directive):
> 
> https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-4.14.y&id=3ab03df64f7754728a2257c47775a70a88428331
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
> ---
>  configs/sheevaplug_defconfig | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Series applied. In the second patch you had forgotten (perhaps
intentionally?) to update .checkpackageignore, so I did it while
applying.

Thanks!

Thomas
Peter Korsgaard May 7, 2024, 6:29 a.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@bootlin.com> writes:

Hi,

 >> Fix the build by bumping the kernel to 4.14.336, which includes commit
 >> 3ab03df64f77 (ARM: 8933/1: replace Sun/Solaris style flag on section
 >> directive):
 >> 
 >> https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=linux-4.14.y&id=3ab03df64f7754728a2257c47775a70a88428331
 >> 
 >> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
 >> ---
 >> configs/sheevaplug_defconfig | 2 +-
 >> 1 file changed, 1 insertion(+), 1 deletion(-)

 > Series applied. In the second patch you had forgotten (perhaps
 > intentionally?) to update .checkpackageignore, so I did it while
 > applying.

Ahh, I hadn't seen commit 7931f78c16f08f7 yet, still running a bit
behind for 2024.02.x after the holidays.

Thanks for fixing it up.
diff mbox series

Patch

diff --git a/configs/sheevaplug_defconfig b/configs/sheevaplug_defconfig
index 7f186df22c..0879f17071 100644
--- a/configs/sheevaplug_defconfig
+++ b/configs/sheevaplug_defconfig
@@ -27,7 +27,7 @@  BR2_TARGET_UBOOT_FORMAT_KWB=y
 # Kernel
 BR2_LINUX_KERNEL=y
 BR2_LINUX_KERNEL_CUSTOM_VERSION=y
-BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.14.253"
+BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.14.336"
 BR2_LINUX_KERNEL_DEFCONFIG="mvebu_v5"
 BR2_LINUX_KERNEL_APPENDED_UIMAGE=y
 BR2_LINUX_KERNEL_UIMAGE_LOADADDR="0x8000"