diff mbox series

[1/2] package/lvm2: enable device-mapper in Kernel config

Message ID 20240412222459.1630158-1-ju.o@free.fr
State New
Headers show
Series [1/2] package/lvm2: enable device-mapper in Kernel config | expand

Commit Message

Julien Olivain April 12, 2024, 10:24 p.m. UTC
LVM2 has a hard dependency on the device-mapper presence in the Kernel.
This commit enables those mandatory Kernel configuration by defining
the _LINUX_CONFIG_FIXUPS macro. This will make sure the final system
image will end up in a working configuration.

This was suggested by Arnout in [1].

[1] https://lists.buildroot.org/pipermail/buildroot/2024-April/688776.html

Suggested-by: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Julien Olivain <ju.o@free.fr>
---
 package/lvm2/lvm2.mk | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/package/lvm2/lvm2.mk b/package/lvm2/lvm2.mk
index bda16489550..4fcfddb1bbd 100644
--- a/package/lvm2/lvm2.mk
+++ b/package/lvm2/lvm2.mk
@@ -76,5 +76,10 @@  HOST_LVM2_CONF_OPTS = \
 	--disable-selinux \
 	--with-confdir=$(HOST_DIR)/etc
 
+define LVM2_LINUX_CONFIG_FIXUPS
+	$(call KCONFIG_ENABLE_OPT,CONFIG_MD)
+	$(call KCONFIG_ENABLE_OPT,CONFIG_BLK_DEV_DM)
+endef
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))