diff mbox series

[1/1] package/ttyd: bump to version 1.7.7

Message ID 20240412135820.1599-1-tianyuanhao3@163.com
State Accepted
Headers show
Series [1/1] package/ttyd: bump to version 1.7.7 | expand

Commit Message

TIAN Yuanhao April 12, 2024, 1:58 p.m. UTC
Notable changes:

- The web terminal is readonly by default now, to make it writable, use
  -W option.

Also set TTYD_CPE_ID_VALID.

cpe:2.3:a:ttyd_project:ttyd is a valid CPE identifier for this package:

  https://nvd.nist.gov/products/cpe/detail/DBEDA75E-4E19-48C1-92D7-43E4035BC048

Signed-off-by: TIAN Yuanhao <tianyuanhao3@163.com>
---
 package/ttyd/ttyd.hash | 2 +-
 package/ttyd/ttyd.mk   | 3 ++-
 2 files changed, 3 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN April 12, 2024, 6:43 p.m. UTC | #1
Yuanhao, All,

On 2024-04-12 13:58 +0000, TIAN Yuanhao spake thusly:
> Notable changes:
> 
> - The web terminal is readonly by default now, to make it writable, use
>   -W option.
> 
> Also set TTYD_CPE_ID_VALID.

I've moved that part to its own commit, so that it can be backported to
stable branches.

> cpe:2.3:a:ttyd_project:ttyd is a valid CPE identifier for this package:
> 
>   https://nvd.nist.gov/products/cpe/detail/DBEDA75E-4E19-48C1-92D7-43E4035BC048
> 
> Signed-off-by: TIAN Yuanhao <tianyuanhao3@163.com>

Applied to master, as two separate commits, one for the CPE_ID, one for
the version bump, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/ttyd/ttyd.hash | 2 +-
>  package/ttyd/ttyd.mk   | 3 ++-
>  2 files changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/package/ttyd/ttyd.hash b/package/ttyd/ttyd.hash
> index b11327c465..9a407a68fd 100644
> --- a/package/ttyd/ttyd.hash
> +++ b/package/ttyd/ttyd.hash
> @@ -1,3 +1,3 @@
>  # Locally computed:
> -sha256  300d8cef4b0b32b0ec30d7bf4d3721a5d180e22607f9467a95ab7b6d9652ca9b  ttyd-1.7.4.tar.gz
> +sha256  039dd995229377caee919898b7bd54484accec3bba49c118e2d5cd6ec51e3650  ttyd-1.7.7.tar.gz
>  sha256  8b7e100f8311cb428c57609164d93099bada2599f948359045d1ac876a7a625b  LICENSE
> diff --git a/package/ttyd/ttyd.mk b/package/ttyd/ttyd.mk
> index d0e144b252..e6cf791988 100644
> --- a/package/ttyd/ttyd.mk
> +++ b/package/ttyd/ttyd.mk
> @@ -4,10 +4,11 @@
>  #
>  ################################################################################
>  
> -TTYD_VERSION = 1.7.4
> +TTYD_VERSION = 1.7.7
>  TTYD_SITE = $(call github,tsl0922,ttyd,$(TTYD_VERSION))
>  TTYD_LICENSE = MIT
>  TTYD_LICENSE_FILES = LICENSE
>  TTYD_DEPENDENCIES = json-c libuv libwebsockets openssl zlib
> +TTYD_CPE_ID_VALID = YES
>  
>  $(eval $(cmake-package))
> -- 
> 2.34.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/ttyd/ttyd.hash b/package/ttyd/ttyd.hash
index b11327c465..9a407a68fd 100644
--- a/package/ttyd/ttyd.hash
+++ b/package/ttyd/ttyd.hash
@@ -1,3 +1,3 @@ 
 # Locally computed:
-sha256  300d8cef4b0b32b0ec30d7bf4d3721a5d180e22607f9467a95ab7b6d9652ca9b  ttyd-1.7.4.tar.gz
+sha256  039dd995229377caee919898b7bd54484accec3bba49c118e2d5cd6ec51e3650  ttyd-1.7.7.tar.gz
 sha256  8b7e100f8311cb428c57609164d93099bada2599f948359045d1ac876a7a625b  LICENSE
diff --git a/package/ttyd/ttyd.mk b/package/ttyd/ttyd.mk
index d0e144b252..e6cf791988 100644
--- a/package/ttyd/ttyd.mk
+++ b/package/ttyd/ttyd.mk
@@ -4,10 +4,11 @@ 
 #
 ################################################################################
 
-TTYD_VERSION = 1.7.4
+TTYD_VERSION = 1.7.7
 TTYD_SITE = $(call github,tsl0922,ttyd,$(TTYD_VERSION))
 TTYD_LICENSE = MIT
 TTYD_LICENSE_FILES = LICENSE
 TTYD_DEPENDENCIES = json-c libuv libwebsockets openssl zlib
+TTYD_CPE_ID_VALID = YES
 
 $(eval $(cmake-package))