diff mbox series

[v3,3/3] uboot/uboot: add new dependency to yamllint

Message ID 20240412055358.1354293-3-heiko.thiery@gmail.com
State Accepted
Headers show
Series [v3,1/3] package/python-yamllint: new package | expand

Commit Message

Heiko Thiery April 12, 2024, 5:54 a.m. UTC
Since U-Boot 2024.04 [1] binman also uses yamllint as dependency [2].

[1] https://source.denx.de/u-boot/u-boot/-/commit/10fee88d42f
[2] https://source.denx.de/u-boot/u-boot/-/blob/v2024.04/tools/buildman/requirements.txt?ref_type=tags#L3

Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
---

v2: accidentally resend this series as v2
    (it's too early in the morning and no coffee yet)

v3:
 - update URLs in the comment

 boot/uboot/uboot.mk | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

--
2.39.2

Comments

Bryan Brattlof April 12, 2024, 3:18 p.m. UTC | #1
On April 12, 2024 thus sayeth Heiko Thiery:
> Since U-Boot 2024.04 [1] binman also uses yamllint as dependency [2].
> 
> [1] https://source.denx.de/u-boot/u-boot/-/commit/10fee88d42f
> [2] https://source.denx.de/u-boot/u-boot/-/blob/v2024.04/tools/buildman/requirements.txt?ref_type=tags#L3
> 
> Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
> ---
> 
> v2: accidentally resend this series as v2
>     (it's too early in the morning and no coffee yet)
> 
> v3:
>  - update URLs in the comment
> 
>  boot/uboot/uboot.mk | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)

Reviewed-by: Bryan Brattlof <bb@ti.com>

Thanks for this. I successfully built v2024.04 U-Boot for all of TI's K3 
SoCs. One step closer for K3 :)

~Bryan

> 
> diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
> index a894654698..0ee63cabdb 100644
> --- a/boot/uboot/uboot.mk
> +++ b/boot/uboot/uboot.mk
> @@ -276,10 +276,12 @@ UBOOT_DEPENDENCIES += host-vim
>  endif
> 
>  ifeq ($(BR2_TARGET_UBOOT_USE_BINMAN),y)
> -# https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/buildman/requirements.txt
> +# https://source.denx.de/u-boot/u-boot/-/blob/v2024.04/tools/binman/binman.rst?plain=1#L377
> +# https://source.denx.de/u-boot/u-boot/-/blob/v2024.04/tools/buildman/requirements.txt
>  UBOOT_DEPENDENCIES += \
>  	host-python-jsonschema \
> -	host-python-pyyaml
> +	host-python-pyyaml \
> +	host-python-yamllint
>  UBOOT_MAKE_OPTS += BINMAN_INDIRS=$(BINARIES_DIR)
>  endif
> 
> --
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index a894654698..0ee63cabdb 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -276,10 +276,12 @@  UBOOT_DEPENDENCIES += host-vim
 endif

 ifeq ($(BR2_TARGET_UBOOT_USE_BINMAN),y)
-# https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/buildman/requirements.txt
+# https://source.denx.de/u-boot/u-boot/-/blob/v2024.04/tools/binman/binman.rst?plain=1#L377
+# https://source.denx.de/u-boot/u-boot/-/blob/v2024.04/tools/buildman/requirements.txt
 UBOOT_DEPENDENCIES += \
 	host-python-jsonschema \
-	host-python-pyyaml
+	host-python-pyyaml \
+	host-python-yamllint
 UBOOT_MAKE_OPTS += BINMAN_INDIRS=$(BINARIES_DIR)
 endif