diff mbox series

[1/3] boot/uboot: remove BR2_TARGET_UBOOT_NEEDS_TI_K3_BOOT_FIRMWARE

Message ID 20240410214454.86748-1-romain.naour@smile.fr
State New
Headers show
Series [1/3] boot/uboot: remove BR2_TARGET_UBOOT_NEEDS_TI_K3_BOOT_FIRMWARE | expand

Commit Message

Romain Naour April 10, 2024, 9:44 p.m. UTC
As suggested by Arnout during the review [1], we can assume that U-Boot
needs ti-k3-boot-firmware when it is selected (likely by
ti-k3-r5-loader).

We can remove BR2_TARGET_UBOOT_NEEDS_TI_K3_BOOT_FIRMWARE without
legacy handling since this option is not part of any Buildroot
release.

[1] http://lists.busybox.net/pipermail/buildroot/2024-April/689263.html

Cc: Arnout Vandecappelle <arnout@mind.be>
Signed-off-by: Romain Naour <romain.naour@smile.fr>
---
 Config.in.legacy              |  3 +--
 boot/uboot/Config.in          | 11 -----------
 boot/uboot/uboot.mk           |  6 +++++-
 configs/ti_am62x_sk_defconfig |  1 -
 configs/ti_am64x_sk_defconfig |  1 -
 5 files changed, 6 insertions(+), 16 deletions(-)
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index 76af1da348..f67187e92d 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -154,9 +154,8 @@  config BR2_TARGET_TI_K3_IMAGE_GEN
 	  U-Boot binman tool (requires U-boot >= 2023.10).
 
 config BR2_TARGET_UBOOT_NEEDS_TI_K3_DM
-	bool "u-boot TI K3 DM option has been renamed."
+	bool "u-boot TI K3 DM option has been removed."
 	select BR2_LEGACY
-	select BR2_TARGET_UBOOT_NEEDS_TI_K3_BOOT_FIRMWARE
 	help
 	  The TI K3 Device Manager is already included in
 	  ti-k3-boot-firmware.
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 8d2228dc7d..8133b780bb 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -240,17 +240,6 @@  config BR2_TARGET_UBOOT_NEEDS_OPTEE_TEE
 	  U-Boot, and that the TEE variable pointing to OPTEE's
 	  tee.elf, is passed during the Buildroot build.
 
-config BR2_TARGET_UBOOT_NEEDS_TI_K3_BOOT_FIRMWARE
-	bool "U-Boot needs ti-k3-boot-firmware"
-	depends on BR2_TARGET_TI_K3_BOOT_FIRMWARE
-	help
-	  TI K3 devices needs at least ti-sysfw (System Firmware) when
-	  built with u-boot's binman tool.
-
-	  Some TI K3 devices using a split firmware boot flow (AM62,
-	  j721e) also need the Device Manager (DM) firmware to be
-	  available for the U-Boot build.
-
 config BR2_TARGET_UBOOT_NEEDS_OPENSBI
 	bool "U-Boot needs OpenSBI"
 	depends on BR2_TARGET_OPENSBI
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index a894654698..c3baa75e49 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -194,7 +194,11 @@  UBOOT_DEPENDENCIES += optee-os
 UBOOT_MAKE_OPTS += TEE=$(BINARIES_DIR)/tee.elf
 endif
 
-ifeq ($(BR2_TARGET_UBOOT_NEEDS_TI_K3_BOOT_FIRMWARE),y)
+# TI K3 devices needs at least ti-sysfw (System Firmware) provided
+# by ti-k3-boot-firmware when built with u-boot's binman tool.
+# Some TI K3 devices using a split firmware boot flow (AM62,
+# j721e) also need the Device Manager (DM) firmware.
+ifeq ($(BR2_TARGET_TI_K3_BOOT_FIRMWARE),y)
 UBOOT_DEPENDENCIES += ti-k3-boot-firmware
 endif
 
diff --git a/configs/ti_am62x_sk_defconfig b/configs/ti_am62x_sk_defconfig
index 5c7b97b3b0..a0b4c21216 100644
--- a/configs/ti_am62x_sk_defconfig
+++ b/configs/ti_am62x_sk_defconfig
@@ -37,7 +37,6 @@  BR2_TARGET_UBOOT_BOARD_DEFCONFIG="am62x_evm_a53"
 BR2_TARGET_UBOOT_NEEDS_DTC=y
 BR2_TARGET_UBOOT_NEEDS_OPENSSL=y
 BR2_TARGET_UBOOT_NEEDS_ATF_BL31=y
-BR2_TARGET_UBOOT_NEEDS_TI_K3_BOOT_FIRMWARE=y
 BR2_TARGET_UBOOT_USE_BINMAN=y
 # BR2_TARGET_UBOOT_FORMAT_BIN is not set
 BR2_TARGET_UBOOT_FORMAT_IMG=y
diff --git a/configs/ti_am64x_sk_defconfig b/configs/ti_am64x_sk_defconfig
index 28e97f94e2..8dbe0fae33 100644
--- a/configs/ti_am64x_sk_defconfig
+++ b/configs/ti_am64x_sk_defconfig
@@ -37,7 +37,6 @@  BR2_TARGET_UBOOT_BOARD_DEFCONFIG="am64x_evm_a53"
 BR2_TARGET_UBOOT_NEEDS_DTC=y
 BR2_TARGET_UBOOT_NEEDS_OPENSSL=y
 BR2_TARGET_UBOOT_NEEDS_ATF_BL31=y
-BR2_TARGET_UBOOT_NEEDS_TI_K3_BOOT_FIRMWARE=y
 BR2_TARGET_UBOOT_USE_BINMAN=y
 # BR2_TARGET_UBOOT_FORMAT_BIN is not set
 BR2_TARGET_UBOOT_FORMAT_IMG=y