diff mbox series

[1/1] package/dmraid: set -fPIC

Message ID 20240408193139.196047-1-fontaine.fabrice@gmail.com
State New
Headers show
Series [1/1] package/dmraid: set -fPIC | expand

Commit Message

Fabrice Fontaine April 8, 2024, 7:31 p.m. UTC
Add -fPIC to CFLAGS to fix the following build failure raised since
commit de6415ad9c35b2013af1f1821bcac12ba3959674:

/home/autobuild/autobuild/instance-5/output-1/host/lib/gcc/x86_64-buildroot-linux-gnu/12.3.0/../../../../x86_64-buildroot-linux-gnu/bin/ld: misc/misc.o: warning: relocation against `stdout@@GLIBC_2.2.5' in read-only section `.text'
/home/autobuild/autobuild/instance-5/output-1/host/lib/gcc/x86_64-buildroot-linux-gnu/12.3.0/../../../../x86_64-buildroot-linux-gnu/bin/ld: log/log.o: relocation R_X86_64_PC32 against symbol `stdout@@GLIBC_2.2.5' can not be used when making a shared object; recompile with -fPIC

Fixes: de6415ad9c35b2013af1f1821bcac12ba3959674
 - http://autobuild.buildroot.org/results/0349c6bfd66f5e50429e4a5cc07fb7abf2b07345

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/dmraid/dmraid.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/dmraid/dmraid.mk b/package/dmraid/dmraid.mk
index 9a78c2ae07..97c729aa70 100644
--- a/package/dmraid/dmraid.mk
+++ b/package/dmraid/dmraid.mk
@@ -13,7 +13,7 @@  DMRAID_MAKE = $(MAKE1)
 DMRAID_INSTALL_STAGING = YES
 DMRAID_LICENSE = GPL-2.0
 DMRAID_LICENSE_FILES = $(DMRAID_SUBDIR)/LICENSE_GPL $(DMRAID_SUBDIR)/LICENSE
-DMRAID_MAKE_OPTS = $(TARGET_CONFIGURE_OPTS)
+DMRAID_MAKE_OPTS = $(TARGET_CONFIGURE_OPTS) CFLAGS="$(TARGET_CFLAGS) -fPIC"
 
 DMRAID_DEPENDENCIES = lvm2