diff mbox series

[1/1] package/openblas: fix build

Message ID 20240407153417.2030051-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/openblas: fix build | expand

Commit Message

Fabrice Fontaine April 7, 2024, 3:34 p.m. UTC
Fix the following build failure raised since bump to version 0.3.27 in
commit 59b48b5cff057f2429b1143d6f50c39d93ca8ef3:

/bin/sh: ./xccblat3_3m: No such file or directory

Fixes: 59b48b5cff057f2429b1143d6f50c39d93ca8ef3
 - http://autobuild.buildroot.org/results/52acc2d95bbc07155b9d446ab8625f9c9eb81b52

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 ...-should-not-be-run-in-cross-compiles.patch | 33 +++++++++++++++++++
 1 file changed, 33 insertions(+)
 create mode 100644 package/openblas/0002-fix-position-of-endif-gemm3m-tests-should-not-be-run-in-cross-compiles.patch

Comments

Arnout Vandecappelle April 7, 2024, 7:35 p.m. UTC | #1
On 07/04/2024 17:34, Fabrice Fontaine wrote:
> Fix the following build failure raised since bump to version 0.3.27 in
> commit 59b48b5cff057f2429b1143d6f50c39d93ca8ef3:
> 
> /bin/sh: ./xccblat3_3m: No such file or directory
> 
> Fixes: 59b48b5cff057f2429b1143d6f50c39d93ca8ef3
>   - http://autobuild.buildroot.org/results/52acc2d95bbc07155b9d446ab8625f9c9eb81b52
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   ...-should-not-be-run-in-cross-compiles.patch | 33 +++++++++++++++++++
>   1 file changed, 33 insertions(+)
>   create mode 100644 package/openblas/0002-fix-position-of-endif-gemm3m-tests-should-not-be-run-in-cross-compiles.patch
> 
> diff --git a/package/openblas/0002-fix-position-of-endif-gemm3m-tests-should-not-be-run-in-cross-compiles.patch b/package/openblas/0002-fix-position-of-endif-gemm3m-tests-should-not-be-run-in-cross-compiles.patch
> new file mode 100644
> index 0000000000..44883b2c26
> --- /dev/null
> +++ b/package/openblas/0002-fix-position-of-endif-gemm3m-tests-should-not-be-run-in-cross-compiles.patch
> @@ -0,0 +1,33 @@
> +From 48e017de095018c60d83355804a3075658b4970c Mon Sep 17 00:00:00 2001
> +From: Martin Kroeker <martin@ruby.chemie.uni-freiburg.de>
> +Date: Fri, 5 Apr 2024 22:54:34 +0200
> +Subject: [PATCH] fix position of endif - gemm3m tests should not be run in
> + cross-compiles
> +
> +Upstream: https://github.com/OpenMathLib/OpenBLAS/commit/48e017de095018c60d83355804a3075658b4970c
> +Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> +---
> + ctest/Makefile | 3 +--
> + 1 file changed, 1 insertion(+), 2 deletions(-)
> +
> +diff --git a/ctest/Makefile b/ctest/Makefile
> +index bbaf96f8ed..6c7cc1ed56 100644
> +--- a/ctest/Makefile
> ++++ b/ctest/Makefile
> +@@ -203,7 +203,6 @@ ifeq ($(BUILD_COMPLEX16),1)
> + 	OPENBLAS_NUM_THREADS=2 ./xzcblat3 < zin3
> + endif
> + endif
> +-endif
> +
> + ifeq ($(SUPPORT_GEMM3M),1)
> + ifeq ($(USE_OPENMP), 1)
> +@@ -222,7 +221,7 @@ ifeq ($(BUILD_COMPLEX16),1)
> + endif
> + endif
> + endif
> +-
> ++endif
> +
> +
> +
diff mbox series

Patch

diff --git a/package/openblas/0002-fix-position-of-endif-gemm3m-tests-should-not-be-run-in-cross-compiles.patch b/package/openblas/0002-fix-position-of-endif-gemm3m-tests-should-not-be-run-in-cross-compiles.patch
new file mode 100644
index 0000000000..44883b2c26
--- /dev/null
+++ b/package/openblas/0002-fix-position-of-endif-gemm3m-tests-should-not-be-run-in-cross-compiles.patch
@@ -0,0 +1,33 @@ 
+From 48e017de095018c60d83355804a3075658b4970c Mon Sep 17 00:00:00 2001
+From: Martin Kroeker <martin@ruby.chemie.uni-freiburg.de>
+Date: Fri, 5 Apr 2024 22:54:34 +0200
+Subject: [PATCH] fix position of endif - gemm3m tests should not be run in
+ cross-compiles
+
+Upstream: https://github.com/OpenMathLib/OpenBLAS/commit/48e017de095018c60d83355804a3075658b4970c
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ ctest/Makefile | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/ctest/Makefile b/ctest/Makefile
+index bbaf96f8ed..6c7cc1ed56 100644
+--- a/ctest/Makefile
++++ b/ctest/Makefile
+@@ -203,7 +203,6 @@ ifeq ($(BUILD_COMPLEX16),1)
+ 	OPENBLAS_NUM_THREADS=2 ./xzcblat3 < zin3
+ endif
+ endif
+-endif
+ 
+ ifeq ($(SUPPORT_GEMM3M),1)
+ ifeq ($(USE_OPENMP), 1)
+@@ -222,7 +221,7 @@ ifeq ($(BUILD_COMPLEX16),1)
+ endif
+ endif
+ endif
+-
++endif
+ 
+ 
+