diff mbox series

[1/1] package/cups: add libxcrypt optional dependency

Message ID 20240407143534.1888458-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/cups: add libxcrypt optional dependency | expand

Commit Message

Fabrice Fontaine April 7, 2024, 2:35 p.m. UTC
Fix the following build failure raised since bump of glibc to version
2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:

/home/buildroot/autobuild/run/instance-1/output-1/host/lib/gcc/arc-buildroot-linux-gnu/13.1.1/../../../../arc-buildroot-linux-gnu/bin/ld: auth.o: in function `cupsdAuthorize':
auth.c:(.text+0xdba): undefined reference to `crypt'

Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
 - http://autobuild.buildroot.org/results/39b72d4e14895f901590d7e3404f69b4573d2cd2

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/cups/Config.in | 1 +
 package/cups/cups.mk   | 1 +
 2 files changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/package/cups/Config.in b/package/cups/Config.in
index 51cf10b073..ad852c0998 100644
--- a/package/cups/Config.in
+++ b/package/cups/Config.in
@@ -6,6 +6,7 @@  config BR2_PACKAGE_CUPS
 	depends on BR2_TOOLCHAIN_HAS_THREADS
 	# needs fork()
 	depends on BR2_USE_MMU
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  The Common Unix Printing System
 
diff --git a/package/cups/cups.mk b/package/cups/cups.mk
index 91fad30b38..dc66ee3e1c 100644
--- a/package/cups/cups.mk
+++ b/package/cups/cups.mk
@@ -32,6 +32,7 @@  CUPS_CONFIG_SCRIPTS = cups-config
 CUPS_DEPENDENCIES = \
 	host-autoconf \
 	host-pkgconf \
+	$(if $(BR2_PACKAGE_LIBXCRYPT),libxcrypt)
 	$(if $(BR2_PACKAGE_ZLIB),zlib)
 
 ifeq ($(BR2_PACKAGE_SYSTEMD),y)