diff mbox series

[1/1] package/apache: add libxcrypt optional dependency

Message ID 20240407140724.1872790-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/apache: add libxcrypt optional dependency | expand

Commit Message

Fabrice Fontaine April 7, 2024, 2:07 p.m. UTC
Fix the following build failure raised since bump of glibc to version
2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:

/home/buildroot/instance-0/output-1/host/lib/gcc/arc-buildroot-linux-gnu/13.1.1/../../../../arc-buildroot-linux-gnu/bin/ld: /home/buildroot/instance-0/output-1/host/arc-buildroot-linux-gnu/sysroot/usr/lib/libaprutil-1.so: undefined reference to `crypt'

Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
 - http://autobuild.buildroot.org/results/f0f55d9d66b07cb3408086d2632f8cd1bebb670e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/apache/Config.in | 1 +
 package/apache/apache.mk | 4 ++++
 2 files changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/package/apache/Config.in b/package/apache/Config.in
index 270296bce4..bc3133ea00 100644
--- a/package/apache/Config.in
+++ b/package/apache/Config.in
@@ -5,6 +5,7 @@  config BR2_PACKAGE_APACHE
 	depends on BR2_USE_MMU # apr
 	select BR2_PACKAGE_APR_UTIL
 	select BR2_PACKAGE_PCRE2
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  The Apache HTTP Server Project is an effort to develop and
 	  maintain an open-source HTTP server for modern operating
diff --git a/package/apache/apache.mk b/package/apache/apache.mk
index 1b095c5eb1..619d13726e 100644
--- a/package/apache/apache.mk
+++ b/package/apache/apache.mk
@@ -52,6 +52,10 @@  else
 APACHE_CONF_OPTS += --disable-brotli
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
+APACHE_DEPENDENCIES += libxcrypt
+endif
+
 ifeq ($(BR2_PACKAGE_LIBXML2),y)
 APACHE_DEPENDENCIES += libxml2
 # Apache wants the path to the header file, where it can find