diff mbox series

[1/1] package/frr: add libxcrypt optional dependency

Message ID 20240407134801.1839680-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/frr: add libxcrypt optional dependency | expand

Commit Message

Fabrice Fontaine April 7, 2024, 1:48 p.m. UTC
Fix the following build failure raised since bump of glibc to version
2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:

/home/autobuild/autobuild/instance-1/output-1/per-package/frr/host/bin/../lib/gcc/i686-buildroot-linux-gnu/12.3.0/../../../../i686-buildroot-linux-gnu/bin/ld: lib/.libs/libfrr.so: undefined reference to `crypt'

Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
 - http://autobuild.buildroot.org/results/668da3829cacbe883e6cf97ce6191a8180441db6

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/frr/Config.in | 1 +
 package/frr/frr.mk    | 3 ++-
 2 files changed, 3 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN April 7, 2024, 3:39 p.m. UTC | #1
fabrice, All,

On 2024-04-07 15:48 +0200, Fabrice Fontaine spake thusly:
> Fix the following build failure raised since bump of glibc to version
> 2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:
> 
> /home/autobuild/autobuild/instance-1/output-1/per-package/frr/host/bin/../lib/gcc/i686-buildroot-linux-gnu/12.3.0/../../../../i686-buildroot-linux-gnu/bin/ld: lib/.libs/libfrr.so: undefined reference to `crypt'
> 
> Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
>  - http://autobuild.buildroot.org/results/668da3829cacbe883e6cf97ce6191a8180441db6
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
[--SNIP--]
> diff --git a/package/frr/frr.mk b/package/frr/frr.mk
> index 29a9e7b3e8..d20dc07bb7 100644
> --- a/package/frr/frr.mk
> +++ b/package/frr/frr.mk
> @@ -13,7 +13,8 @@ FRR_CPE_ID_PRODUCT = free_range_routing
>  FRR_AUTORECONF = YES
>  
>  FRR_DEPENDENCIES = host-frr readline json-c libyang protobuf-c \

This protobuf-c dependency is not present in master. What branch did you
base this change on?

Otherwise, applied to master, after applying the patch manually because
of the above conflict, thanks.

Regards,
Yann E. MORIN.

> -	$(if $(BR2_PACKAGE_C_ARES),c-ares)
> +	$(if $(BR2_PACKAGE_C_ARES),c-ares) \
> +	$(if $(BR2_PACKAGE_LIBXCRYPT),libxcrypt)
>  
>  HOST_FRR_DEPENDENCIES = host-flex host-bison host-elfutils host-python3
>  
> -- 
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/frr/Config.in b/package/frr/Config.in
index ef105202f4..e2ad5d5aa6 100644
--- a/package/frr/Config.in
+++ b/package/frr/Config.in
@@ -9,6 +9,7 @@  config BR2_PACKAGE_FRR
 	depends on BR2_HOST_GCC_AT_LEAST_7 # protobuf-c
 	select BR2_PACKAGE_BASH
 	select BR2_PACKAGE_BUSYBOX_SHOW_OTHERS # bash
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	select BR2_PACKAGE_LIBYANG
 	select BR2_PACKAGE_PROTOBUF_C
 	select BR2_PACKAGE_READLINE
diff --git a/package/frr/frr.mk b/package/frr/frr.mk
index 29a9e7b3e8..d20dc07bb7 100644
--- a/package/frr/frr.mk
+++ b/package/frr/frr.mk
@@ -13,7 +13,8 @@  FRR_CPE_ID_PRODUCT = free_range_routing
 FRR_AUTORECONF = YES
 
 FRR_DEPENDENCIES = host-frr readline json-c libyang protobuf-c \
-	$(if $(BR2_PACKAGE_C_ARES),c-ares)
+	$(if $(BR2_PACKAGE_C_ARES),c-ares) \
+	$(if $(BR2_PACKAGE_LIBXCRYPT),libxcrypt)
 
 HOST_FRR_DEPENDENCIES = host-flex host-bison host-elfutils host-python3