diff mbox series

[1/1] package/inih: bump to version 58

Message ID 20240407131649.1416942-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/inih: bump to version 58 | expand

Commit Message

Fabrice Fontaine April 7, 2024, 1:16 p.m. UTC
This bump will fix the following build failure with gcc 5 raised since
bump to version 57 in commit 65c8a9b6626de83365865dea6fff1749466a36aa
thanks to
https://github.com/benhoyt/inih/commit/4e618f77d4bae216865c5abd972d99b1ba5031e2:

In file included from /home/buildroot/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/mips-linux-gnu/include/c++/5.3.0/cstdint:35:0,
                 from ../cpp/INIReader.h:17,
                 from ../cpp/INIReader.cpp:16:
/home/buildroot/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/mips-linux-gnu/include/c++/5.3.0/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
 #error This file requires compiler and library support for the \
  ^

https://github.com/benhoyt/inih/releases/tag/r58

Fixes: 65c8a9b6626de83365865dea6fff1749466a36aa
 - http://autobuild.buildroot.org/results/7a5ba516cde536e103669a0422d336dd8a3b1dbc

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/inih/inih.hash | 2 +-
 package/inih/inih.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Arnout Vandecappelle April 7, 2024, 7:35 p.m. UTC | #1
On 07/04/2024 15:16, Fabrice Fontaine wrote:
> This bump will fix the following build failure with gcc 5 raised since
> bump to version 57 in commit 65c8a9b6626de83365865dea6fff1749466a36aa
> thanks to
> https://github.com/benhoyt/inih/commit/4e618f77d4bae216865c5abd972d99b1ba5031e2:
> 
> In file included from /home/buildroot/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/mips-linux-gnu/include/c++/5.3.0/cstdint:35:0,
>                   from ../cpp/INIReader.h:17,
>                   from ../cpp/INIReader.cpp:16:
> /home/buildroot/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/mips-linux-gnu/include/c++/5.3.0/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
>   #error This file requires compiler and library support for the \
>    ^
> 
> https://github.com/benhoyt/inih/releases/tag/r58
> 
> Fixes: 65c8a9b6626de83365865dea6fff1749466a36aa
>   - http://autobuild.buildroot.org/results/7a5ba516cde536e103669a0422d336dd8a3b1dbc
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/inih/inih.hash | 2 +-
>   package/inih/inih.mk   | 2 +-
>   2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/inih/inih.hash b/package/inih/inih.hash
> index 476b544ce6..f20d7ac0b6 100644
> --- a/package/inih/inih.hash
> +++ b/package/inih/inih.hash
> @@ -1,3 +1,3 @@
>   # Locally computed
> -sha256  f03f98ca35c3adb56b2358573c8d3eda319ccd5287243d691e724b7eafa970b3  inih-57.tar.gz
> +sha256  e79216260d5dffe809bda840be48ab0eec7737b2bb9f02d2275c1b46344ea7b7  inih-58.tar.gz
>   sha256  9ae3b39e83e9158e44b67733baa3bb2d84e80efdcfb14a5820210a42c7abdf7f  LICENSE.txt
> diff --git a/package/inih/inih.mk b/package/inih/inih.mk
> index 93032f1ed5..80cde0942b 100644
> --- a/package/inih/inih.mk
> +++ b/package/inih/inih.mk
> @@ -4,7 +4,7 @@
>   #
>   ################################################################################
>   
> -INIH_VERSION = 57
> +INIH_VERSION = 58
>   INIH_SITE = $(call github,benhoyt,inih,r$(INIH_VERSION))
>   INIH_INSTALL_STAGING = YES
>   INIH_LICENSE = BSD-3-Clause
diff mbox series

Patch

diff --git a/package/inih/inih.hash b/package/inih/inih.hash
index 476b544ce6..f20d7ac0b6 100644
--- a/package/inih/inih.hash
+++ b/package/inih/inih.hash
@@ -1,3 +1,3 @@ 
 # Locally computed
-sha256  f03f98ca35c3adb56b2358573c8d3eda319ccd5287243d691e724b7eafa970b3  inih-57.tar.gz
+sha256  e79216260d5dffe809bda840be48ab0eec7737b2bb9f02d2275c1b46344ea7b7  inih-58.tar.gz
 sha256  9ae3b39e83e9158e44b67733baa3bb2d84e80efdcfb14a5820210a42c7abdf7f  LICENSE.txt
diff --git a/package/inih/inih.mk b/package/inih/inih.mk
index 93032f1ed5..80cde0942b 100644
--- a/package/inih/inih.mk
+++ b/package/inih/inih.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-INIH_VERSION = 57
+INIH_VERSION = 58
 INIH_SITE = $(call github,benhoyt,inih,r$(INIH_VERSION))
 INIH_INSTALL_STAGING = YES
 INIH_LICENSE = BSD-3-Clause