diff mbox series

[1/1] package/whois: add libxcrypt optional dependency

Message ID 20240407121342.892419-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/whois: add libxcrypt optional dependency | expand

Commit Message

Fabrice Fontaine April 7, 2024, 12:13 p.m. UTC
Fix the following build failure raised since bump of glibc to version
2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:

/home/autobuild/autobuild/instance-12/output-1/host/lib/gcc/riscv32-buildroot-linux-gnu/12.3.0/../../../../riscv32-buildroot-linux-gnu/bin/ld: cannot find -lcrypt: No such file or directory

Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
 - http://autobuild.buildroot.org/results/b0aaffaf951725186ae078ce101edb24c963c6a3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/whois/Config.in | 1 +
 package/whois/whois.mk  | 1 +
 2 files changed, 2 insertions(+)

Comments

Yann E. MORIN April 7, 2024, 12:19 p.m. UTC | #1
Fabrice, All,

On 2024-04-07 14:13 +0200, Fabrice Fontaine spake thusly:
> Fix the following build failure raised since bump of glibc to version
> 2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:
> 
> /home/autobuild/autobuild/instance-12/output-1/host/lib/gcc/riscv32-buildroot-linux-gnu/12.3.0/../../../../riscv32-buildroot-linux-gnu/bin/ld: cannot find -lcrypt: No such file or directory
> 
> Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
>  - http://autobuild.buildroot.org/results/b0aaffaf951725186ae078ce101edb24c963c6a3
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/whois/Config.in | 1 +
>  package/whois/whois.mk  | 1 +
>  2 files changed, 2 insertions(+)
> 
> diff --git a/package/whois/Config.in b/package/whois/Config.in
> index d2a030282b..19c22b5583 100644
> --- a/package/whois/Config.in
> +++ b/package/whois/Config.in
> @@ -1,6 +1,7 @@
>  config BR2_PACKAGE_WHOIS
>  	bool "whois"
>  	depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
> +	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
>  	help
>  	  Improved whois client.
>  
> diff --git a/package/whois/whois.mk b/package/whois/whois.mk
> index 5a85bea358..e98add4e6a 100644
> --- a/package/whois/whois.mk
> +++ b/package/whois/whois.mk
> @@ -10,6 +10,7 @@ WHOIS_SOURCE = whois_$(WHOIS_VERSION).tar.xz
>  WHOIS_DEPENDENCIES = \
>  	host-pkgconf \
>  	$(if $(BR2_PACKAGE_LIBIDN2),libidn2) \
> +	$(if $(BR2_PACKAGE_LIBXCRYPT),libxcrypt) \
>  	$(TARGET_NLS_DEPENDENCIES)
>  WHOIS_MAKE_ENV = $(TARGET_MAKE_ENV)
>  WHOIS_MAKE_OPTS = CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
> -- 
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/whois/Config.in b/package/whois/Config.in
index d2a030282b..19c22b5583 100644
--- a/package/whois/Config.in
+++ b/package/whois/Config.in
@@ -1,6 +1,7 @@ 
 config BR2_PACKAGE_WHOIS
 	bool "whois"
 	depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  Improved whois client.
 
diff --git a/package/whois/whois.mk b/package/whois/whois.mk
index 5a85bea358..e98add4e6a 100644
--- a/package/whois/whois.mk
+++ b/package/whois/whois.mk
@@ -10,6 +10,7 @@  WHOIS_SOURCE = whois_$(WHOIS_VERSION).tar.xz
 WHOIS_DEPENDENCIES = \
 	host-pkgconf \
 	$(if $(BR2_PACKAGE_LIBIDN2),libidn2) \
+	$(if $(BR2_PACKAGE_LIBXCRYPT),libxcrypt) \
 	$(TARGET_NLS_DEPENDENCIES)
 WHOIS_MAKE_ENV = $(TARGET_MAKE_ENV)
 WHOIS_MAKE_OPTS = CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \