diff mbox series

[1/1] package/libcli: add libxcrypt optional dependency

Message ID 20240407094935.562389-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/libcli: add libxcrypt optional dependency | expand

Commit Message

Fabrice Fontaine April 7, 2024, 9:49 a.m. UTC
Fix the following build failure raised since bump of glibc to version
2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:

/home/autobuild/autobuild/instance-10/output-1/host/lib/gcc/nios2-buildroot-linux-gnu/12.3.0/../../../../nios2-buildroot-linux-gnu/bin/ld: cannot find -lcrypt: No such file or directory

Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
 - http://autobuild.buildroot.org/results/3a5cc2a90d58f39a6c9f27ad87e0d54e705f0c84

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libcli/Config.in | 1 +
 package/libcli/libcli.mk | 4 ++++
 2 files changed, 5 insertions(+)

Comments

Yann E. MORIN April 7, 2024, 12:19 p.m. UTC | #1
Fabrice, All,

On 2024-04-07 11:49 +0200, Fabrice Fontaine spake thusly:
> Fix the following build failure raised since bump of glibc to version
> 2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:
> 
> /home/autobuild/autobuild/instance-10/output-1/host/lib/gcc/nios2-buildroot-linux-gnu/12.3.0/../../../../nios2-buildroot-linux-gnu/bin/ld: cannot find -lcrypt: No such file or directory
> 
> Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
>  - http://autobuild.buildroot.org/results/3a5cc2a90d58f39a6c9f27ad87e0d54e705f0c84
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/libcli/Config.in | 1 +
>  package/libcli/libcli.mk | 4 ++++
>  2 files changed, 5 insertions(+)
> 
> diff --git a/package/libcli/Config.in b/package/libcli/Config.in
> index b2829cad3f..a5a8872d41 100644
> --- a/package/libcli/Config.in
> +++ b/package/libcli/Config.in
> @@ -1,5 +1,6 @@
>  config BR2_PACKAGE_LIBCLI
>  	bool "libcli"
> +	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
>  	help
>  	  Libcli provides a shared library for including a Cisco-like
>  	  command-line interface into other software. It's a telnet
> diff --git a/package/libcli/libcli.mk b/package/libcli/libcli.mk
> index a18daa911c..f3f68f780a 100644
> --- a/package/libcli/libcli.mk
> +++ b/package/libcli/libcli.mk
> @@ -26,6 +26,10 @@ ifeq ($(BR2_STATIC_LIBS),y)
>  LIBCLI_MAKE_ARGS += DYNAMIC_LIB=
>  endif
>  
> +ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
> +LIBCLI_DEPENDENCIES += libxcrypt
> +endif
> +
>  define LIBCLI_BUILD_CMDS
>  	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
>  		$(LIBCLI_MAKE_ARGS)
> -- 
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/libcli/Config.in b/package/libcli/Config.in
index b2829cad3f..a5a8872d41 100644
--- a/package/libcli/Config.in
+++ b/package/libcli/Config.in
@@ -1,5 +1,6 @@ 
 config BR2_PACKAGE_LIBCLI
 	bool "libcli"
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	help
 	  Libcli provides a shared library for including a Cisco-like
 	  command-line interface into other software. It's a telnet
diff --git a/package/libcli/libcli.mk b/package/libcli/libcli.mk
index a18daa911c..f3f68f780a 100644
--- a/package/libcli/libcli.mk
+++ b/package/libcli/libcli.mk
@@ -26,6 +26,10 @@  ifeq ($(BR2_STATIC_LIBS),y)
 LIBCLI_MAKE_ARGS += DYNAMIC_LIB=
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
+LIBCLI_DEPENDENCIES += libxcrypt
+endif
+
 define LIBCLI_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
 		$(LIBCLI_MAKE_ARGS)