diff mbox series

[1/1] package/hiawatha: add libxcrypt optional dependency

Message ID 20240404211821.1985923-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/hiawatha: add libxcrypt optional dependency | expand

Commit Message

Fabrice Fontaine April 4, 2024, 9:18 p.m. UTC
Fix the following build failure raised since bump of glibc to version
2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:

/home/autobuild/autobuild/instance-13/output-1/host/lib/gcc/mips-buildroot-linux-gnu/11.4.0/../../../../mips-buildroot-linux-gnu/bin/ld: CMakeFiles/hiawatha.dir/src/httpauth.c.o: in function `basic_http_authentication':
/home/autobuild/autobuild/instance-13/output-1/build/hiawatha-11.2/src/httpauth.c:334:(.text+0x614): undefined reference to `crypt'

Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
 - http://autobuild.buildroot.org/results/8054bd47edf613a12b09a9958f78abd5f355f17b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/hiawatha/Config.in   | 1 +
 package/hiawatha/hiawatha.mk | 4 ++++
 2 files changed, 5 insertions(+)

Comments

Yann E. MORIN April 7, 2024, 8:50 a.m. UTC | #1
Fabrice, All,

On 2024-04-04 23:18 +0200, Fabrice Fontaine spake thusly:
> Fix the following build failure raised since bump of glibc to version
> 2.39 in commit b5680f53d60acf8ff6010082f873438a39bd5d97:
> 
> /home/autobuild/autobuild/instance-13/output-1/host/lib/gcc/mips-buildroot-linux-gnu/11.4.0/../../../../mips-buildroot-linux-gnu/bin/ld: CMakeFiles/hiawatha.dir/src/httpauth.c.o: in function `basic_http_authentication':
> /home/autobuild/autobuild/instance-13/output-1/build/hiawatha-11.2/src/httpauth.c:334:(.text+0x614): undefined reference to `crypt'
> 
> Fixes: b5680f53d60acf8ff6010082f873438a39bd5d97
>  - http://autobuild.buildroot.org/results/8054bd47edf613a12b09a9958f78abd5f355f17b
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/hiawatha/Config.in   | 1 +
>  package/hiawatha/hiawatha.mk | 4 ++++
>  2 files changed, 5 insertions(+)
> 
> diff --git a/package/hiawatha/Config.in b/package/hiawatha/Config.in
> index 4b1a3ca86c..0c35734c34 100644
> --- a/package/hiawatha/Config.in
> +++ b/package/hiawatha/Config.in
> @@ -10,6 +10,7 @@ config BR2_PACKAGE_HIAWATHA
>  	depends on BR2_TOOLCHAIN_HAS_SYNC_4 # __sync_*_4 intrisics
>  	depends on BR2_TOOLCHAIN_HAS_THREADS
>  	depends on !BR2_STATIC_LIBS
> +	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
>  	select BR2_PACKAGE_ZLIB
>  	help
>  	  Hiawatha is a webserver for Unix and has been built with
> diff --git a/package/hiawatha/hiawatha.mk b/package/hiawatha/hiawatha.mk
> index 2ba8efb2fe..3e9cf2571b 100644
> --- a/package/hiawatha/hiawatha.mk
> +++ b/package/hiawatha/hiawatha.mk
> @@ -47,6 +47,10 @@ else
>  HIAWATHA_CONF_OPTS += -DENABLE_TLS=OFF
>  endif
>  
> +ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
> +HIAWATHA_DEPENDENCIES += libxcrypt
> +endif
> +
>  ifeq ($(BR2_PACKAGE_LIBXSLT),y)
>  HIAWATHA_CONF_OPTS += -DENABLE_XSLT=ON
>  HIAWATHA_DEPENDENCIES += libxslt
> -- 
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/hiawatha/Config.in b/package/hiawatha/Config.in
index 4b1a3ca86c..0c35734c34 100644
--- a/package/hiawatha/Config.in
+++ b/package/hiawatha/Config.in
@@ -10,6 +10,7 @@  config BR2_PACKAGE_HIAWATHA
 	depends on BR2_TOOLCHAIN_HAS_SYNC_4 # __sync_*_4 intrisics
 	depends on BR2_TOOLCHAIN_HAS_THREADS
 	depends on !BR2_STATIC_LIBS
+	select BR2_PACKAGE_LIBXCRYPT if BR2_TOOLCHAIN_USES_GLIBC
 	select BR2_PACKAGE_ZLIB
 	help
 	  Hiawatha is a webserver for Unix and has been built with
diff --git a/package/hiawatha/hiawatha.mk b/package/hiawatha/hiawatha.mk
index 2ba8efb2fe..3e9cf2571b 100644
--- a/package/hiawatha/hiawatha.mk
+++ b/package/hiawatha/hiawatha.mk
@@ -47,6 +47,10 @@  else
 HIAWATHA_CONF_OPTS += -DENABLE_TLS=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXCRYPT),y)
+HIAWATHA_DEPENDENCIES += libxcrypt
+endif
+
 ifeq ($(BR2_PACKAGE_LIBXSLT),y)
 HIAWATHA_CONF_OPTS += -DENABLE_XSLT=ON
 HIAWATHA_DEPENDENCIES += libxslt