diff mbox series

[v11,14/17] boot/uboot: remove BR2_TARGET_UBOOT_NEEDS_TI_K3_DM option

Message ID 20240403195403.1359007-15-romain.naour@smile.fr
State Superseded
Headers show
Series Add support for AM62x-SK HS-FS devices | expand

Commit Message

Romain Naour April 3, 2024, 7:53 p.m. UTC
Previoulsy (without binman), when a TI K3 SoC using Combined binary
with a split firmware boot method was used (am62ax or am62x) [1], the
user had to select BR2_TARGET_UBOOT_NEEDS_TI_K3_DM in the defconfig
to provide Device Manager firmware provided by ti-k3-boot-firmware.

With binman, this option is no longer necessary since
ti-k3-boot-firmware package is already in the u-boot dependency and the
path to DM and SYSFW binaries are provided by BINMAN_INDIRS.

We are going to remove ti-k3-image-gen, so binman is now mandatory on
all TI K3 SoCs.

[1] https://gitlab.com/buildroot.org/buildroot/-/commit/52ce606c05ee3ac869f8087292bc3dbb0d25b79b

Signed-off-by: Romain Naour <romain.naour@smile.fr>
---
 Config.in.legacy     |  6 ++++++
 boot/uboot/Config.in | 19 -------------------
 boot/uboot/uboot.mk  |  6 ------
 3 files changed, 6 insertions(+), 25 deletions(-)
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index d00196e08b..7117f8f528 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -146,6 +146,12 @@  endif
 
 comment "Legacy options removed in 2024.05"
 
+config BR2_TARGET_UBOOT_NEEDS_TI_K3_DM
+	bool "u-boot TI K3 DM option has been removed."
+	select BR2_LEGACY
+	help
+	  The TI K3 Device Manager handled by u-boot binman tool.
+
 config BR2_PACKAGE_FLUTTER_GALLERY
 	bool "flutter-gallery removed"
 	select BR2_LEGACY
diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index 2dc20e4770..57c41f6458 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -240,25 +240,6 @@  config BR2_TARGET_UBOOT_NEEDS_OPTEE_TEE
 	  U-Boot, and that the TEE variable pointing to OPTEE's
 	  tee.elf, is passed during the Buildroot build.
 
-config BR2_TARGET_UBOOT_NEEDS_TI_K3_DM
-	bool "U-Boot needs TI K3 Device Manager (DM)"
-	depends on BR2_TARGET_TI_K3_IMAGE_GEN
-	# We use the SoC selection defined for the ti-k3 package
-	depends on BR2_PACKAGE_TI_K3
-	depends on BR2_PACKAGE_TI_K3_SOC_AM62AX || BR2_PACKAGE_TI_K3_SOC_AM62X
-	help
-	  Some TI K3 devices need the Device Manager (DM) firmware to
-	  be available for the U-Boot build.
-
-if BR2_TARGET_UBOOT_NEEDS_TI_K3_DM
-
-config BR2_TARGET_UBOOT_TI_K3_DM_SOCNAME
-	string
-	default "am62axx" if BR2_PACKAGE_TI_K3_SOC_AM62AX
-	default "am62xx"  if BR2_PACKAGE_TI_K3_SOC_AM62X
-
-endif
-
 config BR2_TARGET_UBOOT_NEEDS_OPENSBI
 	bool "U-Boot needs OpenSBI"
 	depends on BR2_TARGET_OPENSBI
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index be366e7c31..26deda8402 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -186,12 +186,6 @@  UBOOT_DEPENDENCIES += optee-os
 UBOOT_MAKE_OPTS += TEE=$(BINARIES_DIR)/tee.elf
 endif
 
-ifeq ($(BR2_TARGET_UBOOT_NEEDS_TI_K3_DM),y)
-UBOOT_TI_K3_DM_SOCNAME = $(call qstrip,$(BR2_TARGET_UBOOT_TI_K3_DM_SOCNAME))
-UBOOT_DEPENDENCIES += ti-k3-boot-firmware
-UBOOT_MAKE_OPTS += DM=$(BINARIES_DIR)/ti-dm/$(UBOOT_TI_K3_DM_SOCNAME)/ipc_echo_testb_mcu1_0_release_strip.xer5f
-endif
-
 ifeq ($(BR2_TARGET_UBOOT_NEEDS_OPENSBI),y)
 UBOOT_DEPENDENCIES += opensbi
 UBOOT_MAKE_OPTS += OPENSBI=$(BINARIES_DIR)/fw_dynamic.bin