diff mbox series

[1/2] package/graphene: new package

Message ID 20240403084807.512825-1-francois.perrad@gadz.org
State New
Headers show
Series [1/2] package/graphene: new package | expand

Commit Message

Francois Perrad April 3, 2024, 8:48 a.m. UTC
a dependency for gtk4

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 DEVELOPERS                     |  1 +
 package/Config.in              |  1 +
 package/graphene/Config.in     |  6 +++++
 package/graphene/graphene.hash |  3 +++
 package/graphene/graphene.mk   | 44 ++++++++++++++++++++++++++++++++++
 5 files changed, 55 insertions(+)
 create mode 100644 package/graphene/Config.in
 create mode 100644 package/graphene/graphene.hash
 create mode 100644 package/graphene/graphene.mk
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index f6fc30137..f4b3d4627 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1120,6 +1120,7 @@  F:	package/copas/
 F:	package/coxpcall/
 F:	package/dado/
 F:	package/ficl/
+F:	package/graphene/
 F:	package/janet/
 F:	package/libtomcrypt/
 F:	package/libtommath/
diff --git a/package/Config.in b/package/Config.in
index 33039331f..9d659320b 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1640,6 +1640,7 @@  menu "Graphics"
 	source "package/giblib/Config.in"
 	source "package/giflib/Config.in"
 	source "package/granite/Config.in"
+	source "package/graphene/Config.in"
 	source "package/graphite2/Config.in"
 	source "package/gtkmm3/Config.in"
 	source "package/gtksourceview/Config.in"
diff --git a/package/graphene/Config.in b/package/graphene/Config.in
new file mode 100644
index 000000000..60f6073a1
--- /dev/null
+++ b/package/graphene/Config.in
@@ -0,0 +1,6 @@ 
+config BR2_PACKAGE_GRAPHENE
+	bool "graphene"
+	help
+	  A thin layer of types for graphic libraries.
+
+	  https://ebassi.github.io/graphene/
diff --git a/package/graphene/graphene.hash b/package/graphene/graphene.hash
new file mode 100644
index 000000000..7d2b56945
--- /dev/null
+++ b/package/graphene/graphene.hash
@@ -0,0 +1,3 @@ 
+# Locally calculated
+sha256  922dc109d2dc5dc56617a29bd716c79dd84db31721a8493a13a5f79109a4a4ed  graphene-1.10.8.tar.gz
+sha256  cfd9fd7b2be592d2c0910d32dc1d8910c08dc0670b1d9ce417a82fa9eb788df9  LICENSE.txt
diff --git a/package/graphene/graphene.mk b/package/graphene/graphene.mk
new file mode 100644
index 000000000..efdae9140
--- /dev/null
+++ b/package/graphene/graphene.mk
@@ -0,0 +1,44 @@ 
+################################################################################
+#
+# graphene
+#
+################################################################################
+
+GRAPHENE_VERSION = 1.10.8
+GRAPHENE_SITE = $(call github,ebassi,graphene,$(GRAPHENE_VERSION))
+GRAPHENE_LICENSE = MIT
+GRAPHENE_LICENSE_FILES = LICENSE.txt
+GRAPHENE_INSTALL_STAGING = YES
+
+GRAPHENE_CONF_OPTS = \
+	-Dtests=false \
+	-Dinstalled_tests=false \
+	-Dgtk_doc=false
+
+ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
+GRAPHENE_CONF_OPTS += -Dgobject_types=true
+GRAPHENE_DEPENDENCIES += libglib2
+else
+GRAPHENE_CONF_OPTS += -Dgobject_types=false
+endif
+
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+GRAPHENE_CONF_OPTS += -Dintrospection=enabled
+GRAPHENE_DEPENDENCIES += gobject-introspection
+else
+GRAPHENE_CONF_OPTS += -Dintrospection=disabled
+endif
+
+ifeq ($(BR2_X86_CPU_HAS_SSE2),y)
+GRAPHENE_CONF_OPTS += -Dsse2=true
+else
+GRAPHENE_CONF_OPTS += -Dsse2=false
+endif
+
+ifeq ($(BR2_ARM_CPU_HAS_NEON),y)
+GRAPHENE_CONF_OPTS += -Darm_neon=true
+else
+GRAPHENE_CONF_OPTS += -Darm_neon=false
+endif
+
+$(eval $(meson-package))