diff mbox series

package/esp-hosted: bump version to 2024-04-01

Message ID 20240401152312.72881-1-giulio.benetti@benettiengineering.com
State New
Headers show
Series package/esp-hosted: bump version to 2024-04-01 | expand

Commit Message

Giulio Benetti April 1, 2024, 3:23 p.m. UTC
Add support for Linux 6.9

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 ..._ng-fix-build-failure-on-Linux-6.9.0.patch | 37 +++++++++++++++++++
 package/esp-hosted/esp-hosted.hash            |  2 +-
 package/esp-hosted/esp-hosted.mk              |  2 +-
 3 files changed, 39 insertions(+), 2 deletions(-)
 create mode 100644 package/esp-hosted/0001-esp_hosted_ng-fix-build-failure-on-Linux-6.9.0.patch
diff mbox series

Patch

diff --git a/package/esp-hosted/0001-esp_hosted_ng-fix-build-failure-on-Linux-6.9.0.patch b/package/esp-hosted/0001-esp_hosted_ng-fix-build-failure-on-Linux-6.9.0.patch
new file mode 100644
index 0000000000..21e8730d37
--- /dev/null
+++ b/package/esp-hosted/0001-esp_hosted_ng-fix-build-failure-on-Linux-6.9.0.patch
@@ -0,0 +1,37 @@ 
+From 1cd8671eb64a1278466e7a9c90ceca1be0f8c0d5 Mon Sep 17 00:00:00 2001
+From: Giulio Benetti <giulio.benetti@benettiengineering.com>
+Date: Mon, 1 Apr 2024 17:15:19 +0200
+Subject: [PATCH] esp_hosted_ng: fix build failure on Linux 6.9.0
+
+With Linux commit:
+https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=620d269f29a569ba37419cc03cf1da2d55f6252a
+spi_master compatibility has gone, so let's redefine missing needed
+macros spi_master and spi_master_put() locally if Linux version is >=
+6.9.0.
+
+Upstream: https://github.com/espressif/esp-hosted/pull/358
+
+Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
+---
+ esp_hosted_ng/host/spi/esp_spi.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/esp_hosted_ng/host/spi/esp_spi.c b/esp_hosted_ng/host/spi/esp_spi.c
+index d0bd513bd6..9817056b2d 100644
+--- a/esp_hosted_ng/host/spi/esp_spi.c
++++ b/esp_hosted_ng/host/spi/esp_spi.c
+@@ -378,6 +378,11 @@ static int __spi_controller_match(struct device *dev, const void *data)
+ 	return ctlr->bus_num == *bus_num;
+ }
+ 
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(6, 9, 0))
++#define spi_master			spi_controller
++#define spi_master_put(_ctlr)		spi_controller_put(_ctlr)
++#endif
++
+ static struct spi_controller *spi_busnum_to_master(u16 bus_num)
+ {
+ 	struct platform_device *pdev = NULL;
+-- 
+2.34.1
+
diff --git a/package/esp-hosted/esp-hosted.hash b/package/esp-hosted/esp-hosted.hash
index ff0839076e..d449f5030e 100644
--- a/package/esp-hosted/esp-hosted.hash
+++ b/package/esp-hosted/esp-hosted.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  1c4df08132d5204a01adc2797e8f6f6d7ff945609b288cfe2dc2ea50789e8af4  esp-hosted-6a25417fc880fd744b3b0d93c11659c3e7d86384.tar.gz
+sha256  8f25c01522fdcb2003ffbfcc0ccf4981f27bddc8080ba978e33590d56f5ae20b  esp-hosted-669fd9cd1892bb8b364701968d5f06225346eea9.tar.gz
 sha256  ed57d96d27be775b22f9571d3724ef84e0d0b8f24b805ec7f87a32189de19a9c  LICENSE
diff --git a/package/esp-hosted/esp-hosted.mk b/package/esp-hosted/esp-hosted.mk
index cc61e39b36..520ad5dc8c 100644
--- a/package/esp-hosted/esp-hosted.mk
+++ b/package/esp-hosted/esp-hosted.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-ESP_HOSTED_VERSION = 6a25417fc880fd744b3b0d93c11659c3e7d86384
+ESP_HOSTED_VERSION = 669fd9cd1892bb8b364701968d5f06225346eea9
 ESP_HOSTED_SITE = $(call github,espressif,esp-hosted,$(ESP_HOSTED_VERSION))
 ESP_HOSTED_DEPENDENCIES = linux
 ESP_HOSTED_LICENSE = GPL-2.0