diff mbox series

package/xvisor: use BR2_PYTHON3_HOST_DEPENDENCY to ensure python3 is available

Message ID 20240325122314.2119104-1-peter@korsgaard.com
State Accepted
Headers show
Series package/xvisor: use BR2_PYTHON3_HOST_DEPENDENCY to ensure python3 is available | expand

Commit Message

Peter Korsgaard March 25, 2024, 12:23 p.m. UTC
Commit 24e996d14d28d (package/xvisor: fix build without python interpreter)
added a dependency on host-python3 for the d2c.py script, but this script
does not use any non-standard python modules so we can instead use
BR2_PYTHON3_HOST_DEPENDENCY to only build host-python3 if the build host
does not have python3.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/xvisor/xvisor.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard March 25, 2024, 6:18 p.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Commit 24e996d14d28d (package/xvisor: fix build without python interpreter)
 > added a dependency on host-python3 for the d2c.py script, but this script
 > does not use any non-standard python modules so we can instead use
 > BR2_PYTHON3_HOST_DEPENDENCY to only build host-python3 if the build host
 > does not have python3.

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
Peter Korsgaard March 25, 2024, 10:18 p.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:
 >> Commit 24e996d14d28d (package/xvisor: fix build without python interpreter)
 >> added a dependency on host-python3 for the d2c.py script, but this script
 >> does not use any non-standard python modules so we can instead use
 >> BR2_PYTHON3_HOST_DEPENDENCY to only build host-python3 if the build host
 >> does not have python3.

 >> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

 > Committed, thanks.

Committed to 2024.02.x, 2023.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/xvisor/xvisor.mk b/package/xvisor/xvisor.mk
index 2a51706b55..c1b61270f1 100644
--- a/package/xvisor/xvisor.mk
+++ b/package/xvisor/xvisor.mk
@@ -11,7 +11,7 @@  XVISOR_LICENSE = GPL-2.0+
 XVISOR_LICENSE_FILES = COPYING
 XVISOR_INSTALL_IMAGES = YES
 XVISOR_INSTALL_TARGET = NO
-XVISOR_DEPENDENCIES = host-bison host-dtc host-flex host-python3
+XVISOR_DEPENDENCIES = host-bison host-dtc host-flex $(BR2_PYTHON3_HOST_DEPENDENCY)
 
 XVISOR_MAKE_TARGETS = all