diff mbox series

[1/1] package/domoticz: bump to version 2024.4

Message ID 20240324211700.729359-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/domoticz: bump to version 2024.4 | expand

Commit Message

Fabrice Fontaine March 24, 2024, 9:17 p.m. UTC
openzwave dependency is back since
https://github.com/domoticz/domoticz/commit/b0eadaa2ec6d6340df7eeba0e6e373b71ba393fc

https://github.com/domoticz/domoticz/blob/2024.4/History.txt

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/domoticz/domoticz.hash |  2 +-
 package/domoticz/domoticz.mk   | 12 +++++++++++-
 2 files changed, 12 insertions(+), 2 deletions(-)

Comments

Arnout Vandecappelle March 27, 2024, 10:06 p.m. UTC | #1
On 24/03/2024 22:17, Fabrice Fontaine wrote:
> openzwave dependency is back since
> https://github.com/domoticz/domoticz/commit/b0eadaa2ec6d6340df7eeba0e6e373b71ba393fc
> 
> https://github.com/domoticz/domoticz/blob/2024.4/History.txt
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/domoticz/domoticz.hash |  2 +-
>   package/domoticz/domoticz.mk   | 12 +++++++++++-
>   2 files changed, 12 insertions(+), 2 deletions(-)
> 
> diff --git a/package/domoticz/domoticz.hash b/package/domoticz/domoticz.hash
> index 546177332e..ae86a67b79 100644
> --- a/package/domoticz/domoticz.hash
> +++ b/package/domoticz/domoticz.hash
> @@ -1,3 +1,3 @@
>   # Locally computed:
> -sha256  9effa792f856d8d9036c53b9ae500ee3bffa1488addf9d6f1fe4bf960f73f740  domoticz-2024.1.tar.gz
> +sha256  d87113d7cacd0b52b9126fcc1ef24e140a4f7042d5bc6262e86e4b4752f5cf38  domoticz-2024.4.tar.gz
>   sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  License.txt
> diff --git a/package/domoticz/domoticz.mk b/package/domoticz/domoticz.mk
> index 88bad15427..95d3335adb 100644
> --- a/package/domoticz/domoticz.mk
> +++ b/package/domoticz/domoticz.mk
> @@ -4,7 +4,7 @@
>   #
>   ################################################################################
>   
> -DOMOTICZ_VERSION = 2024.1
> +DOMOTICZ_VERSION = 2024.4
>   DOMOTICZ_SITE = $(call github,domoticz,domoticz,$(DOMOTICZ_VERSION))
>   DOMOTICZ_LICENSE = GPL-3.0
>   DOMOTICZ_LICENSE_FILES = License.txt
> @@ -51,6 +51,16 @@ else
>   DOMOTICZ_CONF_OPTS += -DWITH_LIBUSB=OFF
>   endif
>   
> +ifeq ($(BR2_PACKAGE_OPENZWAVE),y)
> +DOMOTICZ_DEPENDENCIES += openzwave
> +
> +# Due to the dependency on mosquitto, domoticz depends on
> +# !BR2_STATIC_LIBS so set USE_STATIC_OPENZWAVE to OFF otherwise
> +# domoticz will not find the openzwave library as it searches by
> +# default a static library.
> +DOMOTICZ_CONF_OPTS += -DUSE_STATIC_OPENZWAVE=OFF
> +endif
> +
>   ifeq ($(BR2_PACKAGE_PYTHON3),y)
>   DOMOTICZ_DEPENDENCIES += python3
>   DOMOTICZ_CONF_OPTS += -DUSE_PYTHON=ON
diff mbox series

Patch

diff --git a/package/domoticz/domoticz.hash b/package/domoticz/domoticz.hash
index 546177332e..ae86a67b79 100644
--- a/package/domoticz/domoticz.hash
+++ b/package/domoticz/domoticz.hash
@@ -1,3 +1,3 @@ 
 # Locally computed:
-sha256  9effa792f856d8d9036c53b9ae500ee3bffa1488addf9d6f1fe4bf960f73f740  domoticz-2024.1.tar.gz
+sha256  d87113d7cacd0b52b9126fcc1ef24e140a4f7042d5bc6262e86e4b4752f5cf38  domoticz-2024.4.tar.gz
 sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  License.txt
diff --git a/package/domoticz/domoticz.mk b/package/domoticz/domoticz.mk
index 88bad15427..95d3335adb 100644
--- a/package/domoticz/domoticz.mk
+++ b/package/domoticz/domoticz.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-DOMOTICZ_VERSION = 2024.1
+DOMOTICZ_VERSION = 2024.4
 DOMOTICZ_SITE = $(call github,domoticz,domoticz,$(DOMOTICZ_VERSION))
 DOMOTICZ_LICENSE = GPL-3.0
 DOMOTICZ_LICENSE_FILES = License.txt
@@ -51,6 +51,16 @@  else
 DOMOTICZ_CONF_OPTS += -DWITH_LIBUSB=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_OPENZWAVE),y)
+DOMOTICZ_DEPENDENCIES += openzwave
+
+# Due to the dependency on mosquitto, domoticz depends on
+# !BR2_STATIC_LIBS so set USE_STATIC_OPENZWAVE to OFF otherwise
+# domoticz will not find the openzwave library as it searches by
+# default a static library.
+DOMOTICZ_CONF_OPTS += -DUSE_STATIC_OPENZWAVE=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_PYTHON3),y)
 DOMOTICZ_DEPENDENCIES += python3
 DOMOTICZ_CONF_OPTS += -DUSE_PYTHON=ON