diff mbox series

[1/1] package/coreutils: bump version to 9.4

Message ID 20240324094549.1943918-1-nemaakhilesh@gmail.com
State Changes Requested
Headers show
Series [1/1] package/coreutils: bump version to 9.4 | expand

Commit Message

Akhilesh Nema March 24, 2024, 9:45 a.m. UTC
Changelog - https://github.com/coreutils/coreutils/blob/9530a14420fc1a267e90d45e8a0d710c3668382d/NEWS

Signed-off-by: Akhilesh Nema <nemaakhilesh@gmail.com>
---
$ cat coreutils.config
BR2_PACKAGE_COREUTILS=y
BR2_PACKAGE_COREUTILS_INDIVIDUAL_BINARIES=y

$ ./utils/test-pkg -k -c coreutils.config -p coreutils
                    bootlin-armv5-uclibc [1/6]: OK
                     bootlin-armv7-glibc [2/6]: OK
                   bootlin-armv7m-uclibc [3/6]: SKIPPED
                     bootlin-x86-64-musl [4/6]: OK
                      br-arm-full-static [5/6]: SKIPPED
                             arm-aarch64 [6/6]: OK
6 builds, 2 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed

./utils/check-package package/coreutils/*
211 lines processed
0 warnings generated

cp --version
cp (GNU coreutils) 9.4
Copyright (C) 2023 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <https://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Torbjorn Granlund, David MacKenzie, and Jim Meyering.

Signed-off-by: Akhilesh Nema <nemaakhilesh@gmail.com>
---
 package/coreutils/coreutils.hash | 2 +-
 package/coreutils/coreutils.mk   | 6 +++++-
 2 files changed, 6 insertions(+), 2 deletions(-)

Comments

Arnout Vandecappelle March 24, 2024, 2:55 p.m. UTC | #1
On 24/03/2024 10:45, Akhilesh Nema wrote:
> Changelog - https://github.com/coreutils/coreutils/blob/9530a14420fc1a267e90d45e8a0d710c3668382d/NEWS
> 
> Signed-off-by: Akhilesh Nema <nemaakhilesh@gmail.com>
> ---
> $ cat coreutils.config
> BR2_PACKAGE_COREUTILS=y
> BR2_PACKAGE_COREUTILS_INDIVIDUAL_BINARIES=y
> 
> $ ./utils/test-pkg -k -c coreutils.config -p coreutils
>                      bootlin-armv5-uclibc [1/6]: OK
>                       bootlin-armv7-glibc [2/6]: OK
>                     bootlin-armv7m-uclibc [3/6]: SKIPPED
>                       bootlin-x86-64-musl [4/6]: OK
>                        br-arm-full-static [5/6]: SKIPPED
>                               arm-aarch64 [6/6]: OK
> 6 builds, 2 skipped, 0 build failed, 0 legal-info failed, 0 show-info failed
> 
> ./utils/check-package package/coreutils/*
> 211 lines processed
> 0 warnings generated
> 
> cp --version
> cp (GNU coreutils) 9.4
> Copyright (C) 2023 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <https://gnu.org/licenses/gpl.html>.
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.
> 
> Written by Torbjorn Granlund, David MacKenzie, and Jim Meyering.
> 
> Signed-off-by: Akhilesh Nema <nemaakhilesh@gmail.com>
> ---
>   package/coreutils/coreutils.hash | 2 +-
>   package/coreutils/coreutils.mk   | 6 +++++-
>   2 files changed, 6 insertions(+), 2 deletions(-)
> 
> diff --git a/package/coreutils/coreutils.hash b/package/coreutils/coreutils.hash
> index 7df1048afa..6304813e44 100644
> --- a/package/coreutils/coreutils.hash
> +++ b/package/coreutils/coreutils.hash
> @@ -1,4 +1,4 @@
>   # Locally calculated after checking pgp signature
> -sha256  adbcfcfe899235b71e8768dcf07cd532520b7f54f9a8064843f8d199a904bbaa  coreutils-9.3.tar.xz
> +sha256  ea613a4cf44612326e917201bbbcdfbd301de21ffc3b59b6e5c07e040b275e52  coreutils-9.4.tar.xz
>   # Locally computed
>   sha256  3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986  COPYING
> diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
> index e9cb7b67cb..ea6442f8f1 100644
> --- a/package/coreutils/coreutils.mk
> +++ b/package/coreutils/coreutils.mk
> @@ -4,7 +4,7 @@
>   #
>   ################################################################################
>   
> -COREUTILS_VERSION = 9.3
> +COREUTILS_VERSION = 9.4
>   COREUTILS_SITE = $(BR2_GNU_MIRROR)/coreutils
>   COREUTILS_SOURCE = coreutils-$(COREUTILS_VERSION).tar.xz
>   COREUTILS_LICENSE = GPL-3.0+
> @@ -14,6 +14,10 @@ COREUTILS_CPE_ID_VENDOR = gnu
>   COREUTILS_CONF_OPTS = --disable-rpath \
>   	$(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)
>   
> +ifneq ($(BR2_TIME_BITS_64),y)

  BR2_TIME_BITS_64 is not set on 64-bits platforms, but we probably don't want 
to disable year2038 on those platforms.

  I also notice now that on 32-bit platforms that always have 64-bit time (e.g. 
riscv32), it is only optionally set... Probably the BR2_TIME_BITS_64 option 
should be reworked a little. Perhaps there should be something like a 
BR2_TOOLCHAIN_HAS_TIME_BITS_64 that indicates when time_t is 64 bits?

  Regards,
  Arnout

> +COREUTILS_CONF_OPTS += --disable-year2038
> +endif
> +
>   ifeq ($(BR2_PACKAGE_COREUTILS_INDIVIDUAL_BINARIES),y)
>   COREUTILS_CONF_OPTS += --disable-single-binary
>   else
diff mbox series

Patch

diff --git a/package/coreutils/coreutils.hash b/package/coreutils/coreutils.hash
index 7df1048afa..6304813e44 100644
--- a/package/coreutils/coreutils.hash
+++ b/package/coreutils/coreutils.hash
@@ -1,4 +1,4 @@ 
 # Locally calculated after checking pgp signature
-sha256  adbcfcfe899235b71e8768dcf07cd532520b7f54f9a8064843f8d199a904bbaa  coreutils-9.3.tar.xz
+sha256  ea613a4cf44612326e917201bbbcdfbd301de21ffc3b59b6e5c07e040b275e52  coreutils-9.4.tar.xz
 # Locally computed
 sha256  3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986  COPYING
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index e9cb7b67cb..ea6442f8f1 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-COREUTILS_VERSION = 9.3
+COREUTILS_VERSION = 9.4
 COREUTILS_SITE = $(BR2_GNU_MIRROR)/coreutils
 COREUTILS_SOURCE = coreutils-$(COREUTILS_VERSION).tar.xz
 COREUTILS_LICENSE = GPL-3.0+
@@ -14,6 +14,10 @@  COREUTILS_CPE_ID_VENDOR = gnu
 COREUTILS_CONF_OPTS = --disable-rpath \
 	$(if $(BR2_TOOLCHAIN_USES_MUSL),--with-included-regex)
 
+ifneq ($(BR2_TIME_BITS_64),y)
+COREUTILS_CONF_OPTS += --disable-year2038
+endif
+
 ifeq ($(BR2_PACKAGE_COREUTILS_INDIVIDUAL_BINARIES),y)
 COREUTILS_CONF_OPTS += --disable-single-binary
 else