diff mbox series

[1/1] package/libdrm: disable tests

Message ID 20240322174941.475669-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/libdrm: disable tests | expand

Commit Message

Fabrice Fontaine March 22, 2024, 5:49 p.m. UTC
Disable tests to avoid the following build failure with amdgpu and gcc 5
if cunit is built before libdrm:

In file included from ../tests/amdgpu/shader_test_util.c:10:0:
../tests/amdgpu/shader_code.h:113:2: error: initializer element is not constant
  ps_##_ps##_shader_patchinfo_code_size_gfx##_n, \
  ^

tests can be disabled since
https://gitlab.freedesktop.org/mesa/drm/-/commit/46d1e99a5d291b22d86ac52710b079491beedff8

Fixes:
 - http://autobuild.buildroot.org/results/612aad1fa642993da36bbec6c16c9020ac283e34

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libdrm/libdrm.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Arnout Vandecappelle March 23, 2024, 8:33 p.m. UTC | #1
On 22/03/2024 18:49, Fabrice Fontaine wrote:
> Disable tests to avoid the following build failure with amdgpu and gcc 5
> if cunit is built before libdrm:
> 
> In file included from ../tests/amdgpu/shader_test_util.c:10:0:
> ../tests/amdgpu/shader_code.h:113:2: error: initializer element is not constant
>    ps_##_ps##_shader_patchinfo_code_size_gfx##_n, \
>    ^
> 
> tests can be disabled since
> https://gitlab.freedesktop.org/mesa/drm/-/commit/46d1e99a5d291b22d86ac52710b079491beedff8
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/612aad1fa642993da36bbec6c16c9020ac283e34
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/libdrm/libdrm.mk | 3 ++-
>   1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/libdrm/libdrm.mk b/package/libdrm/libdrm.mk
> index 61d1c24377..a04331c2da 100644
> --- a/package/libdrm/libdrm.mk
> +++ b/package/libdrm/libdrm.mk
> @@ -17,7 +17,8 @@ LIBDRM_DEPENDENCIES = \
>   
>   LIBDRM_CONF_OPTS = \
>   	-Dcairo-tests=disabled \
> -	-Dman-pages=disabled
> +	-Dman-pages=disabled \
> +	-Dtests=false
>   
>   ifeq ($(BR2_PACKAGE_LIBATOMIC_OPS),y)
>   LIBDRM_DEPENDENCIES += libatomic_ops
Peter Korsgaard March 25, 2024, 7:56 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Disable tests to avoid the following build failure with amdgpu and gcc 5
 > if cunit is built before libdrm:

 > In file included from ../tests/amdgpu/shader_test_util.c:10:0:
 > ../tests/amdgpu/shader_code.h:113:2: error: initializer element is not constant
 >   ps_##_ps##_shader_patchinfo_code_size_gfx##_n, \
 >   ^

 > tests can be disabled since
 > https://gitlab.freedesktop.org/mesa/drm/-/commit/46d1e99a5d291b22d86ac52710b079491beedff8

 > Fixes:
 >  - http://autobuild.buildroot.org/results/612aad1fa642993da36bbec6c16c9020ac283e34

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2024.02.x, 2023.02.x and 2023.11.x, thanks.
Peter Korsgaard March 26, 2024, 3:01 p.m. UTC | #3
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:
 >> Disable tests to avoid the following build failure with amdgpu and gcc 5
 >> if cunit is built before libdrm:

 >> In file included from ../tests/amdgpu/shader_test_util.c:10:0:
 >> ../tests/amdgpu/shader_code.h:113:2: error: initializer element is not constant
 >> ps_##_ps##_shader_patchinfo_code_size_gfx##_n, \
 >> ^

 >> tests can be disabled since
 >> https://gitlab.freedesktop.org/mesa/drm/-/commit/46d1e99a5d291b22d86ac52710b079491beedff8

 >> Fixes:
 >> - http://autobuild.buildroot.org/results/612aad1fa642993da36bbec6c16c9020ac283e34

 >> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

 > Committed to 2024.02.x, 2023.02.x and 2023.11.x, thanks.

Hmm, I think I was too fast here. The libdrm tests also include the
handy utilities like modetest and modeprint, so it is not great to
unconditionally disable them.

Maybe we should add a suboption for it? It is too late for 2024.02.1,
but I will revert the change for 2023.02.x and 2023.11.x so I can get
those released (and EOL'ed).
Bernd Kuhls March 26, 2024, 6:37 p.m. UTC | #4
Am Tue, 26 Mar 2024 16:01:40 +0100 schrieb Peter Korsgaard:

> Maybe we should add a suboption for it?

Hi Peter,

such an option already exists:
$ grep TESTS package/libdrm/Config.in 
config BR2_PACKAGE_LIBDRM_INSTALL_TESTS

To fix the problem with missing utils I sent this patch:
https://patchwork.ozlabs.org/project/buildroot/patch/
20240324174523.1770994-1-bernd@kuhls.net/

Regards, Bernd
diff mbox series

Patch

diff --git a/package/libdrm/libdrm.mk b/package/libdrm/libdrm.mk
index 61d1c24377..a04331c2da 100644
--- a/package/libdrm/libdrm.mk
+++ b/package/libdrm/libdrm.mk
@@ -17,7 +17,8 @@  LIBDRM_DEPENDENCIES = \
 
 LIBDRM_CONF_OPTS = \
 	-Dcairo-tests=disabled \
-	-Dman-pages=disabled
+	-Dman-pages=disabled \
+	-Dtests=false
 
 ifeq ($(BR2_PACKAGE_LIBATOMIC_OPS),y)
 LIBDRM_DEPENDENCIES += libatomic_ops