diff mbox series

[1/1] package/containerd: fix btrfs handling

Message ID 20240321211245.508853-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/containerd: fix btrfs handling | expand

Commit Message

Fabrice Fontaine March 21, 2024, 9:12 p.m. UTC
btrfs handling doesn't depend on btrfs-progs but on kernel >= 4.12 since
bump to version 1.7.7 in commit 79e01ef9506a6cdc4836912607dc594ae7b1999d
and
https://github.com/containerd/containerd/commit/024a748c092cbddde0918f2e93a646ce50116e11
resulting in the following build failure:

In file included from vendor/github.com/containerd/btrfs/v2/btrfs.go:21:0:
./btrfs.h:19:2: error: #error "Headers from kernel >= 4.12 are required on compilation time (not on run time)"
 #error "Headers from kernel >= 4.12 are required on compilation time (not on run time)"
  ^~~~~
In file included from vendor/github.com/containerd/btrfs/v2/btrfs.go:21:0:
./btrfs.h:22:10: fatal error: linux/btrfs_tree.h: No such file or directory
 #include <linux/btrfs_tree.h>
          ^~~~~~~~~~~~~~~~~~~~

Fixes: 79e01ef9506a6cdc4836912607dc594ae7b1999d
 - http://autobuild.buildroot.org/results/d6afeef47daae1783dcce3e2b6a0a16e3e5d5fbd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/containerd/Config.in     | 7 ++++---
 package/containerd/containerd.mk | 4 +---
 2 files changed, 5 insertions(+), 6 deletions(-)

Comments

Peter Korsgaard March 23, 2024, 12:45 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > btrfs handling doesn't depend on btrfs-progs but on kernel >= 4.12 since
 > bump to version 1.7.7 in commit 79e01ef9506a6cdc4836912607dc594ae7b1999d
 > and
 > https://github.com/containerd/containerd/commit/024a748c092cbddde0918f2e93a646ce50116e11
 > resulting in the following build failure:

 > In file included from vendor/github.com/containerd/btrfs/v2/btrfs.go:21:0:
 > ./btrfs.h:19:2: error: #error "Headers from kernel >= 4.12 are required on compilation time (not on run time)"
 >  #error "Headers from kernel >= 4.12 are required on compilation time (not on run time)"
 >   ^~~~~
 > In file included from vendor/github.com/containerd/btrfs/v2/btrfs.go:21:0:
 > ./btrfs.h:22:10: fatal error: linux/btrfs_tree.h: No such file or directory
 >  #include <linux/btrfs_tree.h>
 >           ^~~~~~~~~~~~~~~~~~~~

 > Fixes: 79e01ef9506a6cdc4836912607dc594ae7b1999d
 >  - http://autobuild.buildroot.org/results/d6afeef47daae1783dcce3e2b6a0a16e3e5d5fbd

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard March 25, 2024, 7:29 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > btrfs handling doesn't depend on btrfs-progs but on kernel >= 4.12 since
 > bump to version 1.7.7 in commit 79e01ef9506a6cdc4836912607dc594ae7b1999d
 > and
 > https://github.com/containerd/containerd/commit/024a748c092cbddde0918f2e93a646ce50116e11
 > resulting in the following build failure:

 > In file included from vendor/github.com/containerd/btrfs/v2/btrfs.go:21:0:
 > ./btrfs.h:19:2: error: #error "Headers from kernel >= 4.12 are required on compilation time (not on run time)"
 >  #error "Headers from kernel >= 4.12 are required on compilation time (not on run time)"
 >   ^~~~~
 > In file included from vendor/github.com/containerd/btrfs/v2/btrfs.go:21:0:
 > ./btrfs.h:22:10: fatal error: linux/btrfs_tree.h: No such file or directory
 >  #include <linux/btrfs_tree.h>
 >           ^~~~~~~~~~~~~~~~~~~~

 > Fixes: 79e01ef9506a6cdc4836912607dc594ae7b1999d
 >  - http://autobuild.buildroot.org/results/d6afeef47daae1783dcce3e2b6a0a16e3e5d5fbd

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2024.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/containerd/Config.in b/package/containerd/Config.in
index 12a53bc111..2dd04b109c 100644
--- a/package/containerd/Config.in
+++ b/package/containerd/Config.in
@@ -20,12 +20,13 @@  if BR2_PACKAGE_CONTAINERD
 
 config BR2_PACKAGE_CONTAINERD_DRIVER_BTRFS
 	bool "btrfs snapshot driver"
-	depends on BR2_USE_MMU # btrfs-progs
-	depends on BR2_TOOLCHAIN_HAS_THREADS # btrfs-progs
-	select BR2_PACKAGE_BTRFS_PROGS
+	depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_12
 	help
 	  Build the btrfs snapshot driver for containerd.
 
+comment "brtfs snapshot driver needs headers >= 4.12"
+	depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_12
+
 config BR2_PACKAGE_CONTAINERD_DRIVER_DEVMAPPER
 	bool "devmapper snapshot driver"
 	depends on BR2_TOOLCHAIN_HAS_THREADS # lvm2
diff --git a/package/containerd/containerd.mk b/package/containerd/containerd.mk
index 50c2965b87..9bf51c93ae 100644
--- a/package/containerd/containerd.mk
+++ b/package/containerd/containerd.mk
@@ -35,9 +35,7 @@  CONTAINERD_DEPENDENCIES += libseccomp host-pkgconf
 CONTAINERD_TAGS += seccomp
 endif
 
-ifeq ($(BR2_PACKAGE_CONTAINERD_DRIVER_BTRFS),y)
-CONTAINERD_DEPENDENCIES += btrfs-progs
-else
+ifneq ($(BR2_PACKAGE_CONTAINERD_DRIVER_BTRFS),y)
 CONTAINERD_TAGS += no_btrfs
 endif